Go Down

Topic: SOLVED Trying to program ATTINY85 with Arduino Uno, not communicating. (Read 3434 times) previous topic - next topic

Rat_Patrol

Apr 11, 2018, 06:37 pm Last Edit: Apr 11, 2018, 07:40 pm by Rat_Patrol Reason: solved, I'm an idiot.
I've done this before, but its not working now.

Using the guide from here and I'm getting this error:

Arduino: 1.8.3 (Windows 7), Board: "ATtiny, ATtiny85, 8 MHz (internal)"

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03
Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


I have downloaded blink onto the uno board, it works fine.

I triple checked my pinouts and pin locations.

What am I missing?


Rat_Patrol

DOH!

I still had this particular arduino wired for programming ATTINY's,  I must have put another sketch into it.

Re-uploaded ArduinoISP and it all works as it should. I knew it had to be something simple.

Thanks!

Go Up