Go Down

Topic: Connect ip cam to Arduino Yun and watch live video from iPhone (Read 11921 times) previous topic - next topic

federicofissore

If your yun is connected to your computer, you can upload YunSerialTerminal example, open serial monitor and get the same linux prompt you'd get with ssh

Nico91

I used this command on my OSX terminal an it works:      SSH -X root@arduino.local

Nico91

when i try to install i get this error :

root@Arduino:/mnt/sda1/arduino# opkg install fswebcam_20110717-1_ar71xx.ipk
Installing fswebcam (20110717-1) to root...
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for fswebcam:
*    libgd *
* opkg_install_cmd: Cannot install package fswebcam.

I installed all other.

lucad79

Hi

are you installing the ipk packages from the SD because of your Yun is not connected to Internet?
Otherwise it's a really better solution to let opkg download them (and resolve all the dependances) for you...

Nico91

I put all the file on my SD , next i connected the arduino using ssh with OSX terminal. Next i type the command "opkg install" for all the files.  All works fine but fswebcam no.

AllSystemGO

I don't think it's really important it should work without it.

Nico91

when i type last command i get this :

i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 640 x 480
i: Frames Per Second.: 5
i: Format............: MJPEG
ERROR opening V4L interface: No such file or directory
Init v4L2 failed !! exit fatal
i: init_VideoIn failed

Nico91

#22
Nov 15, 2013, 10:35 am Last Edit: Nov 15, 2013, 10:52 am by Nico91 Reason: 1
I didn't connected webcam Ahahahah!!!! thank youuu now it works fine!


Now how can i run this command from Arduino sketch?

AllSystemGO

No actually you need to go in the web console of the arduino and select the advance user. Go down in the advance menu and you'll see what does the openwrt starts, like WIFI, you can put the command in there and it will be executed when you boot the arduino.

Sorry for the general terms here as I don't have my arduino here and I just can't remember. If ever it doen't help I'll let you know exactly where to go tonight.

Nico91

#24
Nov 15, 2013, 03:37 pm Last Edit: Nov 15, 2013, 07:11 pm by Nico91 Reason: 1
The webcam works fine, but sometimes it freezes for a few seconds and then starts again. Is it normal? how can I solve it?

With Microsoft hd 3000 i get problem, but with Logitech c170 (VGA quality) it work very well. I think that the VGA is better than HD for speed.

AllSystemGO

For me using the HD-3000 I never had a problem yet. I use it to control my rc car and it works well. I'll give the logitech a try too just for fun.

Did you figure out where to put the command to make it start at bootup?

Nico91

Maybe my hd3000 have a problem itself.

Yes i put the command at boot up, it takes few second to configure.

Now i can develop my iphone app.

Thank you.

Go Up