Go Down

Topic: Arduino in OS X 10.9 Mavericks - Serial Port Issues (Read 144237 times) previous topic - next topic

eliasheuninck

Adam, thanks for the clear explanation, but sadly it didn't work for me :/
Maybe I've been tinkering too much with all kinds of settings and drivers.

spage

This procedure fixed my problem on Mac OS X 10.9.1 with Arduino 1.0.5 and an OSEPP Uno R3 Plus

I was brand new to Arduino and was of course very disappointed when I could not get the simple Blink sketch to load.

I searched for quite a while before coming across this post and even then it was with the aid of a colleague

Since this is going to be a problem for anyone with a recent Mac OS it would have been nicer if there was a more prominent way of alerting Mac users. 

Are Apple aware of the driver issue?  Is it an actual problem with the Apple driver or a problem with the way Arduino 1.0.5 is trying to access the driver?  I don't really like regressing the driver so it would be nice to know that someone, somewhere is working on a permanent fix for this...  Do we need to post somewhere else to get Arduino development to take a closer look?

This is the sort of problem that one associates with Windows rather than the Mac!

msaglam

Hi Adam,

Thank you! This worked for me too. However, I still struggled at first for a few hours due to a bad USB cable. I saw a similar post as well. So for anyone that this doesn't work, please make sure to try it with another USB cable before giving up.

timlong

This fix appears to have solved the problem for me, thanks a lot! Are mac going to generate a built in solution with an os update? A lot of people using arduino also use macs...
A solution is required asap - please. See https://discussions.apple.com/message/23717843#23717843

twollweber


However, I still struggled at first for a few hours due to a bad USB cable. I saw a similar post as well. So for anyone that this doesn't work, please make sure to try it with another USB cable before giving up.


Hi all,

I just want to back this post! A different cable made my day! Even though the first cable was new (it came with the Nano clone), a much longer old cable made the device available.

Cheers, Thorsten

Shiki225

#20
Mar 29, 2014, 12:09 am Last Edit: Mar 29, 2014, 01:14 am by Shiki225 Reason: 1
i did everything listed
Solution (as partially provided by the website above)
Type the following commands into the terminal:
   cd /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns
   sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled
   sudo touch /System/Library/Extensions

Restart your computer

Install the original FTDI Virtual Com Port drivers found here: http://www.ftdichip.com/Drivers/VCP.htm

Start Arduino and program as you always have.

but it does not work, I still get the same problem compiling. Am I installing the right driver? When I visit the link above I couldn't find a 10.9 version in http://www.ftdichip.com/Drivers/VCP.htm

I have both the D2XX and VCP Drivers installed, I have tried them individually installed at a time and it didnt work too.

hardest

Same problem, fix with original drivers worked perfectly. REBOOT required.

justPaulo


I was having problems writing to my Arduino Mega (1280) with Arduino 1.0.5 on a clean install of OSX 10.9 Mavericks.
...
Start Arduino and program as you always have.
..


Well it worked for me too, even with my old Arduino board based on a ATMEGA8 chip (2006).
Thanks and congrats for your post.

crankster

I thought I would report on how these great tips didn't work for me and the solution that did.
I have a multiwii se v2.5 board (crius copy)  with ftdi interface.
On my Mac, I reloaded the latest ftdi drivers (as described) and rebooted the mac.
I plug in the multiwii se board through the ftdi interface.
I open arduino.
All I kept getting was a list of bluetooth ports but no USB ports.
I then thought a little laterally and checked the actual chipset on the ftdi interface.
I was so obsessed with using the FTDI driver, I never considered that the usb/serial module might have been made by some one else. It uses a Prolific 2305 chip. I hopped over to
http://www.prolific.com.tw/US/ShowPr...id=229&pcid=41
downloaded the correct driver and IT WORKS!!!!!
So, for any mac people using this board and having difficulties getting a com port to show up on their mac under 10.9, , use this driver, NOT the FTDI driver mentioned above. See if that helps you too.

danpicko

I had the same issue with my 3D printer that runs off a Mega 2560.  Removing the Mavericks drivers and reinstalling the FTDI drivers worked a treat.

Just make sure to use the FTDIUSBSerialDriver_10_4_10_5_10_6_10_7 package inside the disk image.

This fix sorted it out for me.  Very happy - thanks a lot, saved me a lot of pain....  :D

malkindy

as of today the frustration continue as i am not able to access my arduino, all the posted suggestions to the problem i have tried but no luck :0 is this part of open source pains? i just fro not know what else i can try

svhovater

hi folks
Struggled with this for a bit - tried installing the FTDI drivers, as suggested, but no go. I've an UNO R2, and according to the Arduino specs,
The Uno differs from all preceding boards in that it does not use the FTDI USB-to-serial driver chip. Instead, it features the Atmega16U2 (Atmega8U2 up to version R2) programmed as a USB-to-serial converter.

So.. I had recently added a USB3 hub..  once I moved the usb from the hub to the mac, voila. I see the Uno serial port again!

cheers
Steve

anthonyr

Fixed my issues on OS X 10.9.3 with a Sparkfun Red Board. Thanks!

Geoffroy_docq

Hi all,

I had exactly the same issue mac os 10.9.3 : serial port not shown ...
After 2 hours of fight  i finally solved my problem.
I just replaced the usb cable !
Seems that the usb cable provide with the Arduino UNO was the issue.

Hope this can help

SaldivarEngineer

Unfortunately, that doesn't work on my Mac, I have Mavericks too and I've taken all day trying to get Arduino Uno with my code and nothing! I NOTICED that only when I've just had to install the IDE the serial port dv/tty. usbmodemfa341 appears, I mean it only works ONCE but when I try to record another code, it disappeared.

Mac OS 10.9.3
Java 7
FTDI installed

I'd thank any help?

Go Up