Go Down

Topic: Factory reset of HC-06 (Read 13337 times) previous topic - next topic

JoeWright

Hi, is it possible to factory reset the HC-06?

I experimented with setting a baud rate > 115200 (AT+BAUDA 460800).  Turns out that wasn't the smartest move as now I can't connect to it and gibberish comes out.

Any help gratefully received.
Thanks, Joe

int2str

From here:
http://robopoly.epfl.ch/files/content/sites/robopoly/files/Tutoriels/bluetooth/hc-05-at_command_set.pdf

Quote
Way 2: Step 1: Connect PIN3
4 to the power supply PIN.
Step 2: Supp
ly power to
module (the PIN34 is also supplied with hi
gh level since the PIN
34 is connected with
power supply PIN). Then
the module will enter to AT mo
dule. But at this time, the baud
rate is 38400. In this way, us
er should change the baud ra
te at the AT mode, if they
forget the communication baud rate.

JoeWright

Thanks but I think that's only for the HC-05.  The HC-06 doesn't seem to have the same AT-mode function.

int2str

In that case, try:
Quote
KEY: PIN26, for master abandons memory.

JoeWright

Sorry, I should have said, I tried it - didn't work.  It did clear up an issue I was having at one point with the computer and BT talking to each other but hasn't done anything for resetting the baud and allowing me to send AT commands.

pito

Download the HC-06 datasheet and read carefully ho to set it. The HC-05 and HC-06 firmwares differ in the way AT settings are done..

JoeWright

Yeah, the problem with the 06 is that you need to connect at the right baud rate to do the AT commands.  I did this and then set a baud rate too high (with reference to your reply on the other thread).

Carneiro

Hi, Joe.

Have you had any luck on that? I just did the same mistake and set the baud rate too high. The board now can't communicate (in fact, at 115200 there were already too many errors, but I managed to change the rate to a higher...). If only the AT commands through serial are available, I think I bricked the module...  :smiley-red:

Thanks,

Márcio.

Nick_Pyner


Hi, is it possible to factory reset the HC-06?

I experimented with setting a baud rate > 115200 (AT+BAUDA 460800). 


I don't think there is a reset per se

I understood the command for 115200 is AT+BAUD8. The HC-06 runs fine at that rate and maybe you have just sent a dodgey command. Maybe you can still return with AT+BAUD4.

harithota20

The same problem i am also facing, i have given command AT+BAUDA to set it at 460800 after that,  i could not able to bring it back to 115200. Tried with different serial monitor programs, but no use.
Let me know if there is any way to reset the HC-06.

Dkstraub


vanquoc12b4

Hi, I had follow this tutorial and problem fixed: https://youtu.be/VveS1MhYYMk

Go Up