Go Down

Topic: Unable to get http://Arduino.local page. Arduino Yun WiFi is connected Windows-7 (Read 18156 times) previous topic - next topic

Srini_Murthy

Hi All,

Thanking all of you in advance.

I am running 1.5.5 Version of Arduino IDE, on Windows-7 and I am using Arduino Yun. Set up is successful and I am able to upload the sketches to the Arduino Yun successfully and working OK

I am also connected to Arduino Wifi. But I am unable to get to http://Arduino.local page. When I access this page I get Page error.

Please note: My laptop is connected to Wired Modem and acts a Wireless host and connected to WiFi Arduino

Please any help is highly appreciated and it is urgent.

Thanks onceagain in advance.

Srini R. Murthy


Srini_Murthy

NoblePepper,

Based on your advice, I have installed Bonjour service once again ( I thought it was meant for wired connection only ) any way I have installed and opened a UDP Port 5353.

Still, I am not getting to . http://arduino.local. page

Please note: I am not using wifi for my laptop, it is connected through Modem and I am using wifi for arduino

I am really stuck up here.

Thanks in Advance.

Srini Murthy

OttoF

i think it is not a problem with your laptop, i can connect to arduino.local from all devices in the same network.
ipad, iphone, laptop and so on without install anything

noblepepper

Ok, you have bonjour installed.

Did you follow this guide?:http://arduino.cc/en/Guide/ArduinoYun#toc13

Did you give your Yun a name as described in the guide?
If so it will show up as yourYunsName.local not arduino.local.

In the Arduino IDETools->Port list do you see an entry like yourYunsName at 192.168.xxx.xxx (Arduino Yun)?

I am unclear as to exactly how you configured the wifi, did you set up the laptop to act as a access point and connect the Yun to it or is the Yun acting as an access point and the laptop connects to it (probably at 192.168.240.1)?

ProfePaco

I have the same problem. I never succeed using arduino.local, or newname.local. I can access using 194168.204.1

I have no firewall or another software installed.

I have more issues I am trying to solve.

Srini_Murthy

Hi NoblePepper,

Thank you very much for your reply.

I followed all steps as per instructions. No luck yet.

I have attached the screen shot for your reference which captures important information.

My Host laptop Windows 7 Premium, is connected to Modem not to wifi. ( I am not having wireless router at home ) Also attached the diagram in the picture for the same.
I am only connected to Arduino for access.

I installed IDE 1.5.5 and connected the Arduino Yun. I am able to upload the sketches to Arduino
It works great except for the wifi part ( at least what I know until now).

I am also not able to connect using 192.168.240.1 

This is hitting me.

Any help, is sincerely appreciated.

Regards
Srini Murthy


mamu

Do have this on my Arduino based SmartPhone. On my Macs and iPhones, everything works.
Look like an DNS issue.

noblepepper

Ok, when you say you can upload sketches I assume you mean through the USB, correct?

If so, upload the YunSerialTerminal sketch, it is under File->Examples->Bridge->YunSerialTerminal.

Then open the serial monitor, Tools->Serial Monitor
In the box at the top (to the left of the send button)  type -
Code: [Select]
cat /etc/config/wireless |grep disabled and click the send button.
Do you see this?
Code: [Select]
option disabled '0'If so, continue with the below, if you see this
Code: [Select]
option disabled '1' ignore the instructions/questions below they won't work until we get the wifi enabled.

In the box at the top type
Code: [Select]
ifconfig and click the send button.
You should see something like this in the output:
Code: [Select]
wlan0     Link encap:Ethernet  HWaddr 90:A2:DA:F1:04:27 
          inet addr:192.168.2.203  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7192 errors:0 dropped:1825 overruns:0 frame:0
          TX packets:560 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:1224833 (1.1 MiB)  TX bytes:92250 (90.0 KiB)

Type the address by inet addr: in your web browser (192.168.2.203 in the example above, yours will most likely be different)
Do you get the Yun login page?

Next type
Code: [Select]
avahi-browse -a & in the box at the top and click send. You should see output that includes two lines like these:
Code: [Select]

+  wlan0 IPv4 yunName                                    _arduino._tcp        local
+  wlan0 IPv4 Secure Shell on yunName                   _ssh._tcp            local

What do you see in the output where yunName appears in the example above?

Srini_Murthy

Dear NoblePepper,

Thank you very much for your quick reply, it is getting closer.

Yes, I am connected to Yun with USB Micro B Port

Followed your instructions and the output is identical to what you have outlined
I see "Arduino" on YunName ( I have attached the screenshot for your reference with all the commands)

I think, we are close...

Best Regards,
Srini Murthy




noblepepper

Everything looks  correct on the linino  side of things, for some reason windows is not seeing/using the information. I noticed after  my last post that your laptop is connected to two networks at the same time, this has caused strange things for me in the past. Try disconnecting your internet connection in network manager and see if windows sees the arduino.local then.

You didn't mention it, do you get the yun login prompt if you put http://192.168.240.1 in your web browser?

Srini_Murthy

Dear NoblePepper and All,

I am not able to connect using 192.168.240.1 either. I tried all network firewall on/off
It is not able to resolve/connect to Arduino.local. This is strange.
My work is held up

Any new thoughts ?

Much appreciated in advance.

Regards and Thanks

Srini Murthy

noblepepper

In the screenshot you sent there are two networks shown as connected one called Network and one called Unidentified Network. First disconnect the Yun in the WiFi pop up, then disconnect from both of the other networks, you may need to unplug the cable if the modem is connect via ethernet.

Then reconnect to the Yun in the WiFi pop up and try to connect to arduino.local and/or 192.168.240.1

Do you have any other devices with WiFi you can use to see if they can connect to the Yun WiFi such as a tablet or smartphone?

Srini_Murthy

Hi NobelPepper and All,

Thank you very much for your help and very supportive

When I changed the setting for ipV4 IP to "Obtain IP Address Automatically" Things are working with IP Lookup 192.168.240.1 but still name http://arduino.local is not getting resolved.

Please find the attached screenshot for you reference.

At least I can proceed for now.

Once again, my sincere Thanks to NobelPepper & all.

Regards

Srini Murthy

noblepepper

Great, the arduino.local takes a while to register, hopefully it will start working by itself. Your yun is broadcasting the info and your windows looks to be set to receive it.

I never considered that your DHCP may have been turned off, now it is obvious.

Go Up