Go Down

Topic: Wifi Yun trouble (Read 4792 times) previous topic - next topic

AlexDC

Hi everybody !

I encounter some problems to connect my Arduino Yun on my wifi... :(
I'm on the IDE 1.5.5. I follow the guide to the Arduino Yun to connect my board on Internet.

But it seems that my board could not connect to my wifi. My router is at 1 meter from my board.
The SSID and the password are OK. My computer and my iPhone are connected. The signal strength is high.

I uploaded the wifi statut sketch : http://arduino.cc/en/Tutorial/YunWiFiStatus
Sometimes the signal is at 0% and sometimes the signal is at 37%.

I also uploaded this sketch : http://forum.arduino.cc/index.php?topic=202718.0
Sometimes my blue led blinks and I can access to the arduino.local page (so my board is connected to my network) but most of the time the blue led is off and I couldn't access to the arduino.local page (so my board is not conencted).

I pressed the WLAN RST button, but the problem was not solved.

Could you help me ?

Many thanks,

Alexander

federicofissore

Does the yun reboot itself after 60 seconds after you've configured its wifi?

AlexDC

#2
Dec 09, 2013, 02:39 pm Last Edit: Dec 09, 2013, 02:41 pm by AlexDC Reason: 1
Yes.
I have the message : "Configuration saved ! I'm restarting. Please connect your computer to the wireless network called MyWifi" (MyWifi is my home's wifi).
Then, I connect my computer to my network MyWifi, and I couldn't access to my board on the page "arduino.local".
Sometimes the board is connected to my network during 5 minutes, sometimes during 10 minutes, and I could access to my board on the page arduino.local.  But most of the time the card is not connected.
I see it with the "blue led sketch" or "wifi status sketch".
Thanks for your help Frederico.

federicofissore

Please can you
- upload the YunSerialTerminal right after having configured wifi
- open the serial monitor (the yun is connected via usb cable)
- watch linux booting
- wait a couple of minutes (until you lose connection with the yun)
- finally copy and paste the displayed text here


AlexDC

Hi Federico,

Thanks for your help. Here is the reponse on the serial monitor :
Code: [Select]
[  123.150000] wlan0: authenticate with 00:25:15:b6:b2:68
[  123.180000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  123.250000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  123.310000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  123.340000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  134.320000] wlan0: authenticate with 00:25:15:b6:b2:68
[  134.350000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  134.380000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  134.380000] wlan0: authenticated
[  134.390000] wlan0: associate with 00:25:15:b6:b2:68 (try 1/3)
[  134.470000] wlan0: associate with 00:25:15:b6:b2:68 (try 2/3)
[  134.510000] wlan0: associate with 00:25:15:b6:b2:68 (try 3/3)
[  134.520000] wlan0: RX AssocResp from 00:25:15:b6:b2:68 (capab=0x411 status=0 aid=5)
[  134.520000] wlan0: associated
[  167.120000] wlan0: authenticate with 00:25:15:b6:b2:68
[  167.150000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  167.190000] wlan0: authenticated
[  167.210000] wlan0: associate with 00:25:15:b6:b2:68 (try 1/3)
[  167.210000] wlan0: RX AssocResp from 00:25:15:b6:b2:68 (capab=0x411 status=0 aid=5)
[  167.210000] wlan0: associated
[  360.600000] wlan0: authenticate with 00:25:15:b6:b2:68
[  360.630000] wlan0: direct probe to 00:25:15:b6:b2:68 (try 1/3)
[  360.740000] wlan0: direct probe to 00:25:15:b6:b2:68 (try 2/3)
[  360.850000] wlan0: direct probe to 00:25:15:b6:b2:68 (try 3/3)
[  360.960000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  364.400000] wlan0: authenticate with 00:25:15:b6:b2:68
[  364.430000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  364.500000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  364.580000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  364.640000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  368.580000] wlan0: authenticate with 00:25:15:b6:b2:68
[  368.610000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  368.640000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  368.680000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  368.740000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  376.690000] wlan0: authenticate with 00:25:15:b6:b2:68
[  376.720000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  376.770000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  376.840000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  376.890000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  387.860000] wlan0: authenticate with 00:25:15:b6:b2:68
[  387.890000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  387.950000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  388.020000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  388.090000] wlan0: authentication with 00:25:15:b6:b2:68 timed out
[  399.070000] wlan0: authenticate with 00:25:15:b6:b2:68
[  399.100000] wlan0: send auth to 00:25:15:b6:b2:68 (try 1/3)
[  399.160000] wlan0: send auth to 00:25:15:b6:b2:68 (try 2/3)
[  399.220000] wlan0: send auth to 00:25:15:b6:b2:68 (try 3/3)
[  399.270000] wlan0: authentication with 00:25:15:b6:b2:68 timed out


AlexDC

Any ideas ?
I try so many things, I don't know how to solve it.
Tonight I'm gonna test my board on other wifi (friends / family)... and keep you informed  :)

sonnyyu

#6
Dec 11, 2013, 08:10 pm Last Edit: Dec 11, 2013, 08:13 pm by sonnyyu Reason: 1
Quote
I uploaded the wifi statut sketch : http://arduino.cc/en/Tutorial/YunWiFiStatus
Sometimes the signal is at 0% and sometimes the signal is at 37%.


I run at linino console root@Arduino:~#/usr/bin/pretty-wifi-info.lua

Code: [Select]

Current WiFi configuration
SSID: My_Wireless_Router
Mode: Client
Signal: 100%
Encryption method: WPA PSK (CCMP)
Interface name: wlan0
Active for: 37 minutes
IP address: 192.168.0.109/255.255.255.0
MAC address: 90:A2:DA:F0:06:76
RX/TX: 1142/177 KBs


Signal: 100%

To find out best Channel to use you could use android phone/pad  by play store download Application wifi Analyzer.



from above the Channel 4 is best bet. (Ensure you select a correct country to conform local law. Incorrect settings may cause interference.)

The default router wifi setting:



The optimize setting:


PCWorxLA


To find out best Channel to use you could use android phone/pad  by play store download Application wifi Analyzer.
You don't need to have an Android device to do this, with a Windows (Vista, 7, 8.x) you can do the same with Vistumbler
(http://www.vistumbler.net/index.html) ;)

hth,

Ralf

federicofissore

AlexDC what's the brand/model of your router? What are its wifi settings? (channel, frequency, whatever...)

AlexDC

Hi Frederico,

My router is a french model provided by my ISP : a "SFR Box".
But I changed my channel as suggested and it seems working.

Thanks everybody for your help !

AlexDC

Finally, it doesn't work... :(
If i found a solution, I will keep you informed...

Go Up