Go Down

Topic: Arduino Yun Wifi problem (Read 5263 times) previous topic - next topic


Hey! I am a happy owner of a new Yún and I want to connect it to the internet via my home wifi network. I am quite desparate I must admit since I just can not get it to work properly. Connecting through arduino.local and going through the installation procedure on the Yúns local website went well, it restarts, but then I can't find it under its new address when I re-connect to my home network.
The Wifi-Status example script gives the following output in the serial monitor:
Code: [Select]
Current WiFi configuration
SSID: my_home_network_name
Mode: Client
Signal: 100%
Encryption method: WPA2 PSK (CCMP)
Interface name: wlan0
Active for: 12 minutes
IP address:
MAC address: 90:A2:DA:F2:02:14
RX/TX: 39/34 KBs

It does not seem to be connected to the internet though. If I upload the HTTP client example code it does not load the arduino ASCII logo, but it does that when I connect my arduino directly with my router through a RJ45 cable.
Please - can somebody help???


Just to be sure you run that sketch in the same conditions: have you kept selected the serial port and not the wifi port when you run the HTTPClient with the yun connected first time to wifi and then to cable, right?


Thanks Federico, the problem is now solved: The problem was my router, not the yún. A restart of my wifi network and changing the WPA2 to WPA somehow made it work. Now everything works fine. Thanks!


Hi hotte15,

I'm glad that you were able to solved your problem. I don't have your luck.

Like you i was able to go through the wifi setup in the web console of my Yun without any problem. I even have a "Connected" status when i log into arduino.local. I've also tried the  WifiStatus example (Bridge) and all is ok. But as soon as i try the ConnectWithWPA it fails. Nothing appears in my console. Nothing. So i wonder what i'm doing wrong.

p.s. : switching from WPA2 to WPA isn't an option for me.

Anyone had the same problem?


ConnectWithWPA is an example from the Wifi shield. That won't work with the yun, because you don't have direct access to the wifi interface: it is managed by linux. That's why there is a configuration web panel


I can't connect to my Yun
I can log in my arduino.local and set my configurations

serial monitor:

Unable to connect: retrying (1)...
Unable to connect: retrying (2)...
Unable to connect: retrying (3)...
Unable to connect: retrying (4)...
Unable to connect: is the sketch using the bridge?

non of the Bridge examples work



Many people have problems with the wifi. Please start a new thread. Do not use this old thread.
Please give us more details. Your posting is very generic.

How can you not connect to the YUN? via wifi, ethernet, serial port?
Have you used any of the examples in the IDE? Which ones?


Go Up