Go Down

Topic: USB Keyboard not showing in /dev/input/ (Read 841 times) previous topic - next topic

rhammell

I'm trying to connect a USB keyboard to my Yun for a project, but am running into an issue with it not showing up as in input in /dev/input/

Here's the console screencap of what i'm attempting:



I'm entering the commands 'lsusb' and 'ls /dev/input/' twice. The first set of commands is before I connected the keyboard, and the second set is after I connected the keyboard.

As you can see, after connecting the keyboard it shows up when entering 'lsusb'. However, after that when I try 'ls /dev/input' I expect to see an 'event1' added, but its not there.

Any thoughs on why i'm not seeing an 'event1' after connecting the keyboard?

Thanks
Build the next generation of connected devices: http://arduinomeetslinux.com

sonnyyu


rhammell

Software requirements for USB keyboard at Yun:

http://forum.arduino.cc/index.php?topic=309246.msg2148566#msg2148566






Thanks, i'll give this a shot and see if this makes the difference!
Build the next generation of connected devices: http://arduinomeetslinux.com

rhammell

The suggestion you made worked great!

I was able to do the following from the console:
Code: [Select]

opkg update
opkg install kmod-usb-hid


Once I performed that I was then able to see the keyboard events listed using 'ls /dev/input/':




It worked without using 'opkg install kmod-input-core' or 'opkg install kmod-input-evde'. I only used 'opkg install kmod-usb-hid'

Does just using 'opkg install kmod-usb-hid' make a difference? Or should I always install all three?

Thanks for the help!
Build the next generation of connected devices: http://arduinomeetslinux.com

sonnyyu

#4
Apr 22, 2015, 05:39 am Last Edit: Apr 22, 2015, 03:07 pm by sonnyyu
just install

Code: [Select]
opkg install kmod-usb-hid

is fine, since it dependent on kmod-input-evdev, kmod-input-core, kmod-hid.

all three auto will be installed with kmod-usb-hid.



Go Up