Go Down

Topic: [SOLVED] Arduino drivers for Windows 8.1 64bit (Read 251692 times) previous topic - next topic

mskallday

Unfortunately, this is apparently still a problem, as just yesterday I was unable to install the Arduino drivers on my Asus Transformer running 8.1 64-bit

Fortunately; however, I found instructions for how to disable the driver signature verification that were almost entirely accurate on How-to Geek:

http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

Note, that you may need to get your Key Id from Microsoft to  complete these steps.

stephackback

if using win8 64 bit, you download the software Driver Pack at the link http://adf.ly/u3y7S . For the other win, you look at the software Easy Driver Pack blog: http://storesofts.wordpress.com/ultility/

masterice

#17
Jan 29, 2015, 07:02 pm Last Edit: Jan 29, 2015, 07:03 pm by masterice
I wonder how many people having driver problems are using clone boards?
I have found that clones (notably the DccDuinos) may work perfectly happily on Win 7 but not on Win 8.1 which won't give an error with them even if the driver warning is disabled, they simply won't be discovered.

The simple answer is to download the correct DccDuino drivers and away you go.

They coexist quite happily with the genuine Arduino drivers.
They are available from an article about getting the DccDuinos to work with Win 8.1 here

http://javacolors.blogspot.co.uk/2014/08/dccduino-usb-drivers-ch340-ch341-chipset.html

Hope this might help.

Slim Haines


parin001

arduino uno drivers issue solved for windows 8,8.1
1) just download given zip file.
https://www.silabs.com/Support%20Documents/Software/CP210x_VCP_Windows.zip
2) Extract zip file
3) install CP210xVCPInstaller_x64.exe or CP210xVCPInstaller_x86.exe   according to your OS architecture.
4) connect arduino go to control panel ->device manager u can see arduino drivers installed successfully


ChilliTronix

The CH340 driver on the manufacturers site is Windows 8 signed.

olivi55

Still doesn't work for me :/ what should I do ?

Titanium69

#21
Apr 11, 2015, 03:50 pm Last Edit: Apr 11, 2015, 03:53 pm by Titanium69
So I just updated to 1.6.3 today (Windows 8.1/64 bit).  Had 1.0.6 working for the longest time with no problems.
"Port" on my IDE Tools Menu is disabled which makes me suspect the driver didn't install properly.

Reading this thread I see "Problem Solved" yet today's drivers didn't install.

There are other users stating we should go to some unknown site and download their drivers. Really? You really think I'm gonna just blindly download some unknown code into my machine.

Rather than users beating this subject to death (it's been around long enough), why can't Arduino once and for all put this to rest and fix the problem. Or is this gonna be another software/hardware presence that just leaves it's users hanging?

You laugh I laugh
You cry I cry
You fall off a bridge I laugh so hard I fall off with you

federicofissore

Titanium69, does the board show up in windows device manager?
AFAIK drivers are correctly signed.

Arduino drivers contain NO CODE: it's just a text file that tells windows to manage Arduino boards as serial devices.

IDE 1.6.3 has a bug that leaves Port menu greyed out and which affects some users and that has been fixed in latest nightly http://arduino.cc/en/Main/Software#nightly

BgoMike

olivi55
Try it again, I have an Asus with win8.1 64 bit and it works.
When choosing 7 to disable driver signature enforcement I had to use the laptop keyboard.


http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

Apparently after installing the driver, we should restart again which will turn the enforcement back on.

cheers
Mike


mysorian


Sploddy

The issue has not been solved.  Updating drivers in Win8.1 64 bit  device manager does not work.  The only way is to go to the actual file in the IDE driver folder, right click and select "install".  Even so windows regularly dumps the driver thus causing reloading of programs to fail.  Here it is necessary to "re-install the driver" but this does not always work.  Since "Vista", drivers have to conform to MS certification, which the Arduino drivers do not have.

If its capable of failing - It will !

federicofissore

Since "Vista", drivers have to conform to MS certification, which the Arduino drivers do not have.
Can you elaborate? AFAIK Arduino drivers are properly signed with a proper certificate

Sploddy

Can you elaborate? AFAIK Arduino drivers are properly signed with a proper certificate
As you are an "Engineer at Arduino" Would it not be better that you elaborated on the status of your drivers?
I am only posting what I have experienced, and my computing experience and creating software goes back to the TRS80 and C64 days so I did not come down in the last shower of rain.

The drivers I downloaded from your "latest" release of the IDE will not install thru the device manager in Windows 8.1 on a Gigabyte mobo. (as many other users have also experienced) This was because MS introduced a certification of conformity requirement with Win Vista et seq.

The object being that, especially from China, the market was being flooded with countless items of hardware from cameras to satellite TV cards, Audio devices, ad nauseum. The drivers accompanying these items of hardware are usually contained on a mini CD, often without any identification  nor information.  In many cases these so-called drivers contained malware and feral content that corrupted the MS operating systems.  It was only with a certain knowledge of how to removed this feral software that one had no alternative but to completely reformat the computer and re-install the OS.
 
Many people just throw in software into the default folders in Program Files instead of putting applications etc onto a separate drive.  As a result the OS directories and registries became cluttered with so much rubbish, the C: drive becomes nothing more than a garbage dump interfering the smooth running of the OS.

I have transferred my Arduino files and software to a different computer running Vista and installed the driver by using the "Install driver anyway, I know where it came from" option, This a P4GX-MX Asus mobo.

 The Arduino drivers are firmly in place and the software and control of the Arduino UNO R3 board I have are running seemlessly.  This computer is used exclusively for running Astronomy, Security  and Radio related software and not used for games nor entertainment.

My primary interest in Arduino is for Radio and Security applications.

If the "latest drivers" have a genuine MS signed and approved certificate embodied, then why is Windows 8.1 rejecting them?  Are they contained in the latest IDE release?  If not why not and where are they?

Thank you for your kind attention :)

If its capable of failing - It will !

federicofissore

Windows drivers work fine and are up to date. I haven't yet had a chance to access a Windows 8.1, but IDE and drivers installed flawlessly on a Windows 7 and a Windows 10

CrisHooker30

Similar issue except when I try to run the blink test it tells me Com 3 is busy which does not add up its the port I used to connect the thing

Go Up