Go Down

Topic: Installing libraries under ARDUINO v.1.05 (Read 6076 times) previous topic - next topic

anto75

Dear friends,
I am looking to install libraries not included in Arduino IDE v.1.05 : I have followed all the steps so I can see the newest library installed on it BUT as soon as I try to include it into my new sketch it doesn't appear the proper string of code : the row appear empty.
COULD YOU HELP ME? I can install only the libraries included with the IDE ... I want to use other libraries e.g. PID , etc..
BEST REGARDS!!!

                                                                       Antonio from Milan , Italy

johnwasser

Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

anto75

Thank you John! I have tried with other libraries with good results but among the ones that I can't succeeded in there is the important library PID : could you help trying to do the same job as me?

CIAO!!

                                                                         Antonio from Milan , Italy

johnwasser

From where are you getting the PID library you want to install?
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

anto75

Ciao john!! this is the link :  http://playground.arduino.cc/Code/PIDLibrary

the library I try to work is the latest, v.03

THANK YOU!!


                                                    your Arduino mate Antonio from Italy

johnwasser

Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

anto75

Ciao! Happy new year..unfortunately I cannot install this library because the name contains symbols not allowed to be used as Arduino library...I tried to change the new with the new one but the installation process fails due to the previous name embedded in the core of the library..
Please help me..my Italian mates have no idea to resolve it..

CIAO!!!

                                                         Antonio in the fantastic world of Arduino and his amazing mates

Riva

Just tested and it works fine if you follow the readme instructions.
Quote
***************************************************************
* Arduino PID Library - Version 1.1.0
<SNIP>
***************************************************************

- To Use, copy the PID_v1 folder into the Arduino\Libraries directory
Don't PM me for help as I will ignore it.

anto75

Ok! I will try as soon as possible : so I have to find the right library that you mention, ins'it?
Thank you...

Riva


Ok! I will try as soon as possible : so I have to find the right library that you mention, ins'it?
Thank you...

Download the library John pointed you to and extract it to somewhere look into the extracted library until you find the folder called PID_v1 and copy that to your arduino/libraries folder.
Don't PM me for help as I will ignore it.

anto75

thank you!!! You are a big Arduino Mate!!!

Go Up