Go Down

Topic: Problem install Arduino uno r3 in windows 8.1 cod error 43 USB Unknown Device (Read 5926 times) previous topic - next topic

raimens

Good morning, I'm having trouble installing the arduino uno r3 in windows 8.1, ja also tried in windwos 7 and the problem continues go to the device manager I update the driver but the following error:
Windows has stopped this device because it has reported problems. (Code 43)

The request for the USB device descriptor failed.

USB Unknown Device (Failed Request Device Descriptor)


Device USB \ VID_0000 & PID_0002 \ 5 & 0 & 10 & 15c311e1 was configured.

Driver Name: usb.inf
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Driver Date: 06/21/2006
Driver Version: 6.3.9600.16442
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Matching Device Id: USB \ DEVICE_DESCRIPTOR_FAILURE
Outranked Drivers: usb.inf: USB \ DEVICE_DESCRIPTOR_FAILURE: 00FF2000
Device Updated: false

ilioSS

HI,

Raimens,

Please check if your usb driver is installed in the arduino folder in folder drivers.
On the arduino site you can find how to install. the correct driver.
succes,
ilioSS

raimens

Hello thanks for the reply, I have done it but says the latest driver is installed ja ja fetched drivers tested with different versions of the Arduino and on different machines and nothing but the arduino uno board is new, do not understand if someone could help

gkenaley

Guys,

I had the exact same Windows 8.1 problem and tried all the same fixes that you did and more:
1. Got latest Windows 8.1 driver from FTDI
2. Enabled unsigned drivers
3. Tried using the FTDI Windows installer to install the FTDI drivers, rather than using the Device Manager.
Nothing helped. I also tried on a Windows 7 PC and the behavior was similar (i.e. erratic, with error codes).

Then I remembered my problems (documented by Adafruit) where the Raspberry Pi sometimes didn't get enough power when a cheap USB cable with thin wires is used (too much voltage drop). So I switched the USB cable to a new high-quality cable and everything immediately started working!

So I suggest that you try several different mini-USB cables; and if that doesn't work, try using a power brick to power the board.

Good Luck!

quantum

XD You're right. I changed to another USB port and it worked great. Thank you!

Go Up