Go Down

Topic: AVR device not responding and red LED (pin 13) is always on (Read 8492 times) previous topic - next topic

bobh66

I had the problem with run-avrdude using efuse value FB instead of CB, so I modified run-avrdude and that problem went away, but now the red LED (pin 13) on the board is on solid as soon as I power up, and I cannot upload any sketches.

root@Arduino:/etc/arduino# run-avrdude ./base.hex

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.


Resetting the board doesn't help.  Is there any way to reset the AVR chip from Linino, or is the chip dead?  Is that what the solid red LED means?

Thanks

Bob

sonnyyu

You need reflash correct bootloader.

nano /usr/bin/run-avrdude
Change the efuse value from FB to CB

Code: [Select]
#!/bin/sh

echo 1 > /sys/class/gpio/gpio21/value
avrdude -c linuxgpio -C /etc/avrdude.conf -p m32u4 -U lfuse:w:0xFF:m -U hfuse:w:0xD8:m -U efuse:w:0xCB:m -Uflash:w:$1:i $2
echo 0 > /sys/class/gpio/gpio21/value


1. flash bootloader only
Code: [Select]
/usr/bin/run-avrdude    /etc/arduino/Caterina-Yun.hex


2. flash  sketch only ( save memory)
Code: [Select]
/usr/bin/run-avrdude    /tmp/Blink.cpp.hex


3.  flash  sketch+bootloader  
Code: [Select]
cd /tmp
/usr/bin/merge-sketch-with-bootloader.lua  /tmp/Blink.cpp.hex
/usr/bin/run-avrdude    /tmp/Blink.cpp.hex


Blink.cpp.hex  's size is  14450, the new Blink.cpp.hex after merge is 25372. Blink.cpp.hex is from blink example.

bobh66

I corrected the efuse setting in run-avrdude but it still fails to contact the device:

root@Arduino:~# /usr/bin/run-avrdude /etc/arduino/Caterina-Yun.hex

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

root@Arduino:~# /usr/bin/run-avrdude /etc/arduino/Caterina-Yun.hex -F

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0x7771b0
avrdude: Expected signature for ATmega32U4 is 1E 95 87
avrdude: NOTE: "flash" memory has been specified, an erase cycle will be performed
         To disable this feature, specify the -D option.

avrdude done.  Thank you.

root@Arduino:~#

sonnyyu

1. Use fresh OS/software.

/usr/bin/reset-to-factory-anyway
reboot
nano /usr/bin/run-avrdude
Change the efuse value from FB to CB

/usr/bin/run-avrdude /etc/arduino/Caterina-Yun.hex

2. Chang power supply, make 5.0 V close to 5.0 V say ~4.8 V.

3. Use External Programmer.







facevedo

Hello
I'm having the same problem, and the solutions posted here has the same result for me:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.



Have you found any solutions yet?


sonnyyu


bmweller

I have the same issue as above and have tried options 1 and 2.  Can anyone confirm that using an external programmer resolves this?

noblepepper

Are you getting
Code: [Select]
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
??

If so try this http://forum.arduino.cc/index.php?topic=240802.msg1727359#msg1727359

bmweller

Hi noblepepper,

thanks for your advice.  Yes that is the error I received. So I tried your test and I do see the voltage on the MISO swing from 0 to 4.7 back to zero as scripted.  I however don't see the flashing yellow indictor 1 to 2 seconds after hitting the reset button as you described later in the thread; should I be worried?  Are there similar tests that can be done on MOSI (always high by default?) and SCK pins?

Go Up