Go Down

Topic: USBasp Proggrammer Trouble (Read 1 time) previous topic - next topic

OrangesRgood

Hello, To relieve any future hair being ripped out; i'll try to make my this as specific as possible. I recently purchased a USBasp proggrammer (SainSmart USB ISP Programmer for ATMEL AVR ATMega ATTiny 51 Boar) for my arduino uno(NOT smd version) because the Bootloader wasn't working properly(but that's a different conversation). So anyway I followed all of the proper edits to my Arduino IDE preferences, and then installed the drivers onto my PC for the Proggrammer.(I run Windows XP). Realizing it was still not working, I went back to the IDE and made sure all my settings were correct(com port, preferences, Proggrammer selected ect.).  Still no luck .  So I sought the help on the forums of Arduino.cc.  I found that having trouble with these USBasp proggrammers was a common problem.  But the information they had did not help me. When I try to compile it gives me the error;
avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc. I looked the error up and all the wild wild web told me was that the proggrammer was not conneced. (I think it may be a  permission issue?) Help would much appreciated.
 

ralphd

Does it (the USBAsp) show up in the device manager?

pito

You have to install the driver for it, ie from www.fischl.de/usbasp

Go Up