Go Down

Topic: SOLVED - My sketch does not start on DUE (Read 1 time) previous topic - next topic


Jan 15, 2014, 03:36 pm Last Edit: Jan 22, 2014, 07:18 pm by DGSi Reason: 1
First sorry for my english.
My sketch stopped to start on DUE. Everything was ok, but once after adding few lines of "Serial.print()" code for debug purposes,  uploaded sketch not started. Tried reset, erase buttons, uploaded again and nothing. Other simple sketches from examples starts with no problems. Added first lines in setup function:
Code: [Select]
pinMode(13, OUTPUT);
digitalWrite(13, LOW);

Led still on!
My sketch is not very simple - "Sketch uses 130 620 bytes (24%) of program storage space. Maximum is 524 288 bytes."
I have removed some code with a lot usage of memory, sketch space usage decreased from 32% to 24% - still nothing.
Thank You for help!


Well if its not the obvious running out of RAM, perhaps its a particular feature you are
using or a compiler bug - divide and conquer to narrow the culprit down?
[ I will NOT respond to personal messages, I WILL delete them, use the forum please ]


It was possible memory overflow problem. But why my project stopped after adding two Serial.printl() code lines? And why not started again after removing  them? And why not starting after removing a lot of code?


Problem was in code
Code: [Select]
extern SomeClass someclass;
After commenting this line - everything works! But! Header file was not in #include list (that class coding in progress), just in same folder as sketch. No used class instance in program anywhere! If uncommented - sketch do not start again! After including class in sketch and creating instance using "new" operator - sketch works! And why sketch worked before with uncommented line? I dont remember exactly when, but i have upgraded Arduino from 1.5.5 to 1.5.5-R2.
Linker problems?


Hey DGSi,

can you please explain how exactly you fixed this problem?...
I´ve got the same and hope you can help me...

P.s. sorry for my bad english!^^...

Go Up