Go Down

Topic: Arduino IDE 1.0.5 does not start on my Mac OS X 10.5.8 (Read 5215 times) previous topic - next topic


So I don't use my mac often but its in my shop and I would like to have Arudino IDE on it.  I was running an older version of the IDE just fine.  Figured I should do the latest and greatest.  Downloaded 1.0.5, installed on mac, arduino icon bounces in the tray for a bit then goes away, no error box (though honestly been so long since I used OS X...not sure if there is a console log somewhere). 

I know my java version was java 5, heard that is no good for the IDE 1.0.5, so went to system update (only way to do it in mac os 10.5.8 i hear) and got the latest 6 and 7.  The problem *I THINK* is that they are 64bit, am I hosed?  Does mac os 10.5.8 no longer suport 32bit java 6.  That means the arduino IDE will never run again?  It feels I am missing something but cannot find anything helpful when I google this.

(it is an intel mac)


same here
10.5.8 on a iMac intel core 2 duo

i lack the knowledge to troubleshoot this, so i stuck to 1.0.3 hoping a next update would work

anyone have a solution?


thank you for your response

i tried some things - but no luck so far. i tried editing the plist. i noted what happens when i try starting 1.0.5 in the console
i hope someone can shed some light on this.

with 1.6 (original) :
Jan 20 23:19:30 imac-van-frank [0x0-0x27027].cc.arduino.Arduino[188]: [JavaAppLauncher Warning] Java application launched from PPC or bad stub. Relaunching in 32-bit, and tagging sub-processes to prefer 32-bit with $JAVA_ARCH=i386.
Jan 20 23:19:30 imac-van-frank [0x0-0x27027].cc.arduino.Arduino[188]: [JavaAppLauncher Error] This process is [i386] and was re-exec'd from [i386], but for some reason we are trying re-exec to [].
Jan 20 23:19:30 imac-van-frank [0x0-0x27027].cc.arduino.Arduino[188]: [JavaAppLauncher Error] unable to find a version of Java to launch
Jan 20 23:19:30 imac-van-frank com.apple.launchd[94] ([0x0-0x27027].cc.arduino.Arduino[188]): Exited with exit code: 1

changed to 1.5:

Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]: [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]: Exception in thread "main"
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]: java.lang.NoClassDefFoundError: javax/swing/filechooser/FileNameExtensionFilter
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at java.lang.Class.forName0(Native Method)
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at java.lang.Class.forName(Class.java:242)
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:56)
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at apple.launcher.LaunchRunner.run(LaunchRunner.java:112)
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
Jan 20 23:23:17 imac-van-frank [0x0-0x28028].cc.arduino.Arduino[192]:    at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Jan 20 23:23:17 imac-van-frank com.apple.launchd[94] ([0x0-0x28028].cc.arduino.Arduino[192]): Exited with exit code: 1


I don't have any solutions for 1.6, but the error you're getting with Java 1.5 is the one in my second link, above. The solution (hack) I describe there should work, but I wouldn't recommend it unless you know what you're doing in that area.

If you have no other option, here are some hints. All I promise is that this worked for me:

Code can be downloaded from http://grepcode.com/file/repository.grepcode.com/java/root/jdk/openjdk/6-b14/javax/swing/filechooser/FileNameExtensionFilter.java/

You will compile it and add it to /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Classes/classes.jar (after saving a copy of the original first, of course).

From the Classes directory, make a directory javax/swing/filechooser to hold the downloaded copy of FileNameExtensionFilter.java,
compile with "javac -g javax/swing/filechooser/FileNameExtensionFilter.java", and add it to classes.jar with "jar uf classes.jar javax/swing/filechooser/FileNameExtensionFilter.class".


thank you for your response
unfortunately, this is way beyond my knowledge - so i am going to follow your good advice:
"I wouldn't recommend it unless you know what you're doing in that area"

I hope it works for others

i must say - i am disappointed that arduino seems to be so demanding on the system. I sincerely hope a next version will work on older os/java.


- Download Arduino 1.5.2
- Move it to Documents or Applications.
- Open Terminal and enter this command : Java -version
- Copy the version number
- Right-click (two fingers of mouse pad and click) on Arduino and Select "Show package contents"
- In Contents folder, Open " info.plist"
- Go to JVM version under Java, and enter the full version number without any wildcards(*).
- Save and run Arduino.


PS.: Credits should go to Kelvin, got my synapses going. May work on the 1.0.5

Hope this works for you!


thanks for the tip

tldr: doesnt work


java version "1.5.0_30"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_30-b03-389-9M3425)
Java HotSpot(TM) Client VM (build 1.5.0_30-161, mixed mode, sharing)

changed the info.plist to:


icon bounces then quits
in console i get:

Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]: [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]: Exception in thread "main"
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]: java.lang.NoClassDefFoundError: javax/swing/filechooser/FileNameExtensionFilter
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at java.lang.Class.forName0(Native Method)
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at java.lang.Class.forName(Class.java:242)
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:56)
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at apple.launcher.LaunchRunner.run(LaunchRunner.java:112)
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
Jan 22 23:38:34 imac-van-frank [0x0-0x26026].cc.arduino.Arduino[213]:    at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Jan 22 23:38:34 imac-van-frank com.apple.launchd[92] ([0x0-0x26026].cc.arduino.Arduino[213]): Exited with exit code: 1


OK, if you could handle EternalHerald's instructions then I'll fill in the details of mine and you should be able to handle it just fine.

1. Download FileNameExtensionFilter.java by clicking on this URL: http://grepcode.com/file_/repository.grepcode.com/java/root/jdk/openjdk/6-b14/javax/swing/filechooser/FileNameExtensionFilter.java/?v=source&disposition=attachment

2. Move the downloaded file to your Desktop if it's not there already.

3. Launch the Terminal, and do the following series of commands. If any of these gives you an error message, let me know what it is and do not proceed.

  # change working directory to location of Java 1.5.0 classes.jar
  cd  /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Classes

  # work as root - when prompted for password, enter your login password; be very careful from this point on
  sudo  bash

  # save original classes.jar in case anything goes wrong
  cp  -np  classes.jar  classes.jar.SAVED

  # create directory for source code
  mkdir  -p  javax/swing/filechooser

  # move source code to that directory
  mv  $HOME/Desktop/FileNameExtensionFilter.java  javax/swing/filechooser

  # compile it
  javac  -g  javax/swing/filechooser/FileNameExtensionFilter.java

  # add it to classes.jar
  jar  uf  classes.jar  javax/swing/filechooser/FileNameExtensionFilter.class

  # all done


succes! thanks for the detailed instructions! I hope this works for others too!

special thanks, and full credit to:

change the java version in info.plist
compile a thingie and add it to java

no smoke coming from the computer
contents of bankaccount did not mysteriously disappear to nigeria
arduino 1.0.5 started up (disappointingly without fireworks and people cheering - after all that trouble!)
lets hope a next version just works without hassle :)
yay for the helpful users on this forum!


Thanks from me too kelvin.
I have no Idea what i did but it worked.

All the best

Go Up