Go Down

Topic: Using the Plotly web api to display data from Yun (Read 11735 times) previous topic - next topic

bolatu

I dont think so my problem is about disk space issue.
Today, I tried another approach which is WinSCP program to access the files of Yun.

First I copied the files from my PC to root directory of Yun.

Then, According to tutorial of https://github.com/plotly/arduino-api/tree/master/plotly_yun , I have changed the config.json file with my User name, API key and tokens.

I upload the example sketch with my tokens and then I should get some http address with this commands:

Code: [Select]
root@Arduino:~# python run.py
python: can't open file 'run.py': [Errno 2] No such file or directory
root@Arduino:~# tail -f YunMessenger.log
tail: can't open 'YunMessenger.log': No such file or directory
tail: no files


As you can see, I cannot access these files and run them. I am using PuTTY terminal for this because of windows. I really dont figure it out how to install this Plotly libraries to Yun.

I also tried easy_install, but you have said that this can be disk space issue but there is space.

Can you give me suggestion about this problem, because I am stuck right now?

bolatu

Code: [Select]
root@Arduino:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    7.5M      4.9M      2.6M  66% /
/dev/root                 7.0M      7.0M         0 100% /rom
tmpfs                    29.9M    152.0K     29.7M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3            7.5M      4.9M      2.6M  66% /overlay
overlayfs:/overlay        7.5M      4.9M      2.6M  66% /
/dev/sda1                 1.8G         0      1.8G   0% /mnt/sda1


This is after I copied Linino to Yun with WinSCP.

sonnyyu

backup your data and code to pc via winscp.

Code: [Select]
/usr/bin/reset-to-factory-anyway

wait for few minutes and power cycle. This is will clean up every thing and reset to factory default.

Code: [Select]
opkg update
opkg install python-openssl #adds ssl support to python
opkg install distribute #it contains the easy_install command line tool (this can take some time)
easy_install pip #installs pip  (this can take some time)
pip install plotly #(this can take some time)


restore your data.




bolatu

I reseted Yun and then I wrote the commands based on your commands. This is the result, and again it failed. Here is the all codes...

Code: [Select]
root@Arduino:~# opkg update
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//Packages.gz.
wget: socket(AF_INET6,2,0): Address family not supported by protocol
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//Packages.sig.
Signature check failed.
Remove wrong Signature file.
Collected errors:
* opkg_download: Failed to download http://download.linino.org/dogstick/all-in-one/latest/packages//Packages.gz, wget returned 1.
* opkg_verify_file: Unable to open /var/opkg-lists/barrier_breakerroot@Arduino:~# opkg install python-openssl
Unknown package 'python-openssl'.
Collected errors:
* opkg_install_cmd: Cannot install package python-openssl.
root@Arduino:~# opkg install python-openssl
Unknown package 'python-openssl'.
Collected errors:
* opkg_install_cmd: Cannot install package python-openssl.
root@Arduino:~# opkg update
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//Packages.gz.
Updated list of available packages in /var/opkg-lists/barrier_breaker.
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//Packages.sig.
Signature check passed.
root@Arduino:~# opkg install python-openssl
Installing python-openssl (2.7.3-2) to root...
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//python-openssl_2.7.3-2_ar71xx.ipk.
Configuring python-openssl.
root@Arduino:~# opkg install distribute
Installing distribute (0.6.21-1) to root...
Downloading http://download.linino.org/dogstick/all-in-one/latest/packages//distribute_0.6.21-1_ar71xx.ipk.
Configuring distribute.
root@Arduino:~# easy_install pip
Searching for pip
Reading http://pypi.python.org/simple/pip/
Download error on http://pypi.python.org/simple/pip/: [Errno -2] Name or service not known -- Some packages may not be found!
Reading http://pypi.python.org/simple/pip/
Best match: pip 1.5.6
Downloading https://pypi.python.org/packages/source/p/pip/pip-1.5.6.tar.gz#md5=01026f87978932060cc86c1dc527903e
Processing pip-1.5.6.tar.gz
Running pip-1.5.6/setup.py -q bdist_egg --dist-dir /tmp/easy_install-LiB4u8/pip-1.5.6/egg-dist-tmp-2bX6Ki
warning: no files found matching 'pip/cacert.pem'
warning: no files found matching '*.html' under directory 'docs'
warning: no previously-included files matching '*.rst' found under directory 'docs/_build'
no previously-included directories found matching 'docs/_build/_sources'
Adding pip 1.5.6 to easy-install.pth file
Installing pip script to /usr/bin
Installing pip2.7 script to /usr/bin
Installing pip2 script to /usr/bin

Installed /usr/lib/python2.7/site-packages/pip-1.5.6-py2.7.egg
Processing dependencies for pip
Finished processing dependencies for pip
root@Arduino:~# pip install plotly
Downloading/unpacking plotly
  Cannot fetch index base URL https://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement plotly
Cleaning up...
No distributions at all found for plotly
Storing debug log for failure in /root/.pip/pip.log

federicofissore

Ah, you're using the old image. Please upgrade to the latest: see the link in my signature. Once done, please retry

bolatu

I have installed the new image and update the new version but still I have same problem =(

Code: [Select]
root@Arduino:~# opkg update
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.sig.
Signature check failed.
Remove wrong Signature file.
root@Arduino:~# opkg install pyopenssl
Unknown package 'pyopenssl'.
Collected errors:
* opkg_install_cmd: Cannot install package pyopenssl.

sonnyyu

Signature check failed.
lately http://downloads.arduino.cc  server is unstable.

try

Code: [Select]
opkg update

few time until it work.

Code: [Select]
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/Packages.sig.
Signature check passed.


Go Up