Go Down

Topic: DSO 203 aka DSO Quad (Read 3927 times) previous topic - next topic

polymorph

What is your favored firmware upgrade? When you mention yours, does it occupy all the ROM slots?

Do any of them fix the problem of steps in the sine, triangle, and sawtooth waveforms?

Which ones add X Y vector capability?

Here are a couple I've been told about:

https://github.com/gabonator/DS203

First one at the top of the page:
http://www.seeedstudio.com/forum/viewtopic.php?f=26&t=2957
Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

polymorph

#1
Feb 05, 2014, 11:32 pm Last Edit: Feb 07, 2014, 09:03 pm by polymorph Reason: 1
The one I have says it is hardware version 2.72. Does anyone know where I can find the schematic for that version? The Wiki only has the schematic for 2.60, which has two 36Msps channels. But the latest version on Seeed Studio's website claims two 72Msps channels.

http://www.seeedstudio.com/depot/DSO-Quad-Aluminium-Alloy-Black-p-1034.html

Does anyone know the actual analog bandwidth? Measured perhaps by measuring risetime?
Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

polymorph

No one? Maybe I should say something else bad about the DSO 203 and people will respond. ;')

I see at least one person on the Seeed Studio thread who said that upgrade didn't work with his HW version 2.72, which is what I have.
Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

polymorph

I must be doing something incorrectly. Using APP 251.hex from here:
http://www.seeedstudio.com/forum/viewtopic.php?f=26&t=2957

With the sig gen connected to channel A, I get no indication, just a bit of noise. I'll do more troubleshooting later.
Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

polymorph

Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

polymorph

The Gabonator himself said that his firmware won't work with HW 2.72, due at least in part to the 8M of memory being formatted differently than the 2M in the 2.60.

Still no input from anyone else? I can't be the only one with this model.
Steve Greenfield AE7HD
Drawing Schematics: tinyurl.com/23mo9pf - tinyurl.com/o97ysyx - https://tinyurl.com/Technote8
Multitasking: forum.arduino.cc/index.php?topic=223286.0
gammon.com.au/blink - gammon.com.au/serial - gammon.com.au/interrupts

Go Up