Go Down

Topic: Any suggestion about how to create a wirelessly USB port with YUN? (Read 2949 times) previous topic - next topic

matthew_z

Hi:
I have a robot which can be controlled by PC via usb cable, and I wanna make it become wireless.
So I try to use Yun to make a Wireless USB port/hub, but I don't know how to do it.
I checked the example on the arduino website but I didn't find something about communication between TCP/IP and USB port.

Then I wanna find a tool which can be installed on linino to make USB port can be shared by network. I found "usbip" may be useful but it could not be installed by "opkg install" now.

Could someone help me?

Thanks
Matthew

lucad79

Hi Mattew,

I can't try now because I'm at work but this guide may help you:
http://wiki.openwrt.org/doc/howto/usb.iptunnel

I think the required packages are included in the Linino repository too...

let me know if it works!
www.lucadentella.it

matthew_z

#2
Feb 17, 2014, 03:20 pm Last Edit: Feb 17, 2014, 03:22 pm by matthew_z Reason: 1
Hi lucadentella:
I have read this website. I think it is a instruction about usbip.

Then, I tried to use usbip on my laptops with ubuntu 13.04 to share a usb but failed.

root@Matthewslaptop:~# usbip_bind_driver --usbip 1-1

** (process:1306): WARNING **: add 1-1 to match_busid, failed


I tried to find a solution by google and it seems that the software is too old to run with the new linux kernel.

And if it can works on linux. I still can't compile this code on Yun because there is no a C compiler on Yun. Maybe I can try cross compiling for Yun.


Thank you
Matthew

sonnyyu

The usbip at userspace in linino is missing, only kernel one exist.  The up stream OS (Openwrt) is broken.

sonnyyu

#4
Apr 30, 2014, 04:32 pm Last Edit: Apr 30, 2014, 04:36 pm by sonnyyu Reason: 1
New Yun image has those:

kmod-usbip - 3.3.8-1 - USB-over-IP kernel support
kmod-usbip-client - 3.3.8-1 - USB-over-IP client driver
kmod-usbip-server - 3.3.8-1 - USB-over-IP host driver
usbip - 1.1.1-2 - USB-over-IP (common)
usbip-client - 1.1.1-2 - USB-over-IP (client)
usbip-server - 1.1.1-2 - USB-over-IP (server)

I am not sure it get fixed.

federicofissore

Checkout Vadorequest's project: https://github.com/Vadorequest/AAD1/ It's about using a yun to control a car via wifi

sonnyyu

Quote
I tried to find a solution by google and it seems that the software is too old to run with the new linux kernel.


Since kernel 2.6.28 usbip is in the kernel mainline, the problem is in up stream OS.


Go Up