Go Down

Topic: [ATTINY85]Nothing but junk appears on my serial monitor... :( (Read 8267 times) previous topic - next topic

Spyrakos88

Hello! I have an attiny85. I have flashed it with blink and is working well.

The problem is with serial. I burned the bootloader to use serial with no errors. I have tryied differnent cores with differents ide's with no success. I still getting junk letters from the serial . I used arduino duemilanove as isp . Is it possible the chip has failed and only serial doesnt work?

I also removed the atmega from arduino and replaced the capacitor with a jumper wire.Thanks

cjdelphi

There are no hardware serial ports.

Use softwareSerial over 3v  (5v)

Spyrakos88

Thanks for the reply!! Do you mean to power the attiny with 3 volts?

cjdelphi

Under 3.3v softwareSerial acts up (when powering the attiny85)

Spyrakos88

Thanks! The attiny was powered with 5 volts :( but i can't check it right now if it is working with 3.3 volts. I think that if i use the arduino 3.3v output i can get some readable data from serial. I will reply in about 4 hours..

Erni

If you use this core:

https://code.google.com/p/arduino-tiny/

there are several options for serial output.

A simple example below.
The serial output will be pin PB3. Connect a serial/USB converter to that pin.

This might be of interest:

http://www.ernstc.dk/arduino/tinycom.html

Code: [Select]
void setup() {
Serial.begin(9600);
}

void loop() {
Serial.println("Testing..");
}


Spyrakos88

I just tested with 3.3 volts from arduino duemilanove and i get the same junk letters...with this code for example which uses the previous core i get this "ðððððððúððððððððûðððððððððððððððøððúððððððøððúððððððððð" in straight line.

Is there any problem that windows isn't in english language? I think i have tryied everything...

Erni

How are you connecting the tiny to your Arduino.

Why are you powering the tiny with 3.3V

Spyrakos88

Hello my friend here is the tutorial that i used.http://www.instructables.com/id/Program-an-ATtiny-with-Arduino/

I succesfully flashed it with blink sketch but with serial... no luck!

I powered with 3.3volts because today i learned that serial working only under this voltage. But with both voltages i keep reaciving
these letters.

Now im thinking if the problem is the chip itself or the duemilanove...

I accept any help thanks

Erni

Quote
I powered with 3.3volts because today i learned that serial working only under this voltage.


That proves that you should not trust everything you read, it is nonsens.

I don't know the core you are using, as I said in previous post I am using this one:

https://code.google.com/p/arduino-tiny/

Quote
is there any problem that windows isn't in english language? I think i have tryied everything...


No mine windows is danish, and that dosn't give me any trouble.

Are you using SoftWareSerial for communication ?



Spyrakos88

Are you sure about that? I left that as a final solution (before i throw it to the garbage)because it has a lot of reading. So there are attinys that are ok and some others that need this "calibration"?? Bad luck then...


Spyrakos88

Thanks my friend. I cant check it right now because i need to read several things about that (im using attiny for first time) and i will reply asap.  I found pour man's tiny tuner. Is that the way to go or you have a better-faster way?


Go Up