Go Down

Topic: Arduino Uno R3 With Mac OS X 10.9 Mavericks Not Detected/ No Serial USB (Read 9242 times) previous topic - next topic


Hey all,

At least it sounds like most of you are getting the IDE to even start! Intermittently... no lets change that to spasmodically, because I yet to figure out or identify a failure mechanism that cause the IDE to hang on startup.
Good cables,
Shows up in USB tree
Serial connection shows
OSX 10.10.3
IDE 1.6.3
FTDI 1.04
Mega 2560/Uno R3

Only thing that works (sometimes) is a complete restart of the iMac. Can happen anytime. Was programming for a few hours, got a programmer not responding error (on UNO). Now I can't get Arduino to even start it just hangs

Any ideas????

Thoroughly frustrated!!!

Joe B


Hi all,
I just got my Uno R3 and to my excitement and then disappointment my Mac pro on yosemite 10.10 has not been able to connect with USB.
I flashed using the DFU as mentioned all over the place and using Arduino factory USB firmware for atmega16u2 and nothing.

553  dfu-programmer atmega16u2 erase
  554  dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex
  555  dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex --suppress-bootloader-mem
  556  dfu-programmer atmega16u2 reset
  557  dfu-programmer atmega16u2 erase
  558  dfu-programmer atmega16u2 erase
  559  dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex
  560  dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex --suppress-bootloader-mem
  561  dfu-programmer atmega16u2 reset

The USB is found on the system report:

Communication Device:

  Product ID:   0x0043
  Vendor ID:   0x2341
  Version:   0.01
  Serial Number:   9533633363535160B192
  Speed:   Up to 12 Mb/sec
  Manufacturer:   Arduino (www.arduino.cc)
  Location ID:   0x14100000 / 12
  Current Available (mA):   500
  Current Required (mA):   100

So there is something connected to the USB port but the firmware fails to play nicely with USB.
IDE works but the tty.usbmodem never showed up and I could never try the blink sketch.

I will try to buy a new cable as I tried with another one and it did not work.
I also will try on the other iMac I have see if I'm lucky.

Anything else I should try before contacting Arduino to get a new board?



Me again.

So I figured out a work around. I run Windows 8.1 on Virtual Box (VB) with the same cable and board and I can now upload the blink sketch.

So there is definitely something to do with Mac OS X driver to support the atmega16u2.
Windows 8.1 installed the drivers and I started Arduino IDE and the COM4 for me was my Uno.

I wish it was more simple as I prefer to work on OS X environment but at least 1) this proves my Uno works and 2) this keeps me learning the great platform.

I hope this helps as a work around for someone else.

I'm still interested though on getting this resolved so I don't have to spin off VB everytime I want to work on the board.
Let me know if someone finds a solution.


Go Up