Go Down

Topic: Arduino Mega 2650 r3 timeout when uploading (Read 1 time) previous topic - next topic


Mar 08, 2014, 04:34 pm Last Edit: Mar 08, 2014, 08:49 pm by Diymaker Reason: 1
so i have got my arduino yesterday and it worked fine i have uploaded a couple of sketches and they worked perfectly, but today when trying to upload a sketch it compiles but doesnt upload and gives me the timeout error.
But after compiling the "L" led flashes, and also when i press the reset button the "L" led flashes indicating that there is no problem with the bootloader.
The Problem happened after i tried a program that work with a bluetooth module (connected to pins 0 &1) so i can turn on and off a led using commands from an android device. At first it didnt work so i decided to remove the usb cable and added a powersupply (12v). but also didnt work but after that when i tried uploading code again the error poped up.i got the program to work after realizing that the tx and rx pins are connect the wrong way, and the program worked. I dont think that the board is fried bec i think there is a communication between the arduino and the computer that is shown when the program finishes compiling.
*Tried different usb cables
*Tried different computers
*Tried Arduino 0022
*Tried changing the "wiring" in boards.txt
*Tried tons of drivers
but didnt work :(


Please check

for fix.


Two suggestions,
   don't use D0 and D1 for the bluetooth, they are usually used for upload and download thru the USB
   if you have more than three exclamation points in a row, remove them or update the bootloader.


either its the bootloader or a problem with the atmega16u2 chip, cuz the loopback test doesnt work :/

Go Up