Go Down

Topic: Possibility of using the IDE-Console without connecting the YUN to a Router (Read 25263 times) previous topic - next topic

Hermelinmaster

Hi there,

I got my YUN a few weeks ago. After trying different things with more or less success at home (everything connected to my Home-Network) I went to the University just to figure out that there is no possibility of setting up a network with a router.

[Background story]
I want to regulate a asynchronous linear induction motor with a YUN (controlled by a Smartphone or at least a Win8 Tablet).
Getting variables through the Console was the first mayor part, getting enough Interrupts the second obstacle.
[\Background story]

So I need to create a Network with the Yun (or at least on the Win8 Tablet) so I can access the Console (in the Arduino IDE; maybe even the "Upload"-function of the IDE) just as I would on a Network created by a router.

First I tried to use the Access Point Mode of the YUN out of the Box, but the IDE doesn't seem to find the IP-Adress of the YUN to communicate.
Then I tried to set up a Network (tethering) with my Smartphone, but still no recognition by the IDE (1.5.6-r2).
Setting up a Network with the Tablet failed completely (used this: http://www.howtogeek.com/112050/how-to-turn-your-windows-8-laptop-into-a-wireless-access-point/ ). The Smartphone could not connect to configure the YUN for this new network.

Is there an easy way to get things working just as I need them to? And what if my supervising tutor asks me to get things going on an iPh**e/Win-Phone/Symbian/etc. ? In this case it would pretty much be a necessity to get a network from the YUN.

Thanks in advance for your time and the help. Much appreciate it.

Hermelinmaster

PS: Example Code would be:

Code: [Select]

#include <Console.h>

int LED=13;
float incomingByte =0;

void setup() {
  analogWrite(LED,255);
   Bridge.begin();
  Console.begin();
}

void loop() {
  if (Console.available()){
 if (Console.read() != '\n'){
  incomingByte = Console.parseFloat();
    analogWrite(LED, incomingByte);
  Console.println(incomingByte);
   }
}
   }


PPS: German is my mother tongue, just in case of any mistakes ;-)


Hermelinmaster

Hi again,

I thank you for your answer.
But I should have been more clear.

I want to use the Arduino as a stand alone system and only use a Win8 Tablet (later numerous mobile devices, like android phone) to send something over the console, when I wish to.
So a connection via ethernet is not possible. And as I stated before, the sharing of A connection via the wifi adapter of the tablet/phone does not work with the IDE.

I thank everyone for any hint.
Best regards,
Hermelinmaster


Hermelinmaster

Hi again,

I tried this of course but the IDE can't identify the yun on the IP 192.168.240.x.
So it should work just like this? And what do I do wrong? Or can I just use a SSH-program via this connection to communicate?

Tanks for your help.
Best regards,
Hermelinmaster

noblepepper

If you want the IDE to talk to the Yun, the computer where the IDE is running must be connected to the network the Yun is on  or to the Yun with USB.

If you have the Yun's wireless in access point mode and not connected by Ethernet or USB then you need to connect the computer with the IDE to the Yun's access point instead of your normal network.


Hermelinmaster

Hi again,

Thanks for all your help.
Sadly that was exactly what I tried at first: Resetting the YUNs WIFI (holding down the WIFI Button for 30+s) and joining the network YUN-90...... with the PC running the IDE.
But it does not recognize the YUN in the IDE. Even if the IDE is trying to reach the YUN on 192.168.240.1.
It's allways this Message:
Arduino: 1.5.6-r2 (Windows 8), Board: "Arduino Yún"
"Board at 192.168.240.1 is not available"
Plus the Port-menue of the IDE is grayed out.

I'm greatful for every helpful idea.
Thanks a lot.

Hermelinmaster

Hermelinmaster

#7
Mar 30, 2014, 08:23 pm Last Edit: Mar 30, 2014, 09:50 pm by Hermelinmaster Reason: 1
Update:

I just tried to reset everything again. Now the YUN is connected to my home network again (I can reach its web control panel under the IP 192....40). But the IDE still cannot find the YUN.
I'm starting to get frustrated ;-)
Please help me ^^

Update on the Udate:
It started working in my home network as expected after half an hour of doing nothing.
But after resetting the YUN again to connect to the YUN-90... network and waiting an hour nothing changed. The IDE still cannot find the YUN on the expected IP 192.168.240.1 in the YUN-90... network or anywhere else, while the web control panel is available via Firefox and InternetExplorer under 192.168.240.1.

sonnyyu

The condition of IDE will find the YUN

  • Yun Bonjour service is working.

  • Windows' UDP port 5353 is open (No firewall block)

  • Bonjour for Windows is installed

  • Both Windows and Yun in same subnet.



http://forum.arduino.cc/index.php?topic=188101.msg1554795#msg1554795

Go Up