Go Down

Topic: Shield arduino ethernet (Read 7355 times) previous topic - next topic

tahsc

Mar 27, 2014, 07:47 pm Last Edit: Apr 03, 2014, 03:01 pm by tahsc Reason: 1
Bonjour

J'ai un shield ethernet pour arduino uno que je n'arrive pas à configurer http://www.lextronic.fr/P28673-ethernet-shield-pour-arduino.html

Voici mon code :
Code: [Select]
/*
 Web Server

A simple web server that shows the value of the analog input pins.
using an Arduino Wiznet Ethernet shield.

Circuit:
* Ethernet shield attached to pins 10, 11, 12, 13
* Analog inputs attached to pins A0 through A5 (optional)

created 18 Dec 2009
by David A. Mellis
modified 9 Apr 2012
by Tom Igoe

*/

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac[] = {
 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
IPAddress ip(192,168,1,60);

// Initialize the Ethernet server library
// with the IP address and port you want to use
// (port 80 is default for HTTP):
EthernetServer server(80);

void setup() {
// Open serial communications and wait for port to open:
 Serial.begin(9600);
  while (!Serial) {
   ; // wait for serial port to connect. Needed for Leonardo only
 }


 // start the Ethernet connection and the server:
 Ethernet.begin(mac, ip);
 server.begin();
 Serial.print("server is at ");
 Serial.println(Ethernet.localIP());
}


void loop() {
 // listen for incoming clients
 EthernetClient client = server.available();
 if (client) {
   Serial.println("new client");
   // an http request ends with a blank line
   boolean currentLineIsBlank = true;
   while (client.connected()) {
     if (client.available()) {
       char c = client.read();
       Serial.write(c);
       // if you've gotten to the end of the line (received a newline
       // character) and the line is blank, the http request has ended,
       // so you can send a reply
       if (c == '\n' && currentLineIsBlank) {
         // send a standard http response header
         client.println("HTTP/1.1 200 OK");
         client.println("Content-Type: text/html");
         client.println("Connection: close");  // the connection will be closed after completion of the response
 client.println("Refresh: 5");  // refresh the page automatically every 5 sec
         client.println();
         client.println("<!DOCTYPE HTML>");
         client.println("<html>");
         // output the value of each analog input pin
         for (int analogChannel = 0; analogChannel < 6; analogChannel++) {
           int sensorReading = analogRead(analogChannel);
           client.print("analog input ");
           client.print(analogChannel);
           client.print(" is ");
           client.print(sensorReading);
           client.println("<br />");      
         }
         client.println("</html>");
         break;
       }
       if (c == '\n') {
         // you're starting a new line
         currentLineIsBlank = true;
       }
       else if (c != '\r') {
         // you've gotten a character on the current line
         currentLineIsBlank = false;
       }
     }
   }
   // give the web browser time to receive the data
   delay(1);
   // close the connection:
   client.stop();
   Serial.println("client disonnected");
 }
}


Normalement je dois pouvoir accéder à son interface via son adresse IP (192.168.1.60) connecté à mon routeur mais je n'y arrive pas.

Une idée?

icare

Bonsoir,

Normalement je dois pouvoir accéder à son interface via son adresse IP (192.168.1.60) connecté à mon routeur mais je n'y arrive pas.

Es-tu sur de ton adresse IP local ?
2B OR NOT(2B) = FF
Arduino 1.0.5 à 1.8.5 + gEdit + Ubuntu 18.04 LTS

PhilAin

Bonsoir,
L'adresse MAC du shield est-elle celle déclarée dans le code ?
Sur le PC en mode commande si tu tape : ping  [adresse IP du shield] à tu un retour ?

Artouste


Bonsoir,
L'adresse MAC du shield est-elle celle déclarée dans le code ?
Sur le PC en mode commande si tu tape : ping  [adresse IP du shield] à tu un retour ?

bonsoir
sur un shield ethernet (W5100) l'adresse MAC est celle injectée par le code, il n'y a  pas d'adresse MAC en dur, meme si elles sont livrées avec une etiquette MAC ADRESS   :smiley-mr-green:

Artouste


Bonjour

J'ai un shield ethernet pur arduino uno que je n'arrive pas à configurer http://www.lextronic.fr/P28673-ethernet-shield-pour-arduino.html



Normalement je dois pouvoir accéder à son interface via son adresse IP (192.168.1.60) connecté à mon routeur mais je n'y arrive pas.

Une idée?



Je n'ai pas rejoué avec un shield ethernet depuis qq temps, mais je me souviens depuis l'IDE 1.00 qu'il y avait eu qq modifs
renseigne tous les parametres, pas seulement mac et ip :
Ethernet.begin(mac, ip, dns, gateway, subnet);

tahsc

Bonjour

Merci de vos réponses
je confirme que je suis bien en local et je lui ai définit une adresse IP local proche de celle de mon pc mais je n'ai aucun retour par ping.
Sur ce type de shield l'adresse mac est définit par celle renseignée dans le code donc ce n'est pas un problème d'adresse mac.

Je ne vois pas d'ou pourrais provenir le problème

Une idée???

john_lenfr

#6
Apr 03, 2014, 02:20 pm Last Edit: Apr 03, 2014, 02:30 pm by john_lenfr Reason: 1
Essaie de ne rien mettre entre ton PC et ta carte.

Connecte ton shield direct sur ton PC pour écarter un problème réseau quelconque.
Ensuite coupe ton pare feu et désactive tout anti virus.

Dit nous si tu as toujours le même problème de ping

Autrement Velleman font toujours des notices nickel donc je te conseille de reprendre leur notice de A à Z concernant l'installation, il y a peu être quelque chose que tu as du oublier? Cablage? Déclaration des PINS ?

As-tu essayé avec le code exemple ici:
http://www.vellemanprojects.eu/downloads/files/downloads/ka04_sample_code.zip
?

Car apparent il faut déclarer une bibliothèque spéciale: EtherCard.h ?

XavierMiller

quelles adresses as-tu utilisé ?

Artouste

#8
Apr 03, 2014, 02:50 pm Last Edit: Apr 03, 2014, 02:54 pm by Artouste Reason: 1
bonjour
tu utilise une librairie prevue pour un shield ethernet arduino officiel basé sur un W5100 et ce que tu a acheté est une carte basée sur un ENCJ860.
forcement ça va bien moins marcher  :smiley-mr-green:

perso je n'avais pas été prealablement voir le lien dans la mesure où :

Quote
J'ai un shield ethernet pur arduino uno

et debut de ton code
Code: [Select]
/*
 Web Server

A simple web server that shows the value of the analog input pins.
using an Arduino Wiznet Ethernet shield.


reprend tout à zero en essayant l'exemple cité par Christian

tahsc

j'ai donc téléversé le programme que tu m'a donné mais ou dois je mettre l'adresse IP dans le programme pour pouvoir tester?

Sur l'autre programme, je mettait comme adresse IP 192.168.56.2, l'adresse de mon PC étant 192.168.56.1

Artouste


j'ai donc téléversé le programme que tu m'a donné mais ou dois je mettre l'adresse IP dans le programme pour pouvoir tester?

Sur l'autre programme, je mettait comme adresse IP 192.168.56.2, l'adresse de mon PC étant 192.168.56.1

rapidement regardé
le programme attribue l'adresse IP par DHCP
déjà regarde ce que cela donne dans le serial monitor lorsque tu utilise le programme  8)
connecte toi ensuite avec l'adresse IP attribuée

tahsc

Quand je met le serial monitor j'ai ...... RIEN!!!

Je précise que j'ai moi meme monté le module (donc soudé) et apparament il y a des contacts partout, sur la prise RJ45 j'ai les deux led allumée.

Je ne vois pas quoi faire

Artouste


Quand je met le serial monitor j'ai ...... RIEN!!!

Je précise que j'ai moi meme monté le module (donc soudé) et apparament il y a des contacts partout, sur la prise RJ45 j'ai les deux led allumée.

Je ne vois pas quoi faire

tu a bien mis le serial monitor à 57600 ?  8)

tahsc

AHH mercii j'avais oublié de mettre sur 57600.

Mais la il me met DHCP failed

Artouste


AHH mercii j'avais oublié de mettre sur 57600.

Mais la il me met DHCP failed

Alors ton shield n'est pas reconnu
fais des photos (claires , lisibles) de tes soudures

Go Up