Go Down

Topic: Problème avec un ARLCD. (Read 3961 times) previous topic - next topic

Vidou12

Apr 02, 2014, 01:26 pm Last Edit: Apr 16, 2014, 05:29 pm by Vidou12 Reason: 1
Bonjour à tous.

J'ai récemment acquis la carte ARLCD.
Seulement voila.
J'ai voulu bidouiller un peut et je me suis retrouvé avec une carte "morte".
Je m'explique :
Je l'ai déballer et tester avec les exemples de la librairie après avoir fait ma mise a jour.
Suite à cela, je fais mon premier programme. Tout fonctionne bien sauf au démarrage je vois un écran avec écrit ARLCD TOUCHSCREEN etc.
Je me dis que ce doit être une image présente dans la mémoire flash.
Je pars donc a sa recherche et quand je la trouve je décide de la changer.
1er essais pas trop concluant : l'image est déformée plus petite que l'écran et des inscriptions s'affichent en haut de l'écran.
J'agrandis donc mon image. Et la : c'est le drame.
Apres un reset : écran blanc figé plus rien a faire. Plus accès a la mémoire flash rien.
Donc je voulais savoir si vous aviez des info la dessus perso je n'ai rien trouvé...
Par avance merci.
Cordialement.

B@tto

Aucun code + aucun branchement + aucun lien = aucune aide possible
Blog électronique : battomicro.wordpress.com
Photographie : www.interactive-celebration.fr
Fablab de Montpellier : www.labsud.org

john_lenfr

Quote
Use safemode if the user programs a sketch into the
arLCD which disables or otherwise causes the GPU into an unwanted state and no
longer can update new sketches.

Vidou12

#3
Apr 02, 2014, 03:28 pm Last Edit: Apr 16, 2014, 05:29 pm by Vidou12 Reason: 1
Niveau branchement il n'y a qu'un câble USB. Tout le reste est dans le module.
Pour les liens : http://store.earthlcd.com/Downloads
tout est là.
Merci.
PS : Je n'ai pas accès au safe mode. Ecran blanc direct !

john_lenfr


Vidou12

#5
Apr 03, 2014, 02:28 pm Last Edit: Apr 16, 2014, 05:29 pm by Vidou12 Reason: 1
j'essaye de communiquer avec eux mais c'est aux états unis et en anglais donc traduction + décalage horaire a attendre 1 jour entre chaque étapes :/ d'autant plus que pour l'instant ils ne m'ont pas été d'un grand secours j'espérais qu'en France il y ait quel-qu'un dans mon cas ou capable de m'aider. :/  

john_lenfr

Alors? Quelles sont les nouvelles?

Vidou12

ils m'ont envoyé un nouveau mais pareil .... écran blanc impossible de communiquer.... je me demande si c'est pas mon pc qui foutrait la merde...

john_lenfr

Hum, oui, c'est bizarre d'avoir 2 cartes de suite qui plantent.
Peut-être qu'il t'on renvoyé ta carte initiale?
En tout cas vaux mieux tester avec un autre ordi oui.
Mais le module n'est pas autonome?

icare

Bonjour,

Hum, oui, c'est bizarre d'avoir 2 cartes de suite qui plantent.
Peut-être qu'il t'on renvoyé ta carte initiale?
En tout cas vaux mieux tester avec un autre ordi oui.
Mais le module n'est pas autonome?

Par expérience, il faut toujours mettre une petite marque discrète sur les produits que l'on retourne.
2B OR NOT(2B) = FF
Arduino 1.0.5 à 1.8.5 + gEdit + Ubuntu 18.04 LTS

Vidou12

#10
Apr 16, 2014, 05:24 pm Last Edit: Apr 16, 2014, 05:28 pm by Vidou12 Reason: 1
Non c'est pas le même je n'ai pas eu a le renvoyer. En fait j'ai voulu (si vous connaissez ou avez lu dans le lien comment mettre à jour) le mettre à jour je l'ai donc branché et appuis sur le coin droit.
j'ai eu l’écran qui me confirme que je suis en mode mise à jour mais après impossible de lire la mémoire flash pour remplacer les fichiers ni rien. Le pc me fait le bruit de "oh oui je vois que tu me branche un périphérique que je connais" mais rien de plus :/. et après un redémarrage même topo : écran blanc et rien a faire... 

john_lenfr

Et ya pas un driver/pilote à installer pour ton périphérique?
As tu regardé dans le gestionnaire?

Vidou12

Si, il y a un driver mais il est installé.
Là ou je sèche c'est qu'il ne m'affiche rien le gestionnaire de périfs...
Avant il m'affichais ARLCD blabla en connecté. Là rien....
Mais je crois que j'ai trouvé une solution au pb. Je vous tiendrais informé si jamais ça venait à vous arriver.

Vidou12

j'ai un nouveau pb :/ l'ors de la compilation, ce message s'affiche :

In file included from Morpion_ARlcd.ino:1:
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:40: error: expected identifier before '(' token
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:40: error: expected `}' before '(' token
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:40: error: expected unqualified-id before 'volatile'
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:40: error: expected `)' before 'volatile'
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:40: error: expected `)' before 'volatile'
C:\Users\Vidou\Desktop\Arduino\libraries\arLCDLib/ezLCDLib.h:56: error: expected declaration before '}' token

est-ce normal ??

DivertyArduino

Bonjour, j'ai le même problème que vous. Pourriez-vous me communiquer votre solution pour ce problème s'il vous plaît?  Merci d'avance pour votre réponse.

Go Up