Go Down

Topic: Grbl et l'ide Arduino (Read 41326 times) previous topic - next topic

infobarquee

c'était ce fichier
https://github.com/zapmaker/GrblHoming/blob/master/trlocale/GrblController_fr.ts
mais je ne retrouve pas mes modifs, et github, j'en suis a la découverte pour retrouver des modifs faites. :(
AUCUNE AIDE PAR MP

LETARTARE

@infobarquee,
pour modifier il faut les droits d'écriture !!

infobarquee

oui, les modifs avaient été prises en compte dans un autre fichier montrant les différences pendant 2 jours.
et puis plus rien.
AUCUNE AIDE PAR MP

LETARTARE

Bonjour,
sur mon site https://github.com/LETARTARE/GrblHoming/tree/Letartare
je vous propose une version 'GrblController-3.6.1-T1,' qui permet de détecter deux versions 3 axes et 4 axes correctement (0.8c et 0.8c1 qui devrait arriver aujourd'hui) et visualise ,lors de l'envoi d'un fichier sur la carte, les numéros de lignes du fichier, s'il n'en existent pas.

A bientôt.

LETARTARE

Bonjour,
sur mon site https://github.com/LETARTARE/Grbl-xx_with_Arduino/tree/master/Grbl8c1Mega2560, voici enfin la '0.8c1', une version quatre axes de la version officielle '0.8c'.
Attention au brochage qui est semblable, en partie, à la '0.845' qui risque de devenir obsolète.

Pour GC-3.6.1-T1,  je n'ai fourni que les sources avec des fichiers de fabrication pour 'Win32' ; mais je crois qu'avec le fichier *.pro on doit pouvoir l'utiliser sous Linux si la bibliothèque 'Qt-4.?.?' est installée.
Pour 'VISTA pro'  j'ai installé  'Qt-4.7.3' et 'MINGW32-TDM-4.7.1".

Bon tests.

LETARTARE

Bonour,
voici la version Grbl '0.8c2' avec un brochage (différent de la '0.8c1')  étendant celui de la '0.8c' au 4ème axe.
https://github.com/LETARTARE/Grbl-xx_with_Arduino/tree/master/Grbl8c2Mega2560 .
Notez une petite correction sur 'GC-3.6.1-T1' pour une commande manuelle qui générait toujours des valeurs négatives !

A bientôt.

infobarquee

je viens de faire un flash du dernier firmware, mais un truc me chiffonne un peu par rapport aux autres versions.
on a plus l'affichage des paramètres au boot, ou alors j'ai pas percuté sur un truc.
AUCUNE AIDE PAR MP

LETARTARE

Bonjour,
non cela est normal, car à force de faire de nombreux essais, l'affichage complet des paramètres est plutôt une pollution.
Aussi je l'ai momentanément enlevé de 'GC-3.6.1-T1' et réduit dans '0.8cx'; vous devez avoir ceci :
Code: [Select]
Mega2560 with 4 axes (X, Y, Z, A)
Grbl 0.8c2 ['$' for help]

Les commandes "$" et "$$" vont fournir tout le nécessaire.

Bon courage.

infobarquee

j'avais vu ceci
par contre bug génant
si on rentre une commande non reconnue, ca fait planter.
ex :
$x=200
Grbl error: Unsupported statement
AUCUNE AIDE PAR MP

LETARTARE

#129
Jun 07, 2014, 06:10 pm Last Edit: Jun 07, 2014, 06:22 pm by LETARTARE Reason: 1
c'est l'officielle '0.8c' qui génère ce message !!

infobarquee

c'est bien la tienne, celle que tu as mentionné au dessus
8c2mega2560
AUCUNE AIDE PAR MP

LETARTARE

je m'explique : la mienne '0.8c2' est une adaptation de la version officielle '0.8c' et c'est la partie officielle qui génère ce message et heureusement car cela montre que l'analyse syntaxique et lexicographique fonctionne correctement.

infobarquee

je vais pas prendre une verveine à cette heure ci :) ou aller me coucher
si je veux changer les pas de chaque axe comme sur l'autre,
$0=200 pour l'axe X
ca mesort une erreur, c'est ca que je voulais dire.

j'ai aussi changé dans le fichier default.h le nombre de pas, masi cela me ressort toujours
Code: [Select]
$0=100.000 (x, step/mm)
$1=100.000 (y, step/mm)
$2=100.000 (z, step/mm)
$3=100.000 (t, step/deg.)
AUCUNE AIDE PAR MP

LETARTARE

#133
Jun 07, 2014, 07:39 pm Last Edit: Jun 07, 2014, 07:44 pm by LETARTARE Reason: 1
Bonsoir,
je viens de faire le test suivant ( en regardant la finale du double en Tennis à Roland Garros  :))
- 'GC-3.6.1-T1'
- Grbl '0.8c2'
$0=120 -> cela est pris  en compte correctement.
J'ai ajouté justement une possibilité de toujours recharger (ou non)  les valeurs par défaut dans la carte dans
Code: [Select]
'config.h:L47'  #define ALWAYS_DEFAULTS_SETTINGS  1  // update always
D'autre part, je constate que sur la version 3.6.1-T1 ( contrairement à ce que j'ai dit dans un message précédent ou je confondais avec la T2 ou T3), on donne la configuration d'emblée par "$$".
Je joins une photo pour le premier test.

LETARTARE

avec une modification du fichier  'default.h:L87' -> #define USER_PITCH_SCREW   5  // 4mm for all linear axes
voici le résultat :

Go Up