Go Down

Topic: Communication module xbee (Read 2539 times) previous topic - next topic

Sokky

Bonjours, nous travaillons actuellement sur un projet comptant pour le bac (terminale sti2d sin) où nous devons faire communiquer un module xbee qui est sur une carte arduino et un autre possédant l'adaptateur usb pour le connecter directement sur le pc. Nous rencontrons actuellement un problème dans l'envois des informations car les deux modules xbee ne ce reconnaissent pas et donc ne communique pas entre eux.
Merci de votre patience et de votre coopération pour nous aider.
Cordialement.

icare

Bonjour,
Peux-tu nous transmettre ce que vous avez déjà fait et votre montage.
La version du logiciel du forum ne permet pas de deviner où vous en êtes et la plus part des participants du forum ne sont pas devins et n'ont plus de boule de cristal
:D
@+
2B OR NOT(2B) = FF
Arduino 1.0.5 à 1.8.5 + gEdit + Ubuntu 18.04 LTS

john_lenfr

Je crois qu'il va falloir créer un répertoire spécial "Sujet du BAC" ou "Projets TPE" avec une réponse type ou une trame type du style:


  • Code utilisé ?

  • Matériel utilisé ?

  • Photo du montage / cablage ?



:smiley-mr-green:

Sokky

#3
Apr 08, 2014, 02:07 pm Last Edit: Apr 08, 2014, 03:01 pm by Sokky Reason: 1
Bonjour.
Nous avons actuellement une carte arduino avec un shield XBee et un xbee usb branché à l'ordinateur, nous utilisons le logiciel XCTU qui est sur le site fabricant de Xbee ( digi.com). Nous avons aussi programmer l'arduino avec ceci:

Code: [Select]
void setup() {         //Arduino initial setup
 Serial.begin(9600);      //set baud rate on Arduino to 9600

}

void loop() {         //loop program

Serial.print("L");       //Send the character L
delay(2000);         //wait 2 seconds
Serial.print("H");      //Send the character H
delay(2000);         //wait 2 seconds


 }

provenant de ce site: http://robotique-projet.lebonforum.com/t385-tutoriel-pour-xbee-module-et-xbee-shield-avec-arduino

Le problème que nous rencontrons est que le module receveur USB ne reçoit pas ce qu'envoie le module xbee qui est sur l'arduino.
Cordialement.

icare

Re,
Pour que votre code soit lisible, il faut utiliser les balises # et faite "Preview" pour voir le résultat avant  "Post"
@+
2B OR NOT(2B) = FF
Arduino 1.0.5 à 1.8.5 + gEdit + Ubuntu 18.04 LTS

Sokky


john_lenfr

Quand j'avais testé mes modules XBee avec XCTU je n'avais eu aucun problème car en sortie d'usine ils sont prêts à fonctionner.
Avez-vous bien sélectionné le bon port COM et le bon baudrate (9600) sur XCTU?
Quel module XBEE vous avez? Xbee pro? Avec antenne intégrée? Sans?

Le shield pour le xbee c'est quel modèle? Il a une alimentation intégrée? Il y a un inter dessus?

Car le XBee partage la connection TX RX sur les ports 0 et 1 de la carte Arduino donc si vous avez laissé tel quel si ça se trouve vous envoyer rien.

Que disent les leds d'état du shield? du XBee? De la partie récepteur?

Sokky

voici l'image du montage du projet.

john_lenfr

#8
Apr 08, 2014, 03:49 pm Last Edit: Apr 08, 2014, 03:55 pm by john_lenfr Reason: 1
Ok sur ton shield il y a un petit inter avec marqué "XBEE/USB" je pense qu'il est pas du bon côté  :smiley-mr-green:

Côté "USB" pour programmer ta carte Arduino
Côté "XBee" pour commencer à émettre avant d'avoir fait un "reset"

Pour le reste je te conseille de lire ça:
http://www.dfrobot.com/wiki/index.php/IO_Expansion_Shield_for_Arduino_V7_SKU:DFR0265

et ça:
http://www.dfrobot.com/wiki/index.php/Xbee_Shield_For_Arduino_(no_Xbee)_(SKU:DFR0015)

Sokky

Merci de votre aide c'était bien ça, un petit détail sur lequel je n'ai pas fais attention ...  :smiley-sweat:

john_lenfr


PierrickJu37

COUCOU, Tu Veux Voir Malphite ?!!!
Hein xBee OP so Abeille ! $)

Go Up