Go Down

Topic: Arduino Robot Official stuck on example sketch "Logo" (Read 2067 times) previous topic - next topic

Noppe

Hey guys,

I just had a chance to play with an official arduino robot (which is basically two leonardo's).

I had uploaded the "Logo" sketch from IDE 1.5 and now I can not upload anything else!?

If you now an easy solution to this problem; by easy I mean from the usb, I'd really appreciate it.

Otherwise, I guess have to use the ICSP pins to resolve this issue?

Thanks!


PaulS

You might get more help if you explained what the problem is.

Quote
and now I can not upload anything else!?

Why not? You certainly have our permission to try.
The art of getting good answers lies in asking good questions.

Noppe

fair enough,  :)

Let me tell you what happens when I try to upload:

1) Compilation
2) says uploading
3) the robot control board resets; by that I mean:
              -RX line flashes a couple times fast
              - LCD screen goes blank
4) immediately after that the current sketch is operational again and the IDE is stuck at "uploading..." for a little while more
5) This output is resulted:
################################################
avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM6
         Using Programmer              : avr109
         Overriding Baud Rate          : 57600
         AVR Part                      : ATmega32U4
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PA0
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :
###################################
and this:
###################################
Found programmer: Id = "†ÿ("; type = a
    Software Version = E.
...
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?
###################################

What I tried: Pressing reset before upload and on compilation, pressing reset before the usb cable is plugged, fixing the preferences.txt because somehow it was not reflecting the current options selected on the IDE (wrong board, wrong com etc.)

So do you think any of this is helpful?

thanks !

Noppe

by the way,

the current sketch operational on the atmega32u4 chip is the example code from the IDE "R01_Logo".

I'm aware that some bad coding might cause the chip to jam the serial port but this is an example sketch....

Also, I'm using Win 7, 64 bit. I don't know if my USB is 2.0 or 3.0

Noppe

Ok guys, new update:

After a bit struggling, I managed to "try" to upload the arduino robot control bootloader hex file via avrdude.

This is the result:
##################
avrdude: Device signature = 0x1e950f
avrdude: Device signature for ATmega32u4 is 1E 95 87
...
some stuff about flash erase and rewrite
...
flash rewrite verify fails.
###############

So can I ask, why is my device signature wrong?

Noppe

Solved this problem, please read:

http://forum.arduino.cc/index.php?topic=232168.msg1674921#msg1674921

Go Up