Go Down

Topic: Please upgrade your Yún - latest is 1.3 (Read 56344 times) previous topic - next topic

Jantje


- Linux side ready visual notification: when linux boot completes, the usb led lights up (it's bright white)

It is really hard not to see it. Happy to know it is normal :-)

Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

federicofissore

FYI I've changed last "Bridge solved issue" line to
- Bridge is now run with "-u" python flag, preventing some random lockups in the Bridge
as the 64K issue is not related.

If you run into troubles using some Process.run with large outputs, you must use the asynchronous version. Since Bridge (with Process.run) is waiting for the process to end before start consuming its output and since Linux is waiting for the output to be consumed before putting more into the buffer, they both will block. With the asynchronous version, output is immediately consumed by bridge

msssltd

Just want to say thank you for the update.

I upgraded one of my Yun's yesterday.  I completed the upgrade over the network and all went smoothly.  Took me about an hour, including re-installing packages and restoring my own scripts

Really good to see we can use all the OpenWRT packages, so I won't have to install nginx manually.

For the moment I am using the uhttpd server for my PHP application.  Interestingly, a bit of javascript which had been causing one of the pages to crash fcgi , after being left open in a browser for a couple hours, has been running Ok all night.

So to Fredrico and anyone else who may have contributed, you have my thanks.


avenue33

#18
Apr 28, 2014, 03:12 pm Last Edit: Apr 28, 2014, 03:14 pm by avenue33 Reason: 1
I've proceeded with the recommended upgrade. But now, when my Yun is connected to the network, the [font=Courier]arp -a [/font] command doesn't list [font= Courier]arduino[/font] but [font= Courier]host-001[/font] instead --[font= Courier]192.168.1.24[/font] is the address of the Yun.

Code: (Yun) [Select]
# uname -a
Linux myYun 3.3.8 #1 Fri Apr 11 07:16:38 CEST 2014 mips GNU/Linux


Code: (Mac) [Select]
$ arp -a
mac (192.168.1.1) at 11:22:33:44:55:66 on en1 ifscope [ethernet]
host-001 (192.168.1.24) at cc:dd:ee:ff:00:11:22 on en1 ifscope [ethernet]
router.lan (192.168.1.254) at 77:88:99:aa:bb:cc on en1 ifscope [ethernet]


Even performing a [font=Courier]sudo arp -d -a[/font] didn't solve the problem.

Are you experiencing something similar? Thank you!

bjarne

First off, big thank you for the new image !

I installed it from a USB stick as mentioned earlier in this thread, worked like a charm.  I got everything re-configured as I had it before.  A couple of minor questions:

1.  I copied my Mac id_rsa_pub key to ~/.ssh/authorized_keys on the Yun, but I still have to enter my password when I ssh into the Yun.  This worked for the old image, did I forget something, or has this changed in the new image ?

2.  I think I remember some talk about being able to upload via the IDE without password, I never did get that to work (on the old or new image).  There was some allusion to a new version of the IDE which would allow this, did this ever happen ?

tdicola

Just throwing in my experience with the upgrade, it went smoothly and the Yun seems to be working great.  I really like the new indicator LED for when the Linux side is booted.  Overall seems like a great upgrade, thanks!

Tunell

#21
Apr 29, 2014, 10:44 pm Last Edit: Apr 29, 2014, 10:59 pm by Tunell Reason: 1
Just tried plugging in a USB keyboard and it was not given an event number. Still only shows event0.
Normally it will set up the keyboard as event1.

No dice.

Will have to go back to the old method :(

edit: the old method doesn't anymore apparently....
The keyboard shows up as having been attached in dmesg, but is not assigned an event#

Now starting from scratch on getting USB keyboard to work. DANG IT.

federicofissore

@bjarne: yun uses dropbear by default, so file is /etc/dropbear/authorized_keys

@Tunell I have a logitech usb keyboard. I've run
Code: [Select]

root@Arduino:/# opkg update
root@Arduino:/# opkg install kmod-usb-hid
root@Arduino:/# reboot

and when I plugged in my keyboard, it printed
Code: [Select]

root@Arduino:/# [   62.780000] usb 1-1.1: new low-speed USB device number 4 using ehci-platform
[   62.920000] usb 1-1.1: New USB device found, idVendor=046d, idProduct=c312
[   62.920000] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   62.920000] usb 1-1.1: Product: USB Multimedia Keyboard
[   62.920000] usb 1-1.1: Manufacturer: LITEON Technology
[   63.030000] input: LITEON Technology USB Multimedia Keyboard as /devices/platform/ehci-platform/usb1/1-1/1-1.1/1-1.1:1.0/input/input1
[   63.040000] generic-usb 0003:046D:C312.0001: input: USB HID v1.10 Keyboard [LITEON Technology USB Multimedia Keyboard] on usb-ehci-platform-1.1/input0
[   78.410000] usb 1-1.1: USB disconnect, device number 4


Running
Code: [Select]
cat /dev/input/event1 | hexdump printed "things" when pressing the enter key

rmagnus

I did the update but the linino side stopped responding.

The arduino side works.

And the linino ends with a kernel panic message.

I have attached the output here.

Any ideas?

Thank you

Rodolfo

federicofissore

Looks something went wrong with the onboard flash. You can try with the advanced procedure http://arduino.cc/en/Tutorial/YunUBootReflash (you may skip the uboot section) or mail support@arduino.cc and ask for a replacement

chetto983

Do you Know about wifi stability?

federicofissore

There was some hardware software interference between wifi and usb. That's all I know it has been fixed regarding wifi. It may still  be better though, as a consequence of sticking with stable openwrt

bjarne


@bjarne: yun uses dropbear by default, so file is /etc/dropbear/authorized_keys

Thanks Frederico, that works.

Tunell

Keyboard works!
Would be nice if Kmod-usb-hid were included by default, I'm deploying a fleet of yuns for a networking project. It would be nice if I didn't have to connect to the internet to get a keyboard working.
But it's awesome to have this up and running now.

federicofissore

Yep, unfortunately disk space on yun is a constraint. Best is that you make your own customization.

Setup instructions are available at https://github.com/arduino/openwrt-yun

Once you're ready to build, manually execute the first part of the build script
https://github.com/arduino/openwrt-yun/blob/master/build.sh#L1-L21

then run
Code: [Select]
make menuconfig. Look for the kernel modules you wish preinstalled: they are selected as "M" (module), select them as "*" (built-in)

Finally build the image running
https://github.com/arduino/openwrt-yun/blob/master/build.sh#L27

Go Up