Go Down

Topic: avrdude - not responding & other problems (Read 2381 times) previous topic - next topic

nitramf

Hi,

I just tried to get started with my YUN. When uploading Sketches to the Yun the following error occurs:
root@Arduino:/etc/arduino# run-avrdude ./base.hex

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.


avrdude done.  Thank you.

If I try to read the value of a single pin (http://arduino.local/arduino/analog/28) I get the following message:
Could not connect to YunServer 146 Connection refused


What is the problem here?
I've googled a lot and this post won't help me:
http://forum.arduino.cc/index.php?topic=209587.msg1542895#msg1542895
If I change the value and fire up this:

Code: [Select]
/usr/bin/run-avrdude    /etc/arduino/Caterina-Yun.hex

I get the same error as above from avrdude.

I did an upgrade to the latest software. (http://arduino.cc/en/Main/Software#toc8)
I have tried it both with the windows and mac ide (beta for yun)
Please help me :)

Thank you,
nitramf

noblepepper

#1
May 17, 2014, 06:46 pm Last Edit: May 17, 2014, 06:54 pm by noblepepper Reason: 1
I believe you are using the network connection to upload sketches, correct? If so try the links below, also confirm that you can upload sketches through USB.

Try this http://forum.arduino.cc/index.php?topic=238130.msg1712639#msg1712639, while using a voltmeter to see if MISO changes is the definitive answer, Quiggers found http://forum.arduino.cc/index.php?topic=238130.msg1713401#msg1713401 his gpio to enable the voltage translator did not change in Linino so check that first.


nitramf

It does not appear in the port-list (both on mac and windows)

maybe I try to get it solved with an exchange.


noblepepper

It sounds like there are troubles on the 32u4 side, when you press the 32u4 reset does the yellow led flash 1-2 seconds later? If not a n exchange may be the best course...

federicofissore

Does it work if you use the Arduino IDE instead?
Regarding the "connection refused": does the sketch use Bridge?

Go Up