Go Down

Topic: Arduino Pro Mini & USB To RS232 Cable (Read 8495 times) previous topic - next topic

Alferciu

Hello everybody  :)

I bought two arduino pro mini from banggood and a programming cable, but i haven't make it possible to program it, following most of the tutorials i found in internet.

The arduinos are these: http://www.banggood.com/Wholesale-New-Ver-Pro-Mini-ATMEGA328-328p-5V-16MHz-Arduino-Compatible-Nano-Size-p-68534.html
And the cable is this one: http://www.banggood.com/USB-To-RS232-Or-TTL-Serial-FTDI-Chipset-FT232-Computer-Converter-Cable-p-80871.html

Did anyone were able to program it?
Thanks  :)

fungus

That cable only has 4 connectors, you need 5.


PS: How come nobody ever asks us what to buy? They go out and buy stuff then come here when it doesn't work and expect us to fix it.
Advanced Arduino

Paul__B

#2
May 23, 2014, 10:30 pm Last Edit: May 25, 2014, 09:27 am by Paul__B Reason: 1
"fungus" is being somewhat scurrilous here, as he knows the answer only too well.  And they do not make five-pin USB to TTL cables.

The original FTDI cable for which the Pro Mini was designed, had six connections, including the RTS and CTS control lines, and the RTS line is used to reset the MCU at the point of starting the code download.

{OK, so I originally typed CTS in error there.
Causing  fungus to type:


The RTS and GND are tied together so really it's only 5 (and yes, they make 5-pin cables).

When he meant CTS.   Just so no-one else gets confused.  OK?  :D}

If you do not have that connection, you need to press the reset button for half a second (only) at the point where you see "Uploading" in the blue status bar at the bottom of the IDE window, and "Binary sketch size: xxxx bytes (of a 30720 byte maximum)" in the message window below.  You may have to practice this a few times to figure out the proper timing.

fungus


The original FTDI cable for which the Pro Mini was designed, had six connections, including the RTS and CTS control lines, and the CTS line is used to reset the MCU at the point of starting the code download.


The RTS and GND are tied together so really it's only 5 (and yes, they make 5-pin cables).


If you do not have that connection, you need to press the reset button for half a second (only) at the point where you see "Uploading" in the blue status bar at the bottom of the IDE window, and "Binary sketch size: xxxx bytes (of a 30720 byte maximum)" in the message window below.  You may have to practice this a few times to figure out the proper timing.


On every upload? Ain't nobody got time fo' dat.
Advanced Arduino

Alferciu


"fungus" is being somewhat scurrilous here, as he knows the answer only too well.  And they do not make five-pin USB to TTL cables.

The original FTDI cable for which the Pro Mini was designed, had six connections, including the RTS and CTS control lines, and the CTS line is used to reset the MCU at the point of starting the code download.

If you do not have that connection, you need to press the reset button for half a second (only) at the point where you see "Uploading" in the blue status bar at the bottom of the IDE window, and "Binary sketch size: xxxx bytes (of a 30720 byte maximum)" in the message window below.  You may have to practice this a few times to figure out the proper timing.



Thanks, just tried that and couldn't upload :/
I also tried using an arduino mega as uploader (http://www.instructables.com/id/Arduino-Examples-2-Use-an-Arduino-as-a-FTDI-Progr/?lang=es). Didn't work.

I dont know if im doing something wrong... i guess not

Paul__B

OK, well without the RTS line, you will have to do the manual reset as described.


I also tried using an arduino mega as uploader. Didn't work.


Frankly, if the cable does not work, I feel it is better to continue to figure out why it won't work, and address that, rather than trying all the other ways that it will not work.

The other thing you need to try is to swap the Rx and Tx lines on the FTDI cable - still with the manual reset.

By the way, Arduinos - including clones - almost always come with the "blink" program loaded.  If it is not blinking before you first try to program it, you would have reason to suspect the chip does not have the bootloader programmed either, in which case you would need to use your 2560 as an ISP to load that, as per Nick Gammon's instructions.


retrolefty

#6
May 25, 2014, 12:55 am Last Edit: May 25, 2014, 01:00 am by retrolefty Reason: 1

"fungus" is being somewhat scurrilous here, as he knows the answer only too well.  And they do not make five-pin USB to TTL cables.

The original FTDI cable for which the Pro Mini was designed, had six connections, including the RTS and CTS control lines, and the CTS line is used to reset the MCU at the point of starting the code download.

If you do not have that connection, you need to press the reset button for half a second (only) at the point where you see "Uploading" in the blue status bar at the bottom of the IDE window, and "Binary sketch size: xxxx bytes (of a 30720 byte maximum)" in the message window below.  You may have to practice this a few times to figure out the proper timing.



CTS (clear to send) is an input pin for the FTDI and not used by the arduino. RTS (request to send) or DTR (data terminal ready) are output pins on an FTDI chip and either can be used to send the IDE reset pulse to start the AVR bootloader.

One can see how a FTDI chip is used in an older arduino board as far as the FTDI pins that are used.
http://arduino.cc/en/uploads/Main/arduino-duemilanove-schematic.pdf

Alferciu


OK, well without the RTS line, you will have to do the manual reset as described.


I also tried using an arduino mega as uploader. Didn't work.


Frankly, if the cable does not work, I feel it is better to continue to figure out why it won't work, and address that, rather than trying all the other ways that it will not work.

The other thing you need to try is to swap the Rx and Tx lines on the FTDI cable - still with the manual reset.

By the way, Arduinos - including clones - almost always come with the "blink" program loaded.  If it is not blinking before you first try to program it, you would have reason to suspect the chip does not have the bootloader programmed either, in which case you would need to use your 2560 as an ISP to load that, as per Nick Gammon's instructions.




Hello! I noticed that i have a yellow triangle in the device's com port.
Read in prolific's webpage that the drivers doesn't work properly with the chinesse cable on windows 8, so that is the cause why i can't program it in my computer, so i tried in my brother's pc which has windows XP (i could install the drivers correctly), but still getting "not in sync" error (pressing reset at the right moment)
And yes, the arduino come with the blink program.

What could I do?

Thanks :)

Paul__B

Not sure why Chinese cables would be relevant to any operating system other than Apple.

Have you tried the Tx and Rx swap?  Note that reset must be pressed and (more importantly) released at the right time - it does take some practice, and it may need to be more like a second after "Uploading" appears.

Beyond that, it gets rather tricky.

twister1

It helps a lot when you enable debugging output in the Arduino IDE settings so you can see when exactly Arduino IDE starts uploading the sketch and then press the reset button.

The output looks like that:
Code: [Select]

avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "/home/maxtothemax/arduino-0022/hardware/tools/avrdude.conf"
         User configuration file is "/home/maxtothemax/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/ttyUSB1
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]


when you see Arduino IDE is calling avrdude then press the reset button.

With the output enabled I've got almost 100% success with uploadings.

Good luck!

Alferciu

#10
May 26, 2014, 03:58 pm Last Edit: May 26, 2014, 04:00 pm by Alferciu Reason: 1
I sucessfully programmed it in another computer with windows XP, the problem is that the new prolific drivers are not supported in windows 8.
I fixed it and now I can program it in my pc.
Here is the solution for Windows 8 users:

1. Download PL2303 Prolific Driver v1.5.0 (i did from here: http://dl.nguyenhoa.net/e107_plugins/download/download.php?view.23)
2. Unplug the cable
3. Uninstall latest drivers from control panel
4. Install v1.5.0 drivers
5. Plug the cable. Windows will update to the latest drivers.
6. Go to Device manager, right click on the prolific device and Update driver software.
7. Select "Browse my computer for driver software" and then “Let me pick
from a list of device drivers on my computer”
8. Select oldest drivers and Next
9. Done  :D

Source: http://www.dieselboss.com/software/PL2303HXA%20Windows%208%20Driver%20Installation.pdf


It helps a lot when you enable debugging output in the Arduino IDE settings so you can see when exactly Arduino IDE starts uploading the sketch and then press the reset button.

The output looks like that:
Code: [Select]

avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "/home/maxtothemax/arduino-0022/hardware/tools/avrdude.conf"
         User configuration file is "/home/maxtothemax/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/ttyUSB1
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]


when you see Arduino IDE is calling avrdude then press the reset button.

With the output enabled I've got almost 100% success with uploadings.

Good luck!



Thanks for the tip, very helpful :)

Paul__B


Thanks for the tip, very helpful :)


Does that mean you have it figured out and are successfully uploading using the manual reset?

Alferciu



Thanks for the tip, very helpful :)


Does that mean you have it figured out and are successfully uploading using the manual reset?



Yes, that's right :)

Go Up