Go Down

Topic: MPU6050/MPU6500/MPU9150/MPU9250 library over I2c (Read 67200 times) previous topic - next topic


I tried to use your library with multiple sensors but it was not working. Is there any method.


Thank you for the library- very helpful!

I am pretty new to this and am hoping to use the EM MPU9250 breakout with my Arduino Uno, unfortunately I'm having an issue finding the device.  When I run the i2c scanner, I see the following:

I2C Scanner
No I2C devices found

I don't quite know how to address this problem and hope you might offer some insight.

Thank you


Hello! Using AvrCopter project to run the arduino Uno with MPU 9150.
It runs ok. But for a few seconds only I get some results, after that I receive the following error:

Seems like the quaternion check fails. its out of range. and never comes to normal range. So

ret = mympu_update();

after few seconds starts returning 3.

Before there was an issue with firmware compare failure. Which I fixed by setting Fastwire speed from 400 to 200.

No trying to understand the nature of this error I saw the following comments:

* We can detect a corrupted FIFO by monitoring the quaternion data and
         * ensuring that the magnitude is always normalized to one. This
         * shouldn't happen in normal operation, but if an I2C error occurs,
         * the FIFO reads might become misaligned.
         * Let's start by scaling down the quaternion data to avoid long long
         * math.

How can I find out if there was a I2C error (if that was the cause)?
In any case how can I resolve the issue?


I'm trying to use this software with a MPU6500 that has the address 0x1c instead of 0x68. I tried to change the MPU6050.h file by changing everywhere I found 0x68 with the new value but no luck...
Result is:
Testing device connections...
MPU6050 connection failed
a/g:   67   -4965   -930   17388   -25604   24072

I'm new with arduino, can someone to help me? Thank you!


I could not get this sketch working with my MPU9255 chip at first. 

I have tried that slightly modified  sketch  and it worked :   https://github.com/moderndevice/MotionPlug

I went back to the avrcopter sketch and inexplicably it sudently it work.  I am scratching my head.

Be careful : long SDA and SLC cable (or poor connection)  an cause problem.  Use pull up resistor if you use 5V board - see Motionplug.ino  intro remarques for more info.

Go Up