Go Down

Topic: New GPRS module for Arduino (Read 9783 times) previous topic - next topic


i think it is not sure, because, if you do a web page in a computer, but the router ports arent open it happens what are you describing, but nobody out the LAN can access


Damn, but have the hell can I then be sure my IP is global.


I dont know, perhaps if you call to the number of the operator you are using... but... it is the only possibility i can say you.

I have another problem similar to the "A" at the beginning of the packet, i am trying to send characteres 0x00, 0x03... all of them havent correspondence with any ascii character ( they are NULL, SOH...) and the module doesnt send them. is it also another firmware problem?

Could you say me where do you actualice your hilo??

Thanks. Regards


Mar 06, 2009, 11:00 am Last Edit: Mar 06, 2009, 03:29 pm by sonped Reason: 1
I haven't tried sending non ascii chars, but maybe its the same problem, I will upload the firmware later today.
Updated ATCommandSet
firmware 5.05
If I remember right there is a problem with a dll :|
It is in the rar, and I think it is sufficient to copy it to c:/windows/system32 or similar

I'm student and is working with the dev. kit so no specific use at the moment.


You were right about the global IP :(



Thanks, i will try it!

Another question... when i try to transmit data to the source, sometimes it answer me : AT+KTCPNOTIF: 1,8. It means that it was waiting for more or less bytes. In my server how i tried to send 4 bytes, but it send only 3.

What can be the problem? perhaps the time between send AT+KTCPSND and the data??

Thanks. Regards


Mar 13, 2009, 08:22 pm Last Edit: Mar 13, 2009, 08:23 pm by sonped Reason: 1
I had huge problems to find out how to send in the beginning.
Now I send in this format:

AT+KTCPSND=session,nbytes+2  //data + CR LF
"CONNECT"  //from module
<nbytes data> <CR LF> //Data + CR LF
--EOF--Pattern-- //Key pattern
"OK"  //from module

If I forget to send CR LF after data I get session,8 error
Remember you may not send CR LF after Key Pattern :)

hope this helps, it toke me quite some time to find out that sometimes you may send CR LF and sometimes not.
see examples (appendix) in the AT Comman set if you need more.


CAn any one suggets me about SIM508 market report. I mean to ask about it`s industrial usefullness.Whether i have to go for some thing different module or stick with SIM508.

Mohit :(


hi dear friends ,
I have a problem with connecting to an internet server  when I have set up a client on it.i have physical with a valid ip address.i can connect to this server with my gprs module with port 8000(socket server)  but i can't send & receive any data.can you help me?
thanks a lot.


Can you get the "CONNECT" message when you try KTCPSND or KTCPRCV ?

please post the exact commands you use and their response.


hi dear Sonped & another friends,
thank you for your attention.
i can't any connection with socket server (the socket is: & socket API has installed on a srever 2003 with<local ip address> & that is valid IP address for this server & for default gatway<a adsl router> ).
i have set "" on socket server API.
my atcommand for sim300cz is:




thank you very much.


sorry but I can't help you with this module.
It seems to use different AT commands than the Hilo module I had used.


hello everyone.

i have a problem with this module. when i send the command AT+KTCPSND=1,14 I can't write anything else in the hyperterminal until I'll get KTCP_NOTIFY error 6 or 4, it depens on some random reasons since i get both errors with the same server. what I could do?


Go Up