Go Down

Topic: Another New PCB for Arduino Serial Single Sided (Read 52305 times) previous topic - next topic



If you can't find it to buy, you can substitute the inductor with a jumper (wire).
And without the inductor, you don't need both 100nF capacitors (C3 and C6). If you want, you can remove one of them (C3 OR C6). And keep the space of the removed capacitor empty.

This will kill the AVcc filter, but it will work, like any other Arduino.

Good luck!


Hi Adilson,

I removed C6 and jumpered pin 20 to +5V. Will try and make the PCB tonight. Will update once it's done. I'm still waiting for the atmega168 that I ordered.


Uh, I'm sorry.
There is an inconsistence in .png schamtics and the eagle board.
In the board, the 100nF caps are C6 and C7. But I can see you're an expert.

It's not necessary to change the layout, only if you want to.


I'm humbled by your statement, but I'm no expert, just a curious student that continues to learn things :-). Your layout is already excellent I don't want to change a thing.

Ok now I'm confused   ::) what I edited was the schematic I downloaded at http://www.arduino.cc/en/uploads/Main/Arduino_S3v3_R2_EAGLE_again.zip. I wasn't able to take a look at the .png schematics, I go straight to the eagle files (I'm such an eager beaver).

ummm so my revision above is fine?  :D


The modification you did seems to be ok. I think it will work.

Good luck.


Thank you Adilson here's the board that I've made:

not yet finished though, I still haven't received my atmega168 and crystals  :(

please comment, correct, if what I've done is okay, not good (newbie here)  :) While waiting for the 168 and crystal, I decided to do some tests.

1. I plugged in a 9 volt battery, and measure the voltages in 5V and 9V, pins 7,8, 20, 22 of the 28 pin IC socket, and pins 2, 5, 6 of the ICSP header. All are okay and registered ~+5V.

2. Next I decided to test the RS232 TTL circuit, by setting the serial enable jumper. Measured pins 2 and 3 (on the IC socket) and the voltage is +5V, then I jumpered them, this is where I kinda (scratch head) ask the forum for comment. Well, the RX and TX LED should both light up right? but on mine it did not right away, it takes a couple of seconds. Sometimes not at all.

3. I also plugged to my computer open hyperterminal. With pin 2 and 3 jumpered when I press a key on the keyboard the RX/TX LED lights up as it should. Un jumpered it, and only the RX led lights when I press a key on the keyboard.

Is there something wrong with my board? Especially with the #2. I've checked all connections and all are okay.

Thanks very much! Can't wait to start uploading sketches to my Severino.  :D


Aug 14, 2008, 01:27 am Last Edit: Aug 14, 2008, 06:23 am by purgedsoul Reason: 1
Adilson the board works! Thank you!

Though I have some trouble loading the bootloader using 0011. But what got the bootloader to work was I disconnected LED13 first.

And... I'm interested in building your Max232 variation of the Severino :-) can't wait for it..  ;D


Hi guys! this is my first attempt

I don't even know if it works yet, because my atmega168 is without a bootloader. I'll let know if you're interested  ;D

By the way, where can I find instruction how to use it? (total newbie here)


I am a total noob.
I want to make one of this board cause I cant get any Arduino here in my place but I can getAtmega168.

Do I need to upload the bootloader to the Atmega168?
If so how could I do that with this board cause looking at the software side the bootloader only can be upload using parallel port.

Thanks and regards.


Aug 02, 2009, 02:07 pm Last Edit: Aug 02, 2009, 03:40 pm by poldoj Reason: 1
YEAH! I've burnt the bootloader succesfully to my home made arduino (2 thread above)


;D ;D ;D

ps: I had to downsize the video since it was 1gb, so the quality sucks, sorry (just adjust the luminosity)


Aug 06, 2009, 06:46 am Last Edit: Aug 06, 2009, 08:14 am by vios Reason: 1
Can you please detail the procedure to upload the bootloader.

Is it trough parallel or serial?


First I tried with the parallel but it didn't work. I don't know why though. After a couple of failed attemps I gave up and bought an avrisp mkii.
The instruction posted in the link above worked like a charm.

for AKASHI: I'm really looking forward for a single side board supporting the atmega328


@vios: You can burn the bootloader via the parallel port using the parallel programmer details about this can be found here:


With the single sided board, what I did to successfully burn the bootloader using the parallel programmer was to desolder LED13 first.

@poldoj: Nice job! congratulations.

I have tried upgrading the Severino with the atmega328, and it works! just make sure you select the correct chip on the arduino software.


Aug 07, 2009, 10:24 am Last Edit: Aug 07, 2009, 10:49 am by poldoj Reason: 1
@ purgedsoul
Thank you very much! So the Severino can handle the atmega328 as well, cool. Just another question, Will my avrisp mkii be able to burn the bootloader to the atmega328? On the list of the supported devices I saw atmega32 and atmega329 among several others but I didn't see any atmega328. Is there a tutorial teaching you which fuses, bitlocks, .hex file etc. should be used for the 328 chip like that I used for the 168?

thank you!



First thank you for the single sided design, it's totally cool :)

I just finished building my second Severino, boot loader is up and running, but the serial uploading with avrdude won't work properly, it returns the following error:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

While trying to upload the rx and tx leds blink, but they seem faint to me, comparing with the first Severino.

I have checked and rechecked the board, replaced the capacitor, the transistors, the bootloader, the fuses, hit Google, still no go, it just errors out.

I'm not an electronics expert so I was wondering if the problem could be caused by the fact that I used B557C and B547C transistors instead of the the plain ones.

Any ideas?

Thank you.

Go Up