Go Down

Topic: [réglé]validation schema arduino "standalone" (Read 3470 times) previous topic - next topic

bad_dl

Jun 09, 2014, 05:50 pm Last Edit: Oct 18, 2014, 01:17 pm by bad_dl Reason: 1
Bonjour,
dans le cadre de mon projet de chrono pour "slot car" , j'aimerai ne pas avoir a le brancher sur mon arduino uno .

je me tourne donc vers les experes present sur ce forum pour etre sur de pas faire de betise.

De plus quand je tente de simuler la liaison i2c sous ISIS  rien ne se passe (si je teste la meme chose avec un "simulio" ca marche bien). de meme pour le moniteur serie.
avez vous des piste pour trouvé d'ou viens le probleme?

Merci


john_lenfr

Si tu as suivi le schéma d'ici normalement pas de soucis: http://arduino.cc/en/Main/Standalone


bad_dl

il me semble , d'ailleur le prog blink marche ....

bad_dl

j'ai enfin trouvé la solution :)
un mauvais reglage de l'ATmega et du serial :s

Je vous remerci pour votre aide

bad_dl

au finale , une fois la carte faite j'ai réellement un problème.
l'ATmega reçois bien le 5v  , mais il n'as pas l'air de réagir (un simple passage a 1 sur une pin ne change rien)
(le schéma se trouve sur le premier post , je joint le pcb avec celui ci.)
(j'ai rajouté entre les pin VCC et GND des condo de 100nF ce qui n'as rien changé)

auriez vous des pistes?


PS: si certain veulent le pcb au format proteus pour mieux voir , dit le moi

Par avance merci

B@tto

Blog électronique : battomicro.wordpress.com
Photographie : www.interactive-celebration.fr
Fablab de Montpellier : www.labsud.org

68tjs

Sauf à se faire plaisir : "j'y suis arrivé", j'ai un peu de mal à comprendre qu'on fasse son propre circuit pour ATMeg 328P, économiquement parlant c'est une erreur.
Il n'y a pas que la carte UNO à base d'ATMega328p qui existe, il y a aussi les cartes mini-pro et/ou nano.

Les cartes mini-pro ou nano dîtes "officielles" sont hors de prix (~20€ et plus), c'en est même  de la provocation.
Par contre on trouve sans aucune difficulté des cartes sans nom entre 3 et 5€ qui sont parfaitement fonctionnelles et qui disposent de 2 entrées analogiques supplémentaires .
A ce prix là on peut en avoir plusieurs d'avance.

Après avoir un peu bidouillé avec ces cartes maintenant  je trouve que la plus pratique c'est la nano qui peut s'enficher sur une carte de câblage rapide (breadbord).
La "nano" a un port USB incorporé qui jusqu'à présent est basé sur un vrai circuit USB/TTL et non pas une bidouille à base d'ATMega 16U2.
La" mini-pro" trouve sa place dans les utilisations à faible consommation --> pas de circuit USB/TTL à alimenter.
Je n'ai aucun avis sur la "micro" qui est à base d'ATMega32U24.

bad_dl

Pour b@tto , le bootloader est ok (l'ATmega fait bien sont job une fois sur la carte uno)

Pour 68tjs: quand j'ai lancé ça j'ai même pas fait gaffe au nano/mini-pro (donc oui une erreur) et j'avais déjà un atmega sous la main , j'ai donc cherché a faire une carte avec tous ce donc j'avais besoin pour mon système.... mais j'ai du loupé quelque chose .

j'ai vérifier pas mal de fois les soudures.... 

B@tto

@68tjs : en soit c'est pas vraiment une erreur, il faut bien commencé un jour et il est des fois plus compliqué d'intégrer une autre carte qu'un seul composant.

Le FT232 est sur la carte ou pas ?

Sinon typiquement ça sent le problème d'alim : les Atmega sont très casse bonbon sur le sujet ... Un 100 nF aux bornes du µC est indispensable
Blog électronique : battomicro.wordpress.com
Photographie : www.interactive-celebration.fr
Fablab de Montpellier : www.labsud.org

bad_dl

nop le FT232 est sur une autre carte , relier a celle ci par des câbles (j'ai reçu un peu tard le module)

suite a la lecture d'un autre topic (http://forum.arduino.cc/index.php?topic=261425.0) où certain d'entre vous préconisé les condo de 100nF, je les est rajouté sous la carte directement sur le support de l'AT mega (entre 7 et 8 et entre  20 et 22) il n'y a que sur AREF (21) que j'en ais pas mis.... mais ça devrai pas l'empêché de marché (juste faussé les mesures analogiques) Non?

68tjs

Si tu as bien lu j'ai écrit :
"Sauf à se faire plaisir :"

Je n'avais pas l'impression que c'était pour cette raison et la réponse de "bad_dl"  conforte mon interprétation.
Si je suis intervenu c'est aussi à destination des nouveaux qui n'ont pas forcément une idée claire sur le panel de  cartes existantes, surtout s'il se font leur opinion à partir du site arduino.

bad_dl

Pas d'autre piste?

Je vais dessoudé les composant "de base" et retesté ça sur breadboard. des fois que je trouve le problème :s

bad_dl

J'ai enfin trouvé mon erreur.... j'ai mal "lus" la valeur des condensateurs céramiques du quartz . une fois ceci changé , mon atmega a  enfin bien voulu  faire clignoté une led.
je n'ais par contre pas réussi a mettre un auto-reset  pour l'upload. je vais donc devoir faire mumuse avec le bouton pour les mises a jour.

Merci pour votre aide

Menad

moi je cherche l'ATMEGA16u2 sur proteus pour realiser une carte Arduino UNO avec ISIS, alors si quelqu'un possède le lien qui me permettra de télécharger l'ATMEGA16u2!

Go Up