Go Down

Topic: Televersement impossible sur Pro mini (Read 3055 times) previous topic - next topic

Bizounours

Bonjour, suite à mon sujet, sur le pro mini, je vient de le recevoir (24h  ]:D) mais...

En essayant d'uploader "blink", j'ai le message suivant qui s'affiche :
"Taille binaire du croquis : 1 084 octets (d'un max de 30 720 octets)
avrdude: stk500_getsync(): not in sync: resp=0x00"

Je suis sur l'IDE  1.0.5-r2 sous windows 7
L'Arduino est une copie basé sur l'ATMega 328 16 Mhz

C'est celui là :
http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=271516089941&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Avec ce câble (4 pins GND - VCC - RX - TX)
http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=271523793696&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

En branchant le câble j'ai bien les drives qui ce sont installer en COM4

Donc même en ayant bien choisis dans l'IDE l'Arduino Pro mini 328/16 et le COM4 ça ne fonctionne pas, idem en COM1  :~

Artouste


Bonjour, suite à mon sujet, sur le pro mini, je vient de le recevoir (24h  ]:D) mais...

En essayant d'uploader "blink", j'ai le message suivant qui s'affiche :
"Taille binaire du croquis : 1 084 octets (d'un max de 30 720 octets)
avrdude: stk500_getsync(): not in sync: resp=0x00"

Je suis sur l'IDE  1.0.5-r2 sous windows 7
L'Arduino est une copie basé sur l'ATMega 328 16 Mhz

C'est celui là :
http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=271516089941&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

Avec ce câble (4 pins GND - VCC - RX - TX)
http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=271523793696&ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649

En branchant le câble j'ai bien les drives qui ce sont installer en COM4

Donc même en ayant bien choisis dans l'IDE l'Arduino Pro mini 328/16 et le COM4 ça ne fonctionne pas, idem en COM1  :~

bonjour
il faut gerer le reset à la main
il y a une fenetre temporelle assez stricte pendant laquelle le bootloader ecoute puis rend la main

Bizounours

Coucou, ça confirme ce que je craignais... J'ai lu (enfin survoler, car en anglais) des choses sur ça :/

Je vais essayer de passer par l'Uno du coup, j'ai jamais été bon au jeu d'adresse  :smiley-sweat:

B@tto

Sur une des photo sur ebay on voit comment démonter le module et récuperer le signal DTR qui sert au Reset. Il suffit de souder un fil entre le DTR et le Reset de la mini
Blog électronique : battomicro.wordpress.com
Photographie : www.interactive-celebration.fr
Fablab de Montpellier : www.labsud.org

Artouste


Sur une des photo sur ebay on voit comment démonter le module et récuperer le signal DTR qui sert au Reset. Il suffit de souder un fil entre le DTR et le Reset de la mini

:smiley-mr-green:
Alors en plus , si c'est prévu  8)

Bizounours


Sur une des photo sur ebay on voit comment démonter le module et récuperer le signal DTR qui sert au Reset. Il suffit de souder un fil entre le DTR et le Reset de la mini


Ca serais parfait, en soudant une prise mini usb femelle à la place de l'usb mâle j'aurais plus de problème, j'vais essayer ça !

Artouste



Sur une des photo sur ebay on voit comment démonter le module et récuperer le signal DTR qui sert au Reset. Il suffit de souder un fil entre le DTR et le Reset de la mini


Ca serais parfait, en soudant une prise mini usb femelle à la place de l'usb mâle j'aurais plus de problème, j'vais essayer ça !

heu , je n'ai pas compris ta reponse là
tu n'a pas à toucher à l'usb , le signal DTR est dispo , mais non cablé sur le PCB , il suffit "juste de " le repiquer pour en disposer "plus facilement"
Le coté USB n'est pas concerné par cette manip

Bizounours

C'est pour intégrer dans un boitier, du coup je soude le 5v + gnd + R+T + DTR sur le pro mini, puis je change l'usb pour pouvoir y brancher un usb mini mâle ;)

Artouste


C'est pour intégrer dans un boitier, du coup je soude le 5v + gnd + R+T + DTR sur le pro mini, puis je change l'usb pour pouvoir y brancher un usb mini mâle ;)

ok , là ça va mieux en le precisant  :smiley-mr-green:

Bizounours

Bon, même avec le DTR câblé ça ne fonctionne pas  :~

Artouste


Bon, même avec le DTR câblé ça ne fonctionne pas  :~

a tu verifié que le signal DTR "bouge"
avec un "terminal" qui gere le forçage , pas l'IDE arduino et un simple voltmetre tu va etre vite fixé

Bizounours

Je ne comprend pas, juste un multimètre ?

Artouste


Bizounours

Et le "terminal" qui doit faire le forçage, ca peut être quoi ? Code::Blocks ?

Artouste


Et le "terminal" qui doit faire le forçage, ca peut être quoi ? Code::Blocks ?

connais pas
perso sous W7 , lorsque j'ai besoin de tripoter ces signaux
j'utilise le terminal dispo avec les suites mikroe
je n'ai pas encore trouvé de bon terminal qui propose "ça"
terminalbpp est tres bien , mais pas pour ça

tu peux telecharger une version demo, apres tu utilise l'outil "usart terminal"

voir là par exemple
http://www.mikroe.com/mikroc/avr/

Go Up