Go Down

Topic: [partially solved] 12V relay not cooperating (mod.3393 to be used with Arduino) (Read 8910 times) previous topic - next topic

greenestmike

Hello everyone,
I have an apparently stupid matter on my hands, but I can't figure out where my mistake resides.

Simply put, I'm trying to use a 12V relay module to be driven with Arduino. Under a testing environment, 12V is provided to the board as specs while, with common ground, 5V are provided to the "IN" pin to simulate an Arduino HIGH value.
Unfortunately not only the relay doesn't show any attitude to be cooperative, but the IN pin itself appears to raise its voltage to 12V meaning, to me, than a candidate Arduino could get badly hurt in the process.

Items are: http://www.icstation.com/product_info.php?products_id=3393

Any chance you could suggest me what I am doing wrong?


Thanks in advance...

dave-in-nj

please make a simple schematic for us.

you have 4 pins,  12VDC to one,
common ground to the GND pin.

then measure voltage to make sure you do not have these reversed.

notes say the trigger is 3mA.  are you using a resistor  to limit power ?


if you make a voltage divider from your 12VDC, you should be able to get the unit to change state.

the optio is an LED, so all you need to do is use a dropping resistor to get 3mA or as much as 10mA....

if that does not work, then the unit may be bad.




CrossRoads

No schematic, picture appears to have some kind of 3 terminal device to apparently sink 12V current thru the coil.
These kind of relay modules are pretty common. You have 5V on Vcc? or 12V?
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

greenestmike

Uh, well. Thank you indeed for the very fast response.

Setup here is as follows:
two power supplies: one 12V, another 5V, common ground.

On the board

VCC is connected to 12V
GND to ground
IN1 to 5V

Simple. I would expect the relay to fire, but nothing.
Tried IN2, nothing.
Tried another board... nothing!

In the meantime, power led shows the circuit is active while LED1/2 lights up showing (apparent) action. But, nothing!
What's worst is that a V-meter on the 5V line, while connected to IN1/2 raises to 12V!

Is it my bad day? :)

cjdelphi

The relays are 12v activated.

So vcc is 12v , to trigger the pins simply send them a logic high... you don't need arduino just give it 5v directly and see if it clicks. Then use arduino..

If you're worried,  use a diode in series, to block anything from the relay board.

greenestmike

Thank you all,
in a matter of fact I use VCC 12V and provide 5V without Arduino use but it doesn't work! (thanks for the diode tip)
What puzzle me most, is that *no* relay does (tested two boards, four relays).

I'm definitively missing something here. Provided I'm not an expert on the field, my attempt to provide 12V directly to the coil of one relay burnt it in no time. So, thrown the first away and tested a second one with a resistor in series didn't make it to "click" as expected.

Definitively, today is not my best one :)
But eager to test it tomorrow!

greenestmike

Replying to myself with a little update (some meditation drink helped).

The 12V is actually a steady 13.3V
**AND**
there's voltage on the IN pin, even without outside intervention!

Being a novice on the electronic field, I suspect there's need for a pull-down/pull-up resistor (haven't figured out yet what that means :).
Still, being a "positive" voltage on the INput pin, I tried grounding with a 10k resistor hearing, once upon a time, the "click" (with no "magic smoke" released on the air! Cool! It -still- works!).

Not a solution, but a step closer.

Now, what? I have a 12V relay that works at 12V, right?!
But I expected to work at Arduino (5V) voltage!!

What would the community recommend me?
Meantime I go get another meditation beer  ;)

CrossRoads

What's the voltage on the IN pin?
Perhaps it is "pulled up" up already (to 12V?), so you only need to pull it low via NPN transistor to Gnd to turn the coil on.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

romanz

#8
Jul 08, 2014, 10:52 pm Last Edit: Jul 09, 2014, 01:07 am by romanz Reason: 1
I know these boards, they have optoisolator on the front and they expect LOW to activate and HIGH/NC to deactivate. My version  uses 5V relays but it should work the same with 12V version.

Schematic attached

UPDATE: my mistake, wrong schematic. this one does not have opto element.

Paul__B


I know these boards, they have optoisolator on the front and they expect LOW to activate and HIGH/NC to deactivate. My version  uses 5V relays but it should work the same with 12V version.


You do not know the board referred to here, it does not have the opto-isolators and it does as described in the article, require a positive voltage to trip.  Kudos on the diagram I so frequently provide though, but it is the wrong one on this particular occasion!

What is described as a problem is genuinely puzzling.  It would suggest that the ground is not correctly connected but then if the pilot light lights, a ground must surely be connected.

Two things here:

We need a (precisely focused, image size constrained to 1024 by 768 maximum) photograph showing your test setup in its entirety.

In the meantime (and yes, after taking the photo), connect the relay board to your 12 supply only, and bridge the Vcc to each input pin with a 1k resistor.  Tell us what happens.

dave-in-nj

Try what crossroads said;

put on your 12V and your 5v, then bring the pins to ground.  that should not hurt anything.  if they are high already you cannot 'drive' them with the same voltage.



cjdelphi

I decided to take a closer look at the image...

The 2 transistors used are S8550.   Pnp!

To activate the relay pull it to ground (not supply 3-4v) like the webpage states, place a diode in series and signal 0v to switch it on... switching it off may be an issue as it may require up to around the 12vcc input you use.

romanz

I found same board on ebay with schematics. There is two versions, they call them "high level trigger" and "low level trigger".

High level:



Low level:



The 12V "low level trigger" is useless for Arduino. But someone explain why would 12V relay coil burn when connected to 13.3V ?

Cactusface

#14
Jul 09, 2014, 09:49 am Last Edit: Jul 09, 2014, 10:05 am by Cactusface Reason: 1
Hi,
      I am using one of these boards, in my new seed propagator and it works fine, other then the odd inverted logic, in that it takes a LOW to switch the relays on. I like the opto-isolator input and the FET drivers.  The relay contacts are SPDT so you can wire it to be,  When NOT activated N/O or N/C and so a LOW signal switch them OFF, and a HIGH to switch them ON, but the LEDS would still indicate ON! when OFF!!

romanz  where did you find the schematics? I'd like to go and have a look at these boards, etc..

Here's a picture!!

And a bit of my code:
Code: [Select]

//-----------------------------------------------------------------------------------------------------------
void TestIt()
{
 Light=analogRead(LightPin);
 Light=map(Light, 0, 1023, 0, 255);
 if(Light>200)
 {TargetTemp=25;}
 if(Light>160 && Light<200)
 {TargetTemp=18;}
 if(Light<160)
 {TargetTemp=14;
 
// Set Temp******
  lcd.setCursor(1,1);
  lcd.print("Target Temp:");
  lcd.print(TargetTemp);
  lcd.print(".00c ");
  lcd.setCursor(1,2);
  lcd.print("Current Temp:");
  lcd.print(TEMP);
  lcd.print("c ");
 
  if (TEMP < TargetTemp)
 {
  digitalWrite(Heater1,LOW);    //Heater ON, Relay board uses LOW to switch relay ON.
  digitalWrite(Heater2,LOW);
  lcd.setCursor(1,3);
  lcd.print("Heater ON ");
  lcd.print(Light);
  lcd.print("  ");
 }
 if (TEMP > TargetTemp)
 {
  digitalWrite(Heater1,HIGH);
  digitalWrite(Heater2,HIGH);  //Heater OFF, Relay board uses HIGH to switch relay OFF.
  lcd.setCursor(1,3);
  lcd.print("Heater OFF ");
  lcd.print(Light);
  lcd.print("  ");


Hope it might help.
Regards

Mel.
Open your mind! But not too far, your brains might fall out.
Also like Photography, model building and my 300+ Cacti and Succs.

Go Up