Go Down

Topic: Arduino Driver for Windows Error (code 10) (Read 19634 times) previous topic - next topic

Jewels9

A very sad hello :-(

I am at a loss...
None of the "fixes" in the forum or Youtube videos have helped me thus far...
I will try to give as much info as i can but also not beat around the bush.

I purchased a brand new Arduino Mega 2560 R3 from Microrobotics in South Africa 3 days ago.
It came as part of a 3D printer starter kit. (Including 1x Ramps 1.4 & 5x stepper motor driver boards)

I removed the Arduino board from the box and connected a USB (wich was not included in the kit) to it.
I then proceeded to download the IDE for windows  (1.0.5)
Following the instructions to the letter, i then connected the USB (with Board attached) to my PC.
The pc (laptop) is running Windows 7 Ultimate 32bit has 3 USB ports.
After opening Device Manager and waiting for a "unknown Device" to appear, which never happened, i took the next logical step.
Add legacy hardware/Ports (Com&LPT)
From there, using the wizard, i installed the arduino.inf in the drivers folder, selecting the Arduino Mega 2560 Version 1.0.0.0 [1/4/2013] driver and clicking install........ This is where it all went downhill.
The window pops up saying "The software for this device is now installed but may not work correctly. This device cannot start  (Code 10)"

Since then, i downloaded and tried the 1.5.7 Beta Drivers - same story
I tried the Old Drivers in both 1.0.5 and 1.5.7 - Same story
I tried switching USB ports on the Laptop - Same story
I tried 3 other USB cables - Same story
I tried a different pc all together (Windows 7 Ultimate 64bit) - Same story including the afore mentioned steps
I tried another Laptop (Windows 8.1 32bit) -  Same story including the afore mentioned steps
I tried yet another PC (windows 8.1 64bit) - ......guess....  Same story including the afore mentioned steps
I tried virtual ports, 3rd party software, i even tried all of the other Arduino board drivers Uno/Mega ADK/Due/etc, but they all come back with the same error (Code 10)

Yes, the PWR "ON" LED and the pin 13 LED come on when i plug the UBS cable in,
Yes, it flashes once
Yes, i've changed my system time and date
yes, i rebooted the win8 machines with disable certificate verification
and yes, i have even removed MYSELF from the installation process and got 2 of my friends to try on their PC's.....

CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10 CODE 10

I am about to cry....
If anyone has any ideas, apart from hitting the board with a hammer, that would be great, as i am all done now.
I honestly don't know what else to try.

Julian - (Code 10)

spycatcher2k

Can you supply the direct link to the product, SOME clones use different USB to TTL converter chips.
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

Jewels9

Here is the link but it doesnt say much.
https://www.robotics.org.za/index.php?route=product/product&path=24&product_id=817

please find attached 2 photo's of the board in my possession.

Jewels9

I believe the board must be faulty, so i'm sending it back.

yimbiraralik

I have same problem bro, but when I try my friend's pc which is win8.1 it was worked. When I need update program, I still his pc, but I still can't use in my pc ( win7 SP1 64 bit, home premium)

I had tried a lot of way, nope.

what did you do with your board ?

AJITnayak

#5
Dec 18, 2014, 10:09 am Last Edit: Dec 18, 2014, 10:12 am by AMPS-N
Dear Jewel

Here I am attaching updated driver here. Please save the driver in Arduino folder.

Install the driver manually instead of automatic. Chose the below driver folder while updating from device manager


delete your old driver folder. Please let me know error you getting.


from device manage it clear say driver not being installed. click driver update choose maual update option; then select below folder with your controller board




AMPS

DANYARD

Hi all
I have the same identical problem with my MEGA2560 clone bought on ebay...see page 2 of forum.
I hope it was suddenly faulty because it was operative for about a month.
On MAC PC it is working ok
ON PC WIN 7 ultimate (tested on three identical PCs) code 10 and COM port used by another application....

Now I'm waiting for a new GENUINE board bought from Arduino store.   

If the problem still I will open a SERIOUS issue with Arduino and windows til my board is working.


 

AJITnayak

Before purchasing new board . Have you tried method i told you.
AMPS

DANYARD

Yes but....the same error during upload
Arduino MEGA 2560 Serial port 'COMx' already in use. Try quiting any programs..

and yesterday I also try to connect this Arduino on a MAC with Arduino 1.0.5 SW.   
Loaded blink and uploaded successfully!
After .....
Same error also on MAC without any possibility of recover.
Arduino MEGA 2560 Serial port 'COMx' already in use. Try quiting any programs..
Avrdude timeout....

with the wonder of the MAC owner who is an high skill technician on Arduino !

Tested on the same port with an Arduino 1 board and this work.

At this point the card is definitely defective.  :smiley-sad-blue:

 

AJITnayak

In that case you need to change port itself. As we know in windows 7 it automatically ports get assigned.

follow below procedure,

goto device manager

Chose the port section

goto property

select port setting

 goto advance setting


change port , In windows 7 it shows automatically which port are being used & which port are empty so select unallocated port


once port allocated save & restart
again upload the driver now. It must work this time.

any clarification Let me know
AMPS

juru

Hi!

I give work my board "UNO" with this
http://wch.cn/downloads.php?name=serch&page=1&keyword=CH340

My UNO serial ship is 'WCH CH340G'

dominate

i have the same problem with my two new Arduino Mega 2560 boards. Code-10 error and on arduino board one red led is blinking. I am writing to seller about the problem. I think there is no bootloader on board so board cant boot. Do you have any solution?

CinnamonMemories

Same problem here using Arduino Esplora, I believe this issue hasn't been fixed yet.

bmasojc

I think I have found solution to the problem described above in case of arduino uno with CH340 USB-to-serial chip in Winodws 7 32 bit. Just update the COM driver with drivers for  CH340 USB-to-serial chip which can be downloaded from http://javacolors.blogspot.com/2014/08/dccduino-usb-drivers-ch340-ch341-chipset.html. Although the site describes a solution for Macbook, it contains also drivers for windows. This solution worked for me. (Exchange of usb CABLE and Arduino driver reinstalation did not work for me).
with regards
Bartek

droiedboy1318955

I have the same problem .......
i went through all the steps........
even those above mentioned..........
But i am getting the same error with different message...........
please point me out if i had made any mistake

Go Up