Go Down

Topic: Arduino Driver for Windows Error (code 10) (Read 19642 times) previous topic - next topic

immi

Dear All, I have the same problem mentioned above. I have a a Nano, UNO and they all get connected easily without any problem but Arduino Mega 2560 is giving me a headache. I know my mega 2560 board is ok because I tested it with other PC.

Like others here, i have exhausted all options to install the driver but nothing works and it appears that there is some fundamental problem with the Windows recognizing the serial port.


jessey

I am hating this arduino shit of hit and miss. I am having the same problems as everyone else here and no conclusive help from anyone from the founders of arduino. Who is this Casey guy and another one that devolved this shit, where are they when it comes to any kind of support? I am beside myself here on a love hate thing for arduino...
I'm definitely not impressed...
where can a guy get answers for this or am I just shit out of luck?

Coding Badly


Did you post because you needed to vent or because you want help?


jessey

Did you post because you needed to vent or because you want help?


I think its both. I have been wrestling with this problem for far too long and after reading in the forums I'm not the only one that dosen't get any answers. Anyway it's frustrating to say the least. Ive tried diferent versions and always have problems with ports. Here is my latest attempt at trying to install arduino.

I just installed 1.6.2 arduino again and have a few questions if anyone is interested and or has any answers. When I plugged in my mega board it installed the driver, I had a look in Device Manager and it showed my mega 2560 on COM3 which is odd because it is usually on com12. When I open a sketch it shows it (on the bottom right) on COM1? So I click on "Tools" and Port is greyed out in that menue so I'm thinking that's telling me arduino knows the port is wrong. Anyone have any suggestions on what is going on? Who should I be contacting if no one knows in here? Does arduino have any kind of support?

iammayur

just download CP210x_VCP_Windows from silicon labs and install. worked for me.
Note:works with usb to uart connector.

bforu_gs

Thanks iammayur,

cool, this thing worked for me.

This is the link directly to the drivers.  A restart after install is recommended.

http://tw.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx#windows


Go Up