Go Down

Topic: GD2.h:329:27: error: 'prog_uchar' does not name a type (Read 32302 times) previous topic - next topic

isnagut

Hi,
does have some one an idea how i can fix this error?


Arduino: 1.5.7 (Linux), Board: "Arduino Yún"

Build options changed, rebuilding all
In file included from Arduino_SolMAX.ino:5:0:
/home/kroki/Arduino/sketchbook/libraries/Gameduino2/GD2.h:329:27: error: 'prog_uchar' does not name a type
void copy(const PROGMEM prog_uchar *src, int count);
^
/home/kroki/Arduino/sketchbook/libraries/Gameduino2/GD2.h:329:39: error: ISO C++ forbids declaration of 'src' with no type [-fpermissive]
void copy(const PROGMEM prog_uchar *src, int count);
^

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

THX felix

Peter_n

The new Arduino 1.5.7 BETA has a few differences.
previous: prog_uchar text[] PROGMEN = { "Hello World" };
now: const unsigned char text[] PROGMEM = { "Hello World" };

isnagut

THX for the answer,
but it sdosen't solve the problem.
I tried the lib with the version 1.0.5 and it doesen't work too on Linux.
On Win 8.1 this lib works with the ver 1.0.5.
I'm confused while before my computer crashed and I had to install fedora new the lib was working.

felix

Peter_n

Is that a GameDuino library ?
Can you post a link to the library that you use ?

isnagut


Peter_n

That library is recent (januari 2014) but not yet adapted for Arduino 1.5.7.
You can do it yourself, change all the "prog_uchar".
If it runs in Windows with Arduino 1.0.5, you should be able to run Arduino 1.0.5 in linux.

Your problem with Fedora seems to be another problem.
Perhaps some old Arduino files are in your system, from a previous installed version.
Also check that you have a good set of Java installed.
The new Arduino 1.5.7 seems to be less dependent on the Java.

isnagut

ok, i'll try to get it on linux with the version 1.0.5.
if i start arduino then i see

[kroki@local ~]$ arduino
WARNING:  RXTX Version mismatch
   Jar version = RXTX-2.2
   native lib Version = RXTX-2.2pre2

it's look like i've a problem with the java.

the installation of fedora is new. so i don't have some old files on it.

felix

Peter_n

That is a problem, the librxtx-java.
Can you try removing it from the repositories ?

isnagut

I don't find this resporitori in my installation :-(

Peter_n


isnagut

thx,

i removed rxtx and took the androino 1.0.5 from the web.

now the skech compiles.

now i have the errors
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7
check_group_uucp(): error testing lock file creation Error details:Keine Berechtigungcheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL

But i think that's a problem that i can solve.

felix :-)

isnagut

TXH Peter_n for your help.
I fixed now the version 1.0.5.
Also I installed the version 1.5.6 r2 and this works with the GD Library. So I don't have to change it :-).

Cya
Felix

Peter_n

Cool.
The newest BETA has many improvements for the Due and the Yun.
http://arduino.cc/en/Main/ReleaseNotes
I see this: "Fixed CRC of shutdown command on YunSerialTerminal example", but that's only a change in a tutorial.
I hope the rest is also not a big problem for the Yun.

Go Up