Go Down

Topic: [Solved] Clone arduino Mega 2560 - no serial port DCcduino Mega 2560 (Read 171255 times) previous topic - next topic

sedatm

SIMPLY FOLLOW THESE ON WINDOWS-7
-> Download http://www.wch.cn/downloads.php?name=pro&proid=5 and unrar (CH341SER\)
-> DISCONNECT USB CABLE OF BOARD
-> RUN \CH341SER\setup.exe
-> CONNECT USB CABLE
Here You Go...

ChilliTronix

On Windows 8 and Linux the drivers are built in, so just plug and go...

CORBELmanu

I hope not to be off topic, but here's what I found:

On forum below, I found the driver for my arduino nano V3  card with a chip CH340g for USB-serial link (not a FTDI chip, apparently Chinese clone chips are automatiqement blocked by last updated windows and FTDI, but hey I'm not the right place to mention here)

http://club.dx.com/forums/forums.dx/threadid.635690

Fenchurch Thursday, December 02, 2010 4:43 PM Reply
Found this to work on Win7 64bit probably works with other os's as well.

http://www.winchiphead.com/download/CH341/CH341SER.ZIP


Thank you Fenchurch !!!!!!!

I said that this driver works under Windows 7 64 bit.

howard2k7

I got an Ardunino Nano clone realy cheap off ebay and hadn't done any research before.

On my Dell/W8.1 Laptop the driver didn't install properly. Had a "USB2.0-Serial" unknown hardware thing when i plugged in the board. It got an 340G Chip on it so after trying out the drivers from the Arduino IDE and another FTDI-whatever driver which both did not work finally


http://www.winchiphead.com/download/CH341/CH341SER.ZIP



this one worked like a charm. Plug in the board, fire up the setup.exe and click "Install" and you got yourself a new COM Port for communicating with your new toy.

Thanks for the help in this thread, even if it talked about Mac OS in the first place   :smiley-mr-green:

kigster

I put up a blog post summarizing findings in this thread and several others:

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

Hopefully someone will save time, and not waste an hour like I did :)

ChilliTronix

Well, when I sell Arduino compatibles with CH340 chips on them I just put a link in the listing for them.

dizzwold

 I have one of these cheep 2560 clones with the CH340 chip set. I installed the driver CH341SER_MAC, but sometimes i plug the board in i get the following message and have to manually shutdown my Imac;

 "You need to restart your computer. Hold down the power button until it turns off, then press the power button again".

 I've googled this, and apparently it's called a "kernal panic", and related to quote below;

Actually, I was too quick assigning blame. It was nothing to do with the USB-serial at all, and everything to do with the capacitor on the Arduino power supply. (presumably a large current surge when plugging-in caused a rather serious problem. But it shouldn't crash the Mac surely?)
How can i get around this / what is the solution to the above?

 Use an external power supply, so not using the USB power, or could i hack a USB cable with resistors on the power lines?

 Any input welcome.
I'm not a student or a lecturer. I'm a hobbyist.

paulsvang

I ran into the same problem with this on my iMac Yosemite.  I just opted to not use it.  My Imac keeps shutting off when plugged in.

GiuCan

Hi Everybody,

I just got a arduino nano clone with chip ch430. I installed the driver as in

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

and it worked nicely with the blink script. I connected a gyroscope gy521 and it was still working when suddenly the serial port had disappeared from the serial port menu. I closed and opened arduino again and the port was no longer there. I rebooted and still no port.

I reinstalled the driver few times and rebooted few times. No chances to get it back.

Has anyone ended up in the same problem?

Thanks for sharing,

G

ChilliTronix

Check the last few lines of output for dmesg when the device is plugged in. (Open terminal, run dmesg, plug it in and leave for 1 minute and run dmesg again. See what is new)

mikofan

try downloading this driver

http://mysolution.me/video1/cutting%20plotter/Cutter%20Plotter%20Instruction/Cutter%20Plotter/5-USB%20Connection/CH341SER.rar


GiuCan

try downloading this driver

http://mysolution.me/video1/cutting%20plotter/Cutter%20Plotter%20Instruction/Cutter%20Plotter/5-USB%20Connection/CH341SER.rar


Erm I have Mac... ;(

fejodor

I've just tested a cheap Nano-clone with a CH340G-chip (this one). Works out of the box like a charm with Arduino IDE 1:1.0.5 on Ubuntu 14.04. For all those who still have problems with the chip: Why don't you create a Linux live system on an old usb flash drive, possibly based on Lubuntu, to upload the code. This might sound like a long shot but it's actually not that much work. And it would keep you from hassling with those strange third-party drivers...

ChilliTronix

I don't use Linux live stuff... I have Linux installed by default... :) And your right it just works.

evanhu

Thank you so much! dmatyukhin

I just got several cheap DCcduino boards from China and it works on my mac.

Just to summarise. On Yosemite:

1. Install the driver http://www.wch.cn/downloads.php?name=pro&proid=178

2. Run this(Terminal):

Code: [Select]

sudo nvram boot-args="kext-dev-mode=1"

3. Restart

Go Up