Go Down

Topic: Ethernet shield,Arduino UNO and 3 problems :) (Read 8837 times) previous topic - next topic

AJITnayak


I can try it beacouse my serial monitor is not working while the shield is on. I try it with LCD and lcd.print but no result. I thing that the shield is total fault. I remove the bridges but no result...
If i remove ICSP i get from serial monitor 0.0.0.0...


first do this . remove all your connection . upload just this code to arduino Board . make ensure serial monitor works. share screen shot.If you found code upload successfully but u cant get any monitor display. Then there might problem in IDE, SO kindly update your IDE.
Let us know which IDE your using  with os. Before posting next time do this test.

Code: [Select]

void setup()
{
Serial.begin(9600);
}
void loop()
{
Serial.println("welcome to arduino");
delay(1000);

}


AMPS

knockouta

#16
Oct 16, 2014, 11:54 am Last Edit: Oct 16, 2014, 10:07 pm by knockouta Reason: 1
Hi all, i have now new shield other model. Again with W5100.
The serial monitor is working without the shield. I update IDE to 1.0.6 and uploaded again the code. Again nothing on the Serial monitor and after pressing the restart button i get those erros. PWR and LINK leds are ON, sometimes i get and 100M.
I saw that on ICSP on my UNO the first pin is different with first pin on this on the Shield. I am not sure but...

AJITnayak

1)That means Your ardunio Board working fine.
2) FOr second image you need to show me the First start image.
3)Before Uploading code of ethernet i shared remove your ethernet sheild , Upload the code, Then connect the ethernet sheild.

Make ensure that you use proper serial print statement each part of code.
AMPS

knockouta

I got it running with Leonardo with no problems... I am 100% that the ICSP on my China UNO has wrong firts pin.
Thank you all for helping me.

Thomas499

Hello, I am new to the Arduino experince and have run into a similar problem using a R3 uno and a Ethernet Shield. I have two arudinos and two Ethernet Shields. Both arudinos are R3's, and the Ethernet shields are Seeed V2.0 and Seeed V1.1 Rather than starting a new thread, I decided to post it as an addition. I hope this is appropriate.

Two days ago, I was working on the coding for the arduino to broadcast information to an Ip address (webserver experiment located in the per-established library). I was modifying it a bit to my personal needs, but everything was working perfectly. - This is really neat technology by the way!

Yesterday, The Seeed Ethernet shield V.20 (that I had been successfully working with in my experiment the day before) wouldn't connect to the Internet.  When i pulled up the Serial Monitor after I downloaded the sketch it didn't say anything. When i attached my other Seeed Ethernet Shield V1.1 it worked though so I figured the V.20 may have overheated or something so I took it to Radio Shack and they gave me a different one. - The V1.1 was discontinued.

I noticed when I got home, when I pulled up the Serial Monitor after I downloaded the sketches in the library, the replacement immediately said "Failed to configure Ethernet using DHCP". I took the replacement back, and they didn't have any others so they gave me back the first one I had.

When I download the sketches, it still didn't say anything when i pull up the Serial Monitor though. According to my understanding of the code, if (mac) == 0, it should immediately say "failed to configure Ethernet using DHCP", but it didn't say anything.

Does anyone have any idea why this might happening or how to troubleshoot it? I tried it on both Arduinos with multiple sketches from the library and received the same results. As I mentioned, the V1.1 model works though, and it immediately sends the information to the Serial Monitor.

To help diagnose the potential problems that may be accruing, the V2.0 is able to stack the V1.1 on top, and when this happens, the V1.1 still works (when the Ethernet Cord is attached to the V1.1 and not the V2.0) The only noticeable difference I can find is that the V2.0 has two additional pins on both sides that connect to the arduino. One the right side (power side) these two pins are connected to the arduino IOREF and pin beside it (last pin) that that isn't labeled on the arduino.

On the left side (digital side) the two additional pins are connected to SDA and SCL. I am not sure if those pins could cause some kind of interference.

On the shield itself the PWR green light is on, and the light above C15 is bright red.

Another Unusual thing to note that that during the Ethernet Library experiment webserver, the Serial Monitor today will print off a random Server addresses (where as yesterday it wouldn't print anything. 0.40.0.0 was the first Server address it gave, in the second attempt there were no 0's, but it was way off from what the code said it should have been. The third attempt was 0.0.0.0
Yesterday it didn't print off anything.... In the experiment (WebClient) the serial monitor still doesn't print anything.

Other experiments that came in the Arduino library show (Failed to connect to Ethernet Using DHCT), where as yesterday it didn't print anything. But then again the V1.1 works fine, and I get the same results when I switch up the Arduinos.

Any suggestions are greatly appreciated.

lucygp

Then connect your Ethernet .
check it is working or not.










________________________
fut 15 coins


annwinters

"Redesign Ethernet Shield W5100 R3 Network Expansion Board For Arduino UNO"
"Newest Ethernet Shield W5100 R3 Network Expansion Board For Arduino UNO Mega"


Hi there!

Just to add my experience.

I bought two of the same Ethernet boards as knockouta.
I also have had NO luck at all in getting them running.
I have tried many boards... Uno, Mega, genuine and Chinese... Non worked.
If you upload code, you get a sync error.
Upload first and then add the Ethernet, the webserver program times out.

Basically, these boards are rubbish!

Avoid: being sold on eBay by just 3x people: alice1101983,  worldchips, czb6721960.

It's a unique design as per the photo above. A long line of resistors and only one capacitor.

Be interesting if anyone finds an answer.
Andy

zrubinic

Hi,

I would like to share solution for "server at 0.0.0.0" problem. After some time of searching online and trying different things like cutting down pins i found out thanks to this post (http://wizwiki.net/forum/viewtopic.php?p=5153) that LED connected to pin13 and GND was the problem for me. After I removed my LED from pin13 everything works.

I don't know how is that related but it works.

My board is Arduino UNO and org. Arduino Ethernet Shield with W5100.

Go Up