Go Down

Topic: Is my Arduino Robot dead? (Read 1 time) previous topic - next topic

team_arduino

Hi all,

Grim times, today I was uploading a simple sketch to the official arduino robot. I unplugged it and didn't run. Plugging it in now causes me to receive a message saying "USB device not recognised" (code 43).

I have tried plugging it into a different computer, tried uninstalling and re-installing the drivers and have achieved no result.

Additional Information:

1. Motor board still functions
2. When robot is unplugged and switched on the screen is on.
3. When the control board is plugged in the LED/RX light is on.
4. Hardware ID on the control boards reads "USB\DEVICE_DESCRIPTOR_FAILURE"
5. Have tried alternative cable

I assume that something's gone wrong in the upload, maybe it was unplugged too soon? Extremely worried that it is dead, it was a real investment for a student.

Thanks,
C


rastamankg

Open some simple sketch, like LED blink sketch, hold reset button on robot. when compiling stage is done, release reset button right before upload step.

Go Up