Go Down

Topic: Unable to get FT232R drivers loaded under Windows 7 64bit (Read 188450 times) previous topic - next topic

MrsCrossRoads

Interesting!

http://hackaday.com/2014/10/24/ftdi-screws-up-backs-down/

PhillyNJ

If anyone is interested, I posted a quick tutorial on how to Un-Brick the FT232RL if it was bricked.

https://www.youtube.com/watch?v=RZH_qGautqM

SteveThackery

EDIT:
I found a fix right here:
http://forum.gsmhosting.com/vbb/f684/octopus-box-not-detect-1865577/#post10597099

You have to download the Driver from the link there and then manually assign first the FTDI Bus and then the FTDI Port inf files. I did this and my Arduino IDE had no problem uploading a blink sketch.

I also tried my best in this short video. I hope this will help others.
Video Tutorial:
https://www.youtube.com/watch?v=SPdSKT6KdF8


Fantastic - thank you!  Also, thanks - of course - to the guy who made the video.

joemcder

I have found that I have 2 styles of Nano clones. 

Type #1 are labelled "Arduino Nano" which is improper but typically Chinese.  They worked before but are now dead.  Apparenlty they have the counterfeit FTDI chip LABEL.  Of course a customer (me) has no way of knowing that the chip is counterfeit.  FTDI has recklessly disabled user equipment.  Lawyers should profit handsomely from this infantile blunder.

Type #2 are labelled "DCCduino".  They use a 3rd party USB chip called "CH340" from the vendor "WCH".  These nano boards are unaffected and continue to work. You have to download & install their driver.
 
http://javacolors.blogspot.com/2014/08/dccduino-usb-drivers-ch340-ch341-chipset.html
http://www.wch.cn/downloads.php?name=pro&proid=5  (chinese site - use translate to english)

balu646

You must modify the downloaded Ftdi Driver :
http://www.heise.de/hardware-hacks/news/foren/S-FT232-Reaktivierung/forum-287246/msg-25996390/read/

This article is mine ! Ftdi has modified the own actual driver to disable Chinese Fake Chips !
The driver is changeing the Chips PID to 0000 instead of 6001 so you must change the Inf File for port and Bus , after this you must uninstall the drivers in Device Manager with connected FT 232 ! Before reinstalling the modified driver you have to disable your Internet Connection, otherwise you download the infected FTDI drivers from windows update. The Pid modified driver will appear now as a uncertified Drive, you must agree to install ! You can try to change after theis the pid back to 6001 but after repowering the board the Ft 232 will be reinstalled and the pid will be reset to 0 (zero) so FT Prog is unable to see the FT232 !

ideafires

Right Click My Computer->Manage->Device Manager
 
Select FT232R -> Right Click-> Properties
 
Click Update Driver
 
Select "Browse my Computer for Driver Software"
Click "Let me pick…."-> Click Next
 
Click Next
 
Click Have Disk.
 
Click Browse
 

Navigate to Where you have installed Arduino (c:/Windows32/Arduino)
 
Select FTDIBus.inf and click open.
 
Click Ok
 
Select USB Serial Converter. Click Next. Do yes for any warning.
 
 
One part is done.
 
Select USB Serial Port-> Right Click->Properties->

Click Update Driver
 
Select "Browse my Computer for Driver Software"
Click "Let me pick…."-> Click Next
 
Click Next
 
Click Have Disk.
 
Click Browse
 

Navigate to Where you have installed Arduino (c:/Windows32/Arduino)
 
 Select FTDIPort.inf and click open.
 Click OK
Select USB Serial Port.Click Next. Do yes for any warning.
 That's it . You are done. Arduino got Life. 

bluejets

Looks like the move away from FTDI may be under way......one mob at least.

http://www.ebay.com.au/itm/XTWduino-Nano-V3-0-ATMEGA328P-Moudle-New-f-Arduino-No-USB-Cable-Improve-Board-/271672650185?pt=AU_B_I_Electrical_Test_Equipment&hash=item3f40f3a9c9

Looks like WCH CH340....

http://wch-ic.com/product/usb/ch340.asp


Dr_Quark

I think I've tried every solution I've been able to find in the forum
  • got an earlier version of the drivers (2.10.00) and auto-installed
  • did the manual install
  • used FTDI's CDM removal tool and then manually installed again
  • used MPROG 3.5, but it doesn't see the Nano even though there is an FTDI (with exclamation point) listed under "other devices"
  • attempted another manual install of 2.10.00 (64 bit), but now, after getting through the first step and seeing the "usb serial port (with exclamation point)," updating the driver manually gives me the blue screen of death (twice)


The code on this particular Nano's FTDI chip is 1403 (I've seen the post that says 1408 is the real chip). My symptom is, I plug in a Nano, the drivers load (eventually) and I program it. I need t make a change, but the next time I plug it in to the laptop, no drivers can be found. I assume that what happens is, the drivers load the first time, see the fake FTDI chip, write 0000 to the EPROM, but since the drivers are loaded it works. But when it is plugged in the second time, the drivers see the 0000 and won't load.

Can anyone help me get MPROG 3.5 to see the Nano and undo the soft brick? Is there another way to get the ID fixed?

If you want an idea of how miffed I am about this, if I don't get a satisfactory program in a Nano, I don't have a heater control and it's going to be 14 degrees F tonight. Maybe I can get a scumbag from FTDI to spend the night turning the heat on and off.
Dr.Quark

ChilliTronix

the nano has an ICSP header, you could program it via that if you have an uno and SD card reader.

Dr_Quark

Questions:

1. Does the IDE recognize that you want to program via the ISCP?

2. How does the Uno fit in this loop? I have two Uno's and five Mega's. I'm only reluctant use them because I don't have a board for them that has the few extra screw terminals for the sensors and control relays.

3. The SD card reader might be a problem. I have same, but currently no way to access the pins in the socket, if that's what's required.

If the Uno can bail my Nano's out, that would be great. Just point me to a tutorial on the hookup.
Dr.Quark

ChilliTronix

You can use an Uno to program the nano Via ICSP but to get a program onto it you have to make the hex and copy it to an SD card that will fit in a reader you can read from your Uno.

Nick Gammon has an ICSP programmer here. The article is aimed at loading onto a 328P stand alone but the nano is based on the 328P so that may well work.

Dr_Quark

Thanks much, ChilliTronix. I will look into that later. I'd like to rescue my 20 or so Nano's, if possible.

For now, I've decided to bail from the Nano and use some of my Pro Mini's and breadboards. Sucks, but it's otherwise going to be cold tonight.

The mini is running the program no problem. It just looks like a kludge, which it is.
Dr.Quark

ChilliTronix

The mini is a nano without the USB to serial converter on board. That said if you have 20 Nanos bring up a Linux box, say Ubuntu ans use that. No driver issues there.

XavierM

While installing some softwares and device drivers on a fresh install of windows 7 x64, some of them had problems, including usb2serial boards. Obviously the fix is quite easy and fast, but the little scare that it gives is pretty cool, I must say.

I'm creating some pcb/devices myself and I'm for sure ordering genuine ftdi chips for them, this ic is quite good and price is not that high.

DEAFBOY

I have two Nano here. It was succesfully updated, but cannot flash the compiler. It says, Serial port 'COM25' already in use. Tried with 'Arduino Nano w/ ATmega168' and 'Arduino Nano w/Atmega328'. Same error. The tutorial has not solved my problem. I'll throw Nano in the trash. I don't know what to do with that. :'(
I'm deaf.

www.christian-elektronik.de

Go Up