Go Down

Topic: Unable to get FT232R drivers loaded under Windows 7 64bit (Read 201692 times) previous topic - next topic

liuzengqiang

I have two Nano here. It was succesfully updated, but cannot flash the compiler. It says, Serial port 'COM25' already in use. Tried with 'Arduino Nano w/ ATmega168' and 'Arduino Nano w/Atmega328'. Same error. The tutorial has not solved my problem. I'll throw Nano in the trash. I don't know what to do with that. :'(
I'm keeping them for the future when I get a rework station. Then I can remove its MCU for other uses or replace its ftdi chip with a real one or equivalent compatible chip from another manufacturer.
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

druid442

hi !

i ran the same issue... i didn't read all the posts because there is a lot of them, so........

here is my part of it.....

i use pro-mini along with FTDI 232RL, i had the same issues...... the drivers of W7 sets the FTDI chip PID to 0000, making them completely dumb and useless......

to solve this big thing you need to edit the 2 inf file (ftdiport and ftdibus) and sets the PID to 0000, then, reinstall the drivers manually....... then use Mprog 3.5 with the default FDTI232RL file and upload it.... this way, you will resets the PID to 6001, and it will work again....... but, there is a but,,,,, don't unplug it ! if you do so, W7 will re-sets it back to 0000...... i'm now working on a way to definitively solve this problem on w7

this is a commum issue......... don't worry

eric


druid442

i forgot.......

you can still use it with the PID set to 0000 (with the modified inf file)....... let me double test this possibillity if there is no overflow error on the comm

have a nice day

druid442

hi !

***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***

here is what i came up with......

what's happenning :

W7 drivers sets the FTDI232RL chip PID to 0000, and the FTDI drivers no longer works. as far as I know, this is due to conterfeith chips, so get rid of them right away !

kind of solution ;

unplug FTDI card
edit ftdibus.inf and ftdiport.inf (2 files), search all PID_6001 and replace all with PID_0000, save
plug back FTDI card
manualy update the drivers using those 2 tweaked files
restart W7

you can do that for as many card you have, they are all going to work

wont work in WinXP :-(

***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***
***THIS IS ONLY FOR TEST PURPOSES !!! DON'T ALTER FTDI DRIVERS ***

Dr_Quark

Did you find that you had to do this every time you changed to a new Nano or unplugged and plugged back in the same Nano, or was the fix persistent? Was it also persistent if you shut down Win7 and restarted?

If it's not persistent, making a Linux machine into a Nano programmer seems like a better solution (which I need to do when I get aroundtuit.)
Dr.Quark

akis_t

Later edit:

As it turns out the problem is caused by counterfeit chips, I must delete the workaround procedure I have found, because altering device drivers is contrary to the FTDI license agreement.

If you have such a fake chip, please contact the seller for reimbursement.
Under old European law, you can reverse engineer and modify any code which is running on your device and is preventing something from working. This allows big corporations, state and private, to hire programmers that can hack commercial or custom software, simply to "get it to work". This is all anecdotal of course, do your own research, and so on.


druid442

hi !

to answer Dr_Quark question, yes, you need to do it everytime a ftdi2323rl is plugged/unplugged, whatever you restart or not...... why ?????? because everytime you plug a FTDI232RL, the drivers ckeck for a conterfeith chip........ if this is so, it sets the PID to 0000 thus, making them useless.

the only permanent solution is to edit both files and set the PID to 0000, then, any future usage will be ok since the driver can locate the required files for it to work.

and again...... please..... this information is given for educational purposes use your common sense

any questions are welcome

TheDruid!!!

bratwurst

Same problem here. But it's odd. Same setup, same Nano, same system. I wrote some code to test it out (Just the example "Blink" sketch that I modified a bit, just for fun.) Worked on Sunday, On Monday, the Nano was STILL connected to USB, was STILL blinking, but when I try to download another script I found the Nana now had "No Driver Found" on my Windows 7 Pro system (64 bit.) I didn't change ANYTHING. My system suddenly could identify a port for the Nano. Tried everything I could try, including removing the current driver (FT232R), downloaded the newest version and installed it; no go. I did a full registry clean, rebooted, installed the new driver again and ... no go. I went back to a Windows Restore Point when it worked (From quite a while back, but I had another Nano I'd built a project with,) and ... no go.

This is MADDENING! It makes no bloody SENSE! I checked to see if Windows had done an upgrade in the meantime, but no, it didn't. I did a Windows Update and found some update to the USB "system" (Sorry, I didn't take note nor remember just what that update actually was) and that TOO didn't work.

I'm completely at a loss. All I can think is "Poltergeist" or "Wicked Leprechauns" have invaded my house and this system. Just makes no bloody sense...

bratwurst

To: druid442,

I tried to follow your "guide" for this problem, and it was a bust. I think where I got "stuck" were two things. First, I changed those two files (ftdibus.inf and ftdiport.inf) in the directory

 "C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers"

Frankly, I don't know if this is the right location for those files; my system has three MORE of these files in the directories

"C\Windows\System32\DriverStore\FileRepository" and sub directories that are too long to read or to write here such as "ftdbus.ing_amd64_neutral_5616c9aa1fc2a73" -- "gibberish."

And then you said to "manually install the FTDI driver," using those .inf files I modified. But the driver download from FTDI is an .exe and ... I just don't know whether I changed the right files, and how to integrate those modified files into the FTDI driver install. So I did the best I could, but it just didn't work; same problem. Can you elaborate, detail, what I did wrong and what I should be doing instead? Thanks.

bratwurst

Oh and also, I tried to modify those two files in those "gibberish" directories, but wasn't "Authorized" to modify them. I tried it using the text cmd window (using "vi,") in Administrator Mode, but still, it won't let me write to those files.

elrondemon

#100
Jan 07, 2015, 12:10 am Last Edit: Jan 07, 2015, 12:17 am by elrondemon
Guys, I managed to fix the problem on Win7 X64 with Arduino Nano V3.0 and FT323R driver problem.

Basically the solution is:

1) In device manager right click on the FT323R unrecognized driver -> properties -> driver -> update driver -> "browse my computer..." -> "let me pick from a list..." -> next (staying on "Show All devices") -> Have disk... -> point it to: C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers\ftdibus.inf -> next -> Accept all "untrusted stuff..."....

Wait this to finish (will take a long while).

2) Once its done, in device manager, the unrecognized FT232R will become unrecognized USB Serial Controller.
Make all the steps above on this one BUT (!) this time point it to:
C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers\ftdiport.inf

Wait again. Hopefully, this time it will be assigned as some COM.

Good luck,
Alex

SheepRustler

Yup, Works for me too! BUT you have to follow the instructions EXACTLY. I had to RMB on the offending device in Device Manager and uninstall to get the same menu options. It had'nt worked until I did that.

Thanks Binary Jim !

Poor show FTDI for punishing those of us unknowingly with fake chips. I'll be avoiding FTDI loaded products from now on.....

 

I have just had this problem too.

It was working fine on windows 8.1 for the last month, then all of a sudden. Missing Drivers problem.

I got the drivers from FTDI and re-installed using the .inf files and the .EXE installer.  No difference.

I was left with a missing UART Driver.

(This Works for Me, try it at own risk.)


To fix it I got the drivers in normal format with the .INF files.  Extracted the zip.

From ControlPanel->Device Manager

Locate the missing UART driver.  Right Mouse, Update Driver, Browse Computer -> Let Me Pick->Have Disk->Select the Location of the drivers  (port.inf ) and OK.

Now you have a list of drivers to pick from.  Choose the USB Serial Converter. OK

After that Another Missing Device Will appear, or Should, if it doesnt then this isnt going to work and uninstall the driver you just picked.

Repeat the above steps and install the USB Serial driver

This should now work.  If it doesn't go an uninstall those drivers by right clicking the device and uninstall in driver manager.

MS must have done something to cause this in an update as this was fine a few weeks ago, hope this helps some of you having the same problem.


NStorm

I've encountered the same problem after connecting my FT232 adapter to the Windows host (used on Linux in past). I've downloaded latest driver from FTDI site and installed it. At first connection it worked fine, but after reconnecting the deviced wasn't recognized. I've didn't read this thread back then and didn't know that the driver rewritten my device PID.

But I've fixed it easy way without modifying drivers. I just went to Windows (7 x64) device manager, opened unknown device and manually picked the driver from the list of already installed. First you need to pick from the Category 'USB host'->FTDI->FTDI USB host or something like that. I'm not sure how exactly it was called, I was picking from what it was offered. It warned my it might not work fine, but installed the driver. After that new FTDI USB Serial Port device appears. Following the same procedure on manual picking the driver, I've selected from category of COM/LPT Ports->FTDI and picked FTDI USB Serial Port. After that my adapter started to working fine.

Interesting thing that at 1st under Win7 I've tried to install FTDI USB Serial Port driver on first unknown device directly (without USB host part first) the device and the COM port appeared. But it wasn't working, telling me that the COM port are busy.

Thats is because FTDI driver consists of 2 parts - first you'll need to install USB Host Driver, which will add another device - USB Serial Port. Which is our virtual COM port indeed.

Later, after I've read this thread, I've found ftdi_eeprom and ft232r_prog under Linux and used them to "fix" my eeprom VID back to 0x6001.

Roadracer

I solved problem. Here is how I did it!

- extract .zip file and when windows asks you for drivers you show this folder. System will now install driver. It will report some missing driver for port but don't bother if you can find Serial port 0000 in USB Controler (Device manager).
- download FTDI programator install & run program and press F5. Computer will find FTDI chip. Go in Device descriptor >> VID PID and change 0000 number to 6001. Write data to chip.
- Now disconnect and reconnect and windows should install correct drivers.

Hope it helps.

subsix

Also this solution under linux, work's fine:

http://binefa.cat/blog/?p=80

bye

Go Up