Go Down

Topic: Unable to get FT232R drivers loaded under Windows 7 64bit (Read 189210 times) previous topic - next topic

shayo

BTW, This is the response I got from SainSmart, which isn't very useful:

Thank you for your reply and sorry for the late response because I have asked for leave.

According to the details you provided, we assume that it is the driver/software product instead of the problem of the board itself. We are sorry that we don't have a way to resolve such kind of problem as the software we run is also Arduino software.

Sorry for the inconvenience. Please contact us again if you need further assistance.



Indyaner

#46
Oct 06, 2014, 03:22 pm Last Edit: Oct 06, 2014, 04:24 pm by Indyaner Reason: 1
Just in case people are to lazy to read everything:
A potential Fix was just posted in the last post of Page 3!
(http://forum.arduino.cc/index.php?topic=270175.msg1909690#msg1909690)

I tried my best in this short video. I hope this will help others.
Video Tutorial:
https://www.youtube.com/watch?v=SPdSKT6KdF8

evildave_666

There is useful information in this FTDI app note regarding cleaning out older (or newer) driver versions and working with alternate PID/VID numbers.

http://www.ftdichip.com/Support/Documents/AppNotes/AN_107_AdvancedDriverOptions_AN_000073.pdf

brucemellen

It appears some FTDI laser etched FT232RQ QFN chips with 1410-C as the code are similarly adversely affected with the 2.12 driver.  I bought a handful from Shenzhen China for a board I made - although the Alibaba seller stated they were authentic (I now think not).  I'm wondering about all those other USB to serial boards made in /sold from China - where these knockoffs originate.

CrossRoads

www.tinyosshop.com I think got burned by that a while ago, and now take pains to get authentic chips. My boards from them work with FTDI driver 2.12.0.0 under Win7 Pro and Win8.1
http://www.tinyosshop.com/index.php?route=product/product&product_id=600
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

NanoBotics

I also have a SainSmart Nano, with the same problem. The solution in the video worked for me, however rather than downloading the drivers from the site mentioned, I just pointed the driver location to the .inf files in the original Arduino IDE installation ,FTDi driver folder.

GlueMoses


Just in case people are to lazy to read everything:
A potential Fix was just posted in the last post of Page 3!
(http://forum.arduino.cc/index.php?topic=270175.msg1909690#msg1909690)

I tried my best in this short video. I hope this will help others.
Video Tutorial:
https://www.youtube.com/watch?v=SPdSKT6KdF8


I have a couple of panSticks with a similar chip (version 1403-C).

The solution provided by Indyaner worked perfectly for my setup.

Thanks a lot!

USBDriverExpert

Hi Guys,

There is no reason to throw out your old hardware with counterfit FTDI chips. You just need to purchase a standalone programmer. Check out this one https://www.tindie.com/products/Earth_People_Technology/the-visiport2-compact-arduino-programmer/. It uses a legitimate FT232RQ chip, has selectable 5V/3.3V power, and has selectable Arduino reset RTS/DTR.

santosh0705

Hi All,
I'm the latest victim of these counterfeit chip   =(

I contacted FTDI and they replied this is a counterfeit chip without showing any evidence  :P

I'm sharing here how I managed it to work again.

Once you connect the counterfeit chip in Windows 8 or Windows 7 with drivers from windows update or the official driver it will first detect the device and re-write the PID to 0000. After that it will not work at all and it will be detected as an unknown device. You can't change the PID in the .INF files in the official driver, it won't work.

The workaround:

You need a Windows XP system or a Windows XP virtual machine running in a Linux or MAC system. Please note that it won't work in Windows 7 or Windows 8 VMs because it will detect the device as unknown device and it will not allow it to attach it to the virtual machine. I had Mac and it happily allow it to attached to the Windows XP virtual machine. Run your VM or the Windows XP system and attach the USB device to it.

Download the official driver for Windows XP from FTDI site, extract it and edit both the .INF files. Find and replace all 6001 to 0000. Now this modified driver will work with your counterfeit device in Windows XP. Update the drivers from device manager for the counterfeit chip.

To program the PID back to 6001 you need to download M_Prog or FT_Prog utility from FTDI website. Download any one of them and run it. Scan and Parse for the devices. It will show the device attached to your VM or the System. Now change the PID back to 6001 and reprogram it.

Dont connect it to Windows 8 or Windows 7 system now. First delete any existing driver from your system, there is a utility available in FTDI site to remove old drivers. Second find any old FTDI driver from internet, just google it, you will get few links. Disable your internet connection in your system and now connect you device and update the drivers from the downloaded driver. The device will work happily with the old driver.

Still I'm finding a way to disable the eeprom write in counterfeit chip  :smiley-mr-green: if someone know please share.

Thank you.

Ward123

The fix posted at page 3 solves the unrecognized driver problem, but when I upload any sketch, it gives me the error that the COM port isn't accessible?

error message when uploading:
Code: [Select]
         System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: ser_open(): can't open device "\\.\COM3": Access is denied.

rocketdoc57

I too cannot even get windows to recognize the drivers. It says drivers no found, and I am looking right at the ones you are saying should work. I cannot communicate with my nano ver. 3.0 It seems to be running the "blink" program when I plug it in to the USB cord. I tried erasing, and uploading thinking it was just a quirk, but, I cannot get it to communicate with the nano at all.

I am getting really frustrated, and literally P.O'... can someone help before I pull the las few strands of hair I have left on my poor bald head???? ;-)


Thanks....

MallocArray

@RocketDoc57

Did you follow the directions from this video exactly?
https://www.youtube.com/watch?v=SPdSKT6KdF8

You may have the official drivers downloaded, but you have to use the "Pick from a list" prompt and point to the driver folder to manually pick the "USB Serial Converter" and then the "USB Serial Port" to have it work.

In my case, it had changed from COM3 to COM4.  Once I had the drivers loaded correctly, I could go into the COM4 entry in Device Manager, then go to Port Settings>Advanced and you can change the COM port. I changed COM4 to use COM3, even though it showed it was (In Use) but assigned it anyway.  Then I could upload new programs on COM3 like I had been, and when I unplugged the Arduino, the COM port goes away in Device Manager.

rocketdoc57

I thank you! I did not see the video link, and I followed it and it is working fine!!! My compliments,a nd thanks millions!!!

Palomar

I've been able resurrect two of my Nano's using Indyaner's workaround video (Thanks!).

On a third Nano however, my system goes to BSOD every time right after I click Yes in the Update Driver Warning box. The blue screen error is PAGE_FAULT_IN_NONPAGED_AREA.

Any suggestions?

liuzengqiang

Just to add myself to the list of victims. I think FTDI should prevent fake chips from working but altering them is over the limit of just protecting themselves, it's hurting others and their own names. I didn't know some of my stuff have counterfeit chips and how should I? But now they are not going to work thanks to FTDI's little selfish act. I'll switch away from them in my future designs and use other chips. Their chips are neither cheap nor robust. The counterfeits are probably all going on arduino boards. So if we move to other chips, we'll leave FTDI to defend its own little territory like a kid in a play ground. Nobody cares about you FTDI?! I'll go with some reputable dealer that has some TI chips or other companies. Hate their SSOP-only packaging anyway. Bad for prototyping. Thanks for helping me make decision to stay away.
Serial LCD keypad panel,phi_prompt user interface library,SDI-12 USB Adapter

Go Up