Go Down

Topic: Unable to get FT232R drivers loaded under Windows 7 64bit (Read 209849 times) previous topic - next topic



Unable to install drivers

Steps toward Resolution:

connected arduino uno r3 to computer ( windows 7 64 bit) with a USB cable

Device did not install sucessfully ( as predicted by the guide step 4
'install the drivers' of arduino.cc/en/Guide/Windows )

One of two possibilities is given by the instructions.
1. 'Arduino UNO (COMxx)' is under the ports ' Ports (COM & LPT)'
2. under 'Device Manager' --- 'other Devices' --- there is 'Unknown Device'

My case is the latter. and it seems the instructions only assume the first.
Therefore it seems i am unable to continue with the instructions.

Nevertheless, i attempted to 'update driver software' and install the drivers
from my arduino file directory. but this was not sucessful.




How are the chips counterfiet? this makes no sense. i bought this project at a radio shack. not on the black market????


yeah. it sucks. seems like there's no solution, but to take the Make:it Robotics Starter Kit back where you bought it.


How are the chips counterfiet? this makes no sense. i bought this project at a radio shack. not on the black market????
All it takes is one slip-up or dishonest staff, anywhere in the supply chain, for counterfeits to sneak into ostensibly reputable products.


Same here.  :'(
Not able to connect to the Arduino Nano.
Tryd everything I found here on the forum. Nothing worked.

New chipset for USB to Serial converter.
Found new driver here:


Installed this one and everything oke.

Nice instalation of the com-port.


So, let me get this straight, you fixed this not by software, but by sending away to russia for a microcontroller specific to this project??

And it cost 300 rubies? I don't know the exchange rate. At this point I think I'd like to return the product from where i got it. I wish I could contact someone under the Arduino employ who could explain or resolve my dissatisfaction, but i'm not sure that is possible.


No, I ment, er was a new chipset on my Nano-board.  :smiley-roll-blue:

So simply, change the drivers in Windows.


Reference SUBSIX's post (#104). It does not work for me. When you go to the link, the Linux commands are:
Code: [Select]
$ sudo apt-get install make gcc libftdi-dev
$ wget http://rtr.ca/ft232r/ft232r_prog-1.24.tar.gz
$ tar -zxvf ft232r_prog-1.24.tar.gz
$ cd ft232r_prog-1.24
$ make
$ sudo ./ft232r_prog -old-pid 0x000 -new-pid 0x6001
  (note: the dash in front of "old" is really a hyphen, but inside the "code" box it
   displays as a dash

The last line always gives me the error "unrecognized arg: "-old-pid""

The problem turns out to be the dash in front of the words "old" and "new". This is not a dash (en-dash), it's a hyphen (em-dash). The actual command line should use two dashes and is:
Code: [Select]
$ sudo ./ft232r_prog --old-pid 0x000 --new-pid 0x6001

This is a "feature" of some word processing/editing programs which automatically converts two en-dashes to a hyphen. If you go to the author's web page for ft232r_prog, it has the same error. The original author's page is:


Bottom line, I've unbricked 5 of my Nanos and can now use a handful of PCBs, instead of converting everything to Pro Minis.


Hi Guys - its not only Win 7 64 bit but also Win 7 Ultimate 32 bit system that won't install FT232r USB UART drivers; I have tried all combinations of options available on FTDI site a number of times, including latest recommended methods and also older driver versions - nothing works as it should with all resulting in failures and I have simply given up having wasted several long days trying to resolve this issue!!
I get the big green ticks for the VCP and Com port drivers during installation but then when you try to update the actual drivers for each board in Device Manager by pointing to the folder where the driver files are supposedly installed they always fail!
My adapters include "genuine boards" from Sparkfun and separately from sainsmart (of which the latter I am not sure about how legit this company is as I have experienced a number of different problems in using this company - none of which were satisfactorily resolved by them - in fact the latest problem was simply ignored by them repeatedly asking the same questions despite me supplying all the required details/answers until after about 10 attempts I finally gave up in disgust???) so if the FTDI chip problem relates to use of the alleged fake FTDI chips then some "big companies" have some pretty big explaining to do! Seems like there is something very incidious going on here since so many people are having the same problems????
My only work-around at the moment is to not use this type of board for my XBEE / Uno projects, a real pain in the but and this has just forced me to order several (non-FTDI) boards that I know do work!
The other main problem with the FTDI Driver installation is that you are supposed to notate the path where the files are installed but the latest FTDI procedure produces an exe file for the driver installation and you have no way to identify where this finally installs the drivers as it is too quick to observe during running the exe installation file!
So if anyone can point me to where the FTDI drivers actually are installed in Win 7 Ultimate 32 bit during driver installation I will be very grateful. I rather suspect this issus is going to get much bigger before it is resolved! Please also note that these drivers are not visible or identifiable in Windows/System32/Drivers folder!!
Cheers Ian


If it is genuine FTDI chip, an updateto-date win system (vista/7/8) will be able to download proper driver from contacting Microsoft via the internet and install proper driver. You don't even need admin's password for this auto install. If yours doesn't install, it's probably a fake.

Spark fun got fake ATMEGA chips before and even sold them as practice chips for smd soldering. I think they ultimately discontinued selling them because it is below decent business practice to sell anything fake. I've been burnt by fake chips mostly from arduino nano boards I bought from eBay and another website. What I bought from digikey and mouser work just fine. I also got modules from modern device and spark fun. So far no fakes from them in my hand.


I was having same problems as mentioned. New nano, drivers failed to load in windows.
Tried downloading new drivers, same result.
Unplugged the nano from the IO shield and everything worked correctly.
Supplied stable 6v to power IO shield, everything worked correctly.


old drivers work's for me. don't forget to uninstall new drivers, and never use windows update to avoid upgrade.

just before, do:

$ sudo apt-get install make gcc libftdi-dev
$ wget http://rtr.ca/ft232r/ft232r_prog-1.24.tar.gz
$ tar -zxvf ft232r_prog-1.24.tar.gz
$ cd ft232r_prog-1.24
$ make
$ sudo ./ft232r_prog --old-pid 0x000 --new-pid 0x6001


Hello, I have a duemilanove with the same problems (FTDI fake chip).

I followed the video https://www.youtube.com/watch?v=SPdSKT6KdF8 that was posted in previous pages,
and finally achieved in downloading program to the arduino, but it does not work!!!

Should this be another surprise from FTDI?

Has a same situation happened to anybody?


Get a genuine FTDI chip (FT232RL) from reputable vendor (mouser in USA). Find a friend with hot air rework station. Replace chip. Keep fake chip for soldering practice. That's pretty much what I did. And I now own a rework station myself.

Go Up