Go Down

Topic: Nano ft232r error, worked till today :( (Read 14849 times) previous topic - next topic

highflier

Oct 02, 2014, 12:03 am Last Edit: Oct 02, 2014, 05:23 am by highflier Reason: 1
This is so frustrating,  I have many Arduino boards.  Mostly Nano's.  I have been using them on both win7 and win 8.1.

Today Oct 1.  2014 Many of them just stopped being recognized by my computers.   Thus some work and some do not.  On both win 8.1 laptop and on win 7 desktop.

When a good one is connected it makes the beep, and connects as  com port XX in the computer device manager.
When a bad one is connected it makes the beep (on win 7 a bad beep) and the device manager show it as
Other Device
        ! FT232R USB UART     (obviously not working)

It's like the driver just expired, and that there is some internal difference to the units.

Anybody else seen this issue?
Any insight to the cause, besides my wild guess.
Any idea's on solutions.


Before it is suggested,  I have been using the latest 8.1 drivers (signature is valid for win 8) and have tried uninstalling a failed unit, then reinstalling it and it just say no driver found for the device.  Yet the good ones continue to work.

So far it has been Nano's that have not worked.  Uno, mega and 3 of my Nano's still work.

I did a search and only found 1 thread that sounded the same, it was on in French,  I used Google translator on the page and no real suggestion has been found yet.

A customer had bought a bunch of Nano's it seems like they are the ones that died,  I probably got one of his in my stack.


Highflier



jormc

Hi there!

I have 3 arduinos: 2 of Nano and a Mega 2560. I never have had problems with they, and I was programming them for a long time. Now I'm getting an issue with all they, and seems to be near to your problem: "COMXX port is in use, acces denied". Or now, I can't update the drivers, because a strange matter, the Windows 7 64b doesn't regonize it...

That I've seen, there are a lot of people with this same problem, searching and not getting any true solution...

I'm going to subscribe to this post, I very interested in look for a solution, I'm very frustrated..  =( =( =(

Thanks!

PD: sorry for my little Englis, I hope you can understand me...

Jordi

highflier

Update and more info.

I have not seen post beside me that have some that work and some that do not. 

I have 4 total board in my hands right now.  3 have red pwr led and 1 has green pwr LED.  All worked until recently.  Now only the red led ones work.  The other can not load the driver and do not get assigned a com port when plugged in.  A close study shows a slightly different FTDI chip,  In fact from what I have read on the internet (Must be true)  Both type of mine have counterfeit FTDI chips,  although only one type has started fail.

The second line on the FTDI chip reads
1308     Failed unit
1346    Working unit


What I read is that read FTDI are laser etched and the counterfeits are printed on.

I am still very confused on why it had worked and now is failing.  I even did a system restore and set the date back a month.  The was working unit is still a was working unit.

Highflier


danielmc

Hello:

I have the same problem with arduino nano.
On 30 setember work ok,  on 1 oct. is detected:  FT232R USB UART.

Please, anyone know what the problem is ?

Lo que trato de decir es esto:
Hasta el día 30/09 andaba bien,era detectada correctamente.
Luego el 01/10 ya no anda, se muestra como que no está instalado el driver.
(el arduino funciona pero no se puede programarle nada porque no está instalado el driver, es detectado así:  FT232R USB UART.)

Probe en dos pc distintas con win 7 y win 8.

Yo crei que la había arruinado mientras hacia unas prueba, pero buscando otros drivers me encontré con este comentario
en el foro, justo igual que mi problema.

Alguien sabe como solucionar este problema ?

highflier

Sorry no answers yet.  It appears a chip on the board is no longer compatible.

I will post when a solution is found.. in this thread

Good luck


Indyaner

I have the same problem. ALL my Arduino Nanos are now recognized by Win7 x64 as FT232R USB UART in the device manager.
If I try to assign the (old) driver to it again, he sais, that he could not find the correct driver for this device. What is going on?

I'm kinda pissed that something behind the scenes changed my system in a way that I'm now locked out from using my Hardware that worked last week without problems. Why is this happening to all of us? Was there a windows update or what?


Indy

evildave_666

FTDI's 2.12 driver (which started this behaviour) was pushed to Windows Update last week.

Indyaner

#7
Oct 06, 2014, 11:45 am Last Edit: Oct 06, 2014, 04:26 pm by Indyaner Reason: 1
Thanks evildave. I just saw that other thread:
http://forum.arduino.cc/index.php?topic=270539.0

I guess I have to disable windows updates when they force stuff like this.
Is there a chance to roll back to an older FTDI Driver manually or do I have to throw away all my Microcontroller?

PS: For people who came here because of a searchengine:
You can also read about it here:
http://forum.arduino.cc/index.php?topic=270175.0

EDIT:
I found a fix right here:
http://forum.gsmhosting.com/vbb/f684/octopus-box-not-detect-1865577/#post10597099

You have to download the Driver from the link there and then manually assign first the FTDI Bus and then the FTDI Port inf files. I did this and my Arduino IDE had no problem uploading a blink sketch.

I also tried my best in this short video. I hope this will help others.
Video Tutorial:
https://www.youtube.com/watch?v=SPdSKT6KdF8

evildave_666

There is some driver modification that can be done, but doing so violates the license agreement.

Alternately, use Linux for programming, the serial drivers for FTDI are kernel-builtin.

Otacilio

I'm with exactly the same error. The problem occurs on a Win81. and FreeBSD.

Aconolly

#10
Oct 09, 2014, 04:29 am Last Edit: Oct 09, 2014, 05:05 am by Aconolly Reason: 1
I too have the same issue. They worked before and now both my nano's cant be programmed. I guess i will try the suggested fix but this is crazy. Almost wanted to buy a non FTDI board cause of the issue.



Edit after trying fix:

It worked! Thanks a million! if only I found this earlier I could of used my two days off wisely instead us cursing at my computer  :smiley-roll-sweat:

MallocArray

Agreed that the Video Tutorial link got me going as well.

spruce_m00se


Ladybug

#13
Apr 24, 2015, 11:57 am Last Edit: Apr 24, 2015, 12:01 pm by Ladybug
I have got the exact same problem that highflier is describing in the first post.
So I have tried the solution in the video from Indyaner, to manually assign the FTDI Bus and then the FTDI Port inf files.

Unfurtunately, when I try to assign the FTDI Bus, my laptop crashes completely (with a blue screen!). The error message is "PAGE_FAULT_IN_NONPAGED_AREA".
This happens right after I select "USB Serial Converter" and press enter to continue (see 2:22 of the video). I have got an Arduino nano and Win 8.1.

Does anyone how to solve this? Any help is much appreciated!
Testers don't break software, they dispel the illusion that it was not broken.

fedey2k1

Hello everyone!

I have the same issue, I install the bus with no problem, but when I continue the install of the port, the computer reboots right away.

Any suggestions?

Thank you...

Go Up