Go Down

Topic: Hilfe bei Mosfet und Schaltung (Read 2387 times) previous topic - next topic

LX_Thunder

Hallo Leute, kurze Vorstellun:
Bin seit ca einem Jahr mit Arduino unterwegs, bin Maschinenbauer und habe bisher wenig mit Elektronik gemacht.
Mein neustes Projekt gibt so ne Art Drink Dispenser.
Breadboard funktionierte tadelos, aber die Platine macht Mucken.
Im Prinzip ist es ein Shift Register, welches 8 Mosfets ansteuert. Auf dem Breadboard hatte ich die 10 K Pulldowns diekt am Sachieberegister, auf der Platine hab ich sie an das Gate der Mosfets und dann zum nächsten Mosfet an Source. Dachte das ware ne gute Idee, da die auch auf Masse liegen.
Nun schalte ich aber ein, und es sieht so aus als würden alle Gates kurz ein HIGH bekommen, bevor das Programm startet. Das hat zur Folge dass alle Motoren anlaufen und die Spannung für den Nano zusammenbricht.
Hab ich da jetzt Blödsinn zusammengelötet, bitte habt Nachsicht, ich bin echt Anfänger. Im Anhang mal ein Foto und das Platinenlayout nur mit der Stromversorgung.

Danke im Voraus

LX_Thunder

#1
Oct 27, 2014, 08:59 pm Last Edit: Oct 27, 2014, 09:09 pm by LX_Thunder
Sooo.
Die Antwort hab ich von woanders, finde aber threads sollten nicht offen bleibem.

Man muss auf alle Fälle den Pin 13 (OE) des Schieberegisters schalten. Ich hatte diesen fest auf GND und deswegen sind die Ausgänge aktiv. Ob 0 oder 5V kann man nicht vorhersagen.
Wenn man den aber über einen Pull-Up nach 5V zieht, dann sind die Ausgänge hochohmig und der Pull-Down am Gate wirkt.
Dann muss man nur noch, nachdem der Arduino oben ist OE woeder auf Low setzen.


Go Up