Go Down

Topic: SOLVED - Eagle: Including an Arduino as a component (Read 2623 times) previous topic - next topic


Hi all

I've already prototyped my circuit on stripboard and want to try my hand at producing my own PCBs using the toner transfer method.

I'm a newb at Eagle but have created some new libraries, components, packages, and have finished working on the layout of my first board.

The board uses a Nano as a component in its own right, and to do this I created a library out of the Eagle file for the nano by running exp-project-lbr.ulp.

However autoroute is refusing to connect any wires up to the nano pins.

After messing with the layout for hours it still didn't work, so did some basic testing using Adafruit's Eagle library for the Arduino Uno.

The schematic had two "components": the Uno, and an LED. The Uno refused to autoroute too!

Am I going about this all wrong? Should I set up a "dumb" package that just has the footprint for the Nano instead of including my generated library?


Nov 03, 2014, 02:48 am Last Edit: Nov 03, 2014, 03:37 am by hazymat
Okay so I've created a custom package from scratch with exact Nano measurements and it's still not routing! Air wires are showing on the board view, showing that the package is setup correctly (also I checked custom package has pads and holes, named correctly, and with pin names that correspond to schematic view) - but it refuses to autoroute my package. Strange thing is, I can simply draw a manual route (in a really obvious place) and Eagle accepts it, the air wire disappears when connection is made!

Even more annoyingly if I use a 32 pin IC package and connect it up pretending it's an Arduino this routes perfectly fine.

What on earth am I doing wrong? - Or rather, what things can I check I've done correctly?


Check your grid settings.
View:Grid set to mil
Tools:Autorouter, set Routing Grid to 2, or 1, mil.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


Thanks. Changed all my autoroute grid settings but still no connections.

As mentioned before, I tested this with a bare arduino with one LED and tonnes of space around the board and still didn't route...


Figured it out. Somehow I had created drill holes in the pads, which was preventing the part from routing.

No idea how, I didn't do this manually but must have hit a setting on each pad that created them or something. These holes were on layer 20.

Removed the holes, and it routes like a dream!

Go Up