Go Down

Topic: Arduino Mega 1280 support package for Simulink - Connecting problems (Read 1 time) previous topic - next topic

marcosmoura

Aug 17, 2014, 05:41 pm Last Edit: Aug 17, 2014, 06:09 pm by marcosmoura Reason: 1
Hello, I was using arduino target and it was working with the 1280 but now I need to use the realtime.tlc for target hardware because I have realtime needs. There is a problem connecting to my arduino atmega1280. I am using Matlab 2014a and I downloaded the support package.

It seems to only work with mega 2560 board but for sure there is something I could do to make it work with the 1280 if anyone knows and could share.


I get the following error:
Quote
The call to realtime_make_rtw_hook, during the entry hook generated the following error:
   Could not automatically set the host COM port for your Mega 2560 board. This may be due to a disconnected or unrecognized board.

If the board is not connected to your host computer, connect it and let Windows install the board driver.

If the board is connected, update the board driver. Open Windows Device Manager and locate the board either in Other Devices or in COM Ports. Right-click on the board and select 'Update Driver Software...' Next, select 'Browse my computer for driver software'. Specify the search location as C:\MATLAB\SupportPackages\R2014a\arduino-1.0.5\drivers and click 'Next'.

If Windows still cannot automatically set the COM port for your board, set it manually. In your model, click 'Tools', click 'Run on Target Hardware', and click 'Options...' In the dialog that opens, change 'Set host COM port' to 'Manually' and the set the 'COM port number' to match the port number in Windows.

The build process will terminate as a result.

Could not automatically set the host COM port for your Mega 2560 board. This may be due to a disconnected or unrecognized board.

If the board is not connected to your host computer, connect it and let Windows install the board driver.

If the board is connected, update the board driver. Open Windows Device Manager and locate the board either in Other Devices or in COM Ports. Right-click on the board and select 'Update Driver Software...' Next, select 'Browse my computer for driver software'. Specify the search location as C:\MATLAB\SupportPackages\R2014a\arduino-1.0.5\drivers and click 'Next'.

If Windows still cannot automatically set the COM port for your board, set it manually. In your model, click 'Tools', click 'Run on Target Hardware', and click 'Options...' In the dialog that opens, change 'Set host COM port' to 'Manually' and the set the 'COM port number' to match the port number in Windows.



My COM driver is working, it works with arduino IDE and arduino.tlc target.

Do I have to change some file, edit some parameters ? Making it believe it is a 2560 board ? What can I do ?


This is the  older support package that works and I was using, It has options to choose the boards and everything, something that I dont see the newer versions supporting... I would use this one but sadly it does not work with the real time code generation setting..
https://www.dropbox.com/sh/wqvdanfxifjlkxo/AAAKmCgN7p2H-HnMcpW8pUoBa

Izzy92

post this on the MATLAB forum. You will get much more help

Go Up